Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-01-2008, 02:15 PM   #1
Senior Member
 
PizzaGuy's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Lompoc CA
Posts: 139
I bought my 2007 Diplomat in April of this year. It was used but only had 3200 miles on it. We have been on several small trips and for the most part, everything has worked.

In preparation for our next trip where I will probably have to use the inverter, I thought it would be a good idea to check it out. It has a Magnum ME series inverter/charger. The remote control is version 1.2.

I do not get any ac voltage, the battery charger isn't working either. On the inverter it self, the green led is flashing very rapidly. On the remote control, all 4 led's are lit and the message screen says version 1.2 connecting. The soft buttons all work but the inverter on/off and charger on/off do not do anything.

I tried to reset the inverter but no change. I have called Magnum but they are closed today. I have been following this forum for a while and it looks like there is always someone who has experienced problems such as this in the past. Thought I would give it a try and see if you guys and gals can help me.
__________________
Don & Carol Croner, FMCA- F401447
2007 Monaco Diplomat PDQ 40
2017 Buick Envision, US Gear Tow Brake
PizzaGuy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-01-2008, 02:15 PM   #2
Senior Member
 
PizzaGuy's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Lompoc CA
Posts: 139
I bought my 2007 Diplomat in April of this year. It was used but only had 3200 miles on it. We have been on several small trips and for the most part, everything has worked.

In preparation for our next trip where I will probably have to use the inverter, I thought it would be a good idea to check it out. It has a Magnum ME series inverter/charger. The remote control is version 1.2.

I do not get any ac voltage, the battery charger isn't working either. On the inverter it self, the green led is flashing very rapidly. On the remote control, all 4 led's are lit and the message screen says version 1.2 connecting. The soft buttons all work but the inverter on/off and charger on/off do not do anything.

I tried to reset the inverter but no change. I have called Magnum but they are closed today. I have been following this forum for a while and it looks like there is always someone who has experienced problems such as this in the past. Thought I would give it a try and see if you guys and gals can help me.
__________________
Don & Carol Croner, FMCA- F401447
2007 Monaco Diplomat PDQ 40
2017 Buick Envision, US Gear Tow Brake
PizzaGuy is offline   Reply With Quote
Old 09-01-2008, 04:19 PM   #3
Senior Member
 
Happycarz's Avatar
 
Monaco Owners Club
Join Date: Sep 2007
Location: Scottsdale, AZ
Posts: 2,307
When you said you reset it, is that at the inverter itself? If not, there are two buttons on the side of the inverter that pop out when tripped. Just pust them, or the one, back in to reset it. I'm just trying to help by covering all bases. If this is what you have already done, please disregard.
__________________
Harry

2008 Monaco Camelot 40' PDQ
Happycarz is online now   Reply With Quote
Old 09-01-2008, 04:57 PM   #4
Registered User
 
SacsTC's Avatar
 
Monaco Owners Club
Join Date: Nov 2006
Location: Sacramento, CA.
Posts: 846
Don,
Here are the meanings for the flashing led:
Green LED Indicator
∑ Medium flash (1 every 2 seconds)
Indicates connected loads are being powered from the batteries (inverting).
∑ Fast flash (1 per second)
Indicates search mode, conserving power when appliances are switched OFF.
∑ Solid
Indicates bulk charge when the batteries are low and the inverter is connected
to shore power.
∑ Fast flash (1 per second)
Indicates absorption charge when the batteries are almost fully recharged and
the inverter is connected to shore power.
∑ Slow flash (1 every 8 seconds)
Indicates float charge when batteries are fully charged and the inverter is
connected to shore power.
∑ LED off
Indicates a fault condition such as low battery, overload or over temperature.
There is also a green flashing led on the auto gen start panel.
The inverter powers all the plugs in the bathroom, the kitchen, the entertainment center, tvs, the plug down by the floor on the console and the outlets in the basement. The plugs on the drivers side by the table and the two by the bed are powered by gen or park power.
The bathroom plug has a gfi and if it is tripped, you will think you have no power as that one gfi is the beginning of all the inverter circuit. Make sure that is not tripped. And as Harry already stated, there are circuit breaker buttons on the inverter itself that may be tripped as well.
SacsTC is offline   Reply With Quote
Old 09-01-2008, 05:37 PM   #5
Senior Member
 
Robin_M's Avatar
 
Monaco Owners Club
Tiffin Owners Club
Join Date: May 2007
Location: SE Pennsylvania
Posts: 1,850
Blog Entries: 2
Don,

Unplug the coach from shore power. Turn off both battery switches in the battery compartment, and disconnect the telephone cord on the side of the inverter that leads to the remote display. Cycle the circuit breakers on the front of the inverter. Wait 15 minutes, plug the remote back in and then turn on the battery banks. If you get the same results, you likely have a faulty inverter. If the coach is out of warranty, I'd call Magnum. There may be a longer warranty on the inverter itself.
__________________
Rob.......Links to coaches below
New (to us) 2016 Tiffin Allegro Bus 45 OP
2017 & 2007 Monaco Diplomat Sites
Robin_M is offline   Reply With Quote
Old 09-02-2008, 09:26 AM   #6
Senior Member
 
PizzaGuy's Avatar
 
Monaco Owners Club
Join Date: Aug 2008
Location: Lompoc CA
Posts: 139
Thank you all. I tried to reset the remote and also the inverter again. The inverter would not shut off.
Magnum tech support returned my call and they are sending me a new circuit board for the inverter. It has a three year warranty. They gave me the same procedure that Robin suggested. Thanks again.
__________________
Don & Carol Croner, FMCA- F401447
2007 Monaco Diplomat PDQ 40
2017 Buick Envision, US Gear Tow Brake
PizzaGuy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter ??? Rocket Heart Winnebago Industries Owner's Forum 5 07-02-2008 06:10 PM
Inverter Latitude Newmar Owner's Forum 8 09-09-2007 04:42 AM
Inverter SacsTC Monaco Owner's Forum 9 07-02-2007 04:13 AM
Simple Inverter Hook Up? Plug my 50 amp to the inverter? E Z Livin MH-General Discussions & Problems 7 12-19-2005 02:59 AM
Inverter jmccrack Winnebago Industries Owner's Forum 11 04-28-2005 04:09 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.