RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-12-2013, 10:08 AM   #1
Senior Member
 
Dupdyke's Avatar
 
Join Date: May 2012
Location: Roseville MN sum / La Feria Tx winter
Posts: 790
Isl 400 ecm codes

Does anyone have a good list of the pre 2003 Isl 400 ecm codes. I have checked the online google sites and can not find a decent list. I run vmspc and my rig showed a half dozen codes in a 5 min time line. None of them are in the list i can find online. I took coach to coach care cummins and they checked it and think they found a bad ground connection at the front elect run bay. They checked and then cleared all codes and told me drive it awhile and see if any come back.

Different issue does anyone know the pid to get the real oil pressure and not a constant 55 lbs? I called silverleaf and was informed that it is a cummins ecm issues until about 2008s and it is really a on off value and they just use 55 as a its ok reading.
They told me that my codes are PROBABLY a result of a floating electrical voltage ( bad ground usually) and correct ground and drive it and see what it reports.


thanks
__________________

__________________
Sheri & Don 2003 Dynasty 42" regal ISL 400
2007 Goldwing Trike Gmc 4X4 w/ autoloader for trike
Lets go we got it all loaded.
Dupdyke is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-12-2013, 03:15 PM   #2
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 15,299
I can't help on the codes, but my VMSpc gives my correct readings on oil pressure on my 05 ISL. It idles at about 30 and runs up to around 60 while driving.
__________________

__________________
Don & Mary
2019 Newmar Dutch Star 4018
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 09-12-2013, 05:43 PM   #3
Senior Member
 
onechaddude's Avatar
 
Join Date: Jul 2011
Posts: 1,862
Quote:
Originally Posted by Dupdyke View Post
Does anyone have a good list of the pre 2003 Isl 400 ecm codes. I have checked the online google sites and can not find a decent list. I run vmspc and my rig showed a half dozen codes in a 5 min time line. None of them are in the list i can find online. I took coach to coach care cummins and they checked it and think they found a bad ground connection at the front elect run bay. They checked and then cleared all codes and told me drive it awhile and see if any come back.

Different issue does anyone know the pid to get the real oil pressure and not a constant 55 lbs? I called silverleaf and was informed that it is a cummins ecm issues until about 2008s and it is really a on off value and they just use 55 as a its ok reading.
They told me that my codes are PROBABLY a result of a floating electrical voltage ( bad ground usually) and correct ground and drive it and see what it reports.

thanks
My 07 Neptune with Cummins isb engine always reads 55.0 or 55.5 lbs. pressure according to scanguage D. I'm curious to see what others may say would cause it.
Chad
onechaddude is online now   Reply With Quote
Old 09-12-2013, 06:43 PM   #4
Senior Member
 
Dupdyke's Avatar
 
Join Date: May 2012
Location: Roseville MN sum / La Feria Tx winter
Posts: 790
Tech at silverleaf tells me that the pre fuel rail isl and isb ecm just put out value of 55 if there is more than 5 lbs oil pressure so the stop eng light does not come on. The dash oil guage has a separate sensor and it does not route thru the ecm
__________________
Sheri & Don 2003 Dynasty 42" regal ISL 400
2007 Goldwing Trike Gmc 4X4 w/ autoloader for trike
Lets go we got it all loaded.
Dupdyke is offline   Reply With Quote
Old 09-12-2013, 07:16 PM   #5
Senior Member
 
onechaddude's Avatar
 
Join Date: Jul 2011
Posts: 1,862
Quote:
Originally Posted by Dupdyke View Post
Tech at silverleaf tells me that the pre fuel rail isl and isb ecm just put out value of 55 if there is more than 5 lbs oil pressure so the stop eng light does not come on. The dash oil guage has a separate sensor and it does not route thru the ecm
That's good to know I figured one of the oil pressure sensors was kaput. Thanks for the info.
Chad
onechaddude is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×