Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-20-2020, 05:15 PM   #1
Junior Member
 
Join Date: Jan 2020
Posts: 12
Maxxforce 10 fuel delivery

2011 Monaco knight.
17000 miles
Maxxforce 10

Following up on my other thread “yet another shudder” about a vibration I was having with my coach, today I did a test ride with Dion International out of San Diego. They connected the laptop to monitor real time what the engine was doing while driving (we did this with the transmission too but all was good and the engine was suspected anyway). What showed was a couple ‘active’ codes that otherwise came up as ‘previously active’. They were:
Cylinder #4 balance max limit exceeded
and ICP sensor.

They plan at this point is to do a CPA test that they say will let them know for sure where the problem is (i.e. cylinder 4 injector vs 3 or 5 etc)

The shudder only happens under load at roughly less than 1500 rpms. Anything electrical I believe would be intermittent at any time and not just under load. In this way I agree that an injector could be the issue. The interesting part is that at 1300 miles in 2011 (brand new) the original owner had this exact code and injector 4 replaced as per Internationals record keeping. I know that its been 8-9 years but its only been ~ 15000 miles and while I know that coincidences happen this makes me wonder...

Has anyone had this code? Anyone fixed it themselves? Thoughts appreciated.
Grizz_ly is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-20-2020, 07:02 PM   #2
Junior Member
 
Join Date: Nov 2019
Posts: 24
I have worked on a few of these engines and have found Terminal Dusting is an issue at times. If you disconnect the injector connector there will be this very fine dust inside the connector the isn't getting past connector seal from the out side. Its forming from terminal fretting internal to the connector. It will cause the concern you are having and only under certain conditions based on fuel pressure and injector loading. The current draw on injector has to be just right and it will cause the miss from poor connection. I didn't see it often but never hurts to have them check for it.
cafeguy is offline   Reply With Quote
Reply

Tags
fuel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MaxxForce 10 Low Pressure Fuel Pump died. Dennis_K Navistar MaxxForce Engine Forum 1 09-29-2017 09:58 PM
Maxxforce 10 primary fuel filter replacement GoldRabbit Navistar MaxxForce Engine Forum 1 02-17-2015 11:06 AM
Maxxforce 10 Fuel filter Service Question robertj1979 Navistar MaxxForce Engine Forum 7 10-06-2014 09:17 PM
2011 Monaco Knight MaxxForce - fuel mileage check YellowZonker Monaco Owner's Forum 4 02-23-2012 07:28 PM
fuel line delivery kaptkronos MH-General Discussions & Problems 4 12-30-2008 01:15 PM


All times are GMT -6. The time now is 11:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.