Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-06-2014, 09:35 PM   #15
Junior Member
 
Join Date: Jan 2014
Posts: 14
We had the same problem with ours right after we bought it last year (a 2004 Diplomat) and the circuit board was shot. We contacted the manufacturer and they told us to replace it. It would get hot but only cook for 59 seconds. We purchased a new one a new one from Home Depot - Whirlpool and took it to Camping World to get installed.
rblackwell is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-07-2014, 04:37 AM   #16
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: Foley AL
Posts: 7,124
Quote:
Originally Posted by Lincolnut View Post
Well folks a great big Thank You again.......I got the parts today and spent an hour putting it back together and IT WORKS........Heated water for 1 min & 11 seconds first then 1 min & 30 seconds then went and got the DW and cooked some Popcorn for 2 min & 34 seconds with out any problems........

Now I just got to put it back up in the hole tomorrow and the DW will be happy and I will have one more thing fixed before we head to Florida next month.............

THANKS again.......

Mike
Awesome !! ... thanks for the followup.
__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Old 05-05-2014, 07:49 AM   #17
Senior Member
 
Lincolnut's Avatar
 
Join Date: Mar 2013
Location: Artesia NM
Posts: 136
Well folks I guess this fix did not stay fixed.......Just got back from a 3600 mile trip to Florida and back to NM & the microwave worked for 2 days then we are now back to the 59 second thing.....Not a very happy DW for sure.....

.Now this piece of equipment is going out the window in exchange for just a plain working Microwave.....

Did I do something wrong in the fix? or did the fix just not work? I don't know but after removing it one time and fixing it I don't want to do the same thing and get the same results...........

Mike
Lincolnut is online now   Reply With Quote
Old 05-05-2014, 08:34 AM   #18
Senior Member
 
Join Date: Aug 2007
Location: Roaming Fulltimer
Posts: 406
Sorry to hear that. I replaced the damper motor and switch on mine last Sept and it is still going strong.

RV.Net Open Roads Forum: FIXED! - Sharp R-1870 Conv/Micro shuts off after 59 seconds
tkcas01 is offline   Reply With Quote
Old 05-06-2014, 09:07 AM   #19
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 46,716
Way to go Mike!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Pointe Microwave/Convection Oven Bobgray Winnebago Industries Owner's Forum 18 09-30-2016 12:13 PM
Dometic Wedgewood Oven Pilot Light Problem NomadBD Travel Trailer Discussion 2 02-20-2014 07:50 PM
Microwave/convection oven replacement Rusty years RV Systems & Appliances 13 01-24-2014 05:38 AM
Microwave oven srnnelson RV Systems & Appliances 10 01-16-2014 07:54 PM
Apollo half time oven replacement rca RV Systems & Appliances 0 01-08-2014 11:57 AM


All times are GMT -6. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.