Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2009, 09:06 PM   #1
csp
Senior Member
 
csp's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Posts: 183
Monaco dash vent and window defrost

I have a 95 Monaco Dynasty. The dash does not switch from vent to window defrost. It seems like it stays somewhere between. I can take out the center drawers and manually move it from vent to the window by moving the door linkage. The temperature control works fine but it is run by cable not vacuum. I took apart the dash controller and I could not get any vacuum to any of the lines going to the switches. I looked around at the vacuum lines in the front of the coach but I could not diagnose the problem. Has anyone run in to a problem like this? I could take it to a shop but if it is something I can fix I would rather do it myself.
Thank You for any help.
Chris
__________________
Monaco Dynasty
csp is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-09-2009, 09:29 PM   #2
Senior Member
 
mfire1339's Avatar


 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Jun 2008
Location: Glendora Ca.
Posts: 1,524
csp,

I believe you have a vacuum pump forward of dash. Default operation should be defrost= no vacuum though.

Mike
__________________
2004 Monaco Monarch
Blueox, SMI, 1990 Wrangler YJ
mfire1339 is online now   Reply With Quote
Old 12-09-2009, 10:07 PM   #3
Senior Member
 
GOLDWINGER2's Avatar
 
Vintage RV Owners Club
Fleetwood Owners Club
Join Date: Dec 2009
Location: CA
Posts: 1,198
You have a vacuum leak. Double check all rubber/ plastic hoses. Had the prob on mine, took me a while but i found the leak. It was very small.
J
GOLDWINGER2 is offline   Reply With Quote
Old 12-10-2009, 07:24 AM   #4
Senior Member
 
hardy1000's Avatar
 
Monaco Owners Club
Join Date: Feb 2009
Posts: 1,495
I had my vacum pump fail and had to replace it because it started with the same problem that you are describing. After looking for a leaky hose I finally found the pump in the front generator compartment and it was covered with spray foam, (you might have to dig it out like I did to find it). The vacum pump on mine had one of the hose inlet stems broken, so I replaced the pump and it was a ford part and was a warranty part from Monaco so I don't have the cost.

Good luck
__________________
Del & Lori 2007 Diplomat 40PDQ - 2020 Grand Cherokee TrailHawk Hemi Toad, M&G Brake System, Blue Ox.
hardy1000 is offline   Reply With Quote
Old 12-11-2009, 08:09 PM   #5
csp
Senior Member
 
csp's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Posts: 183
Thank you for the advice
I will try to find a leak and then check the pump if I can find it. I will post the results.
Chris
__________________
Monaco Dynasty
csp is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cutting wall & Installing new window go44 Travel Trailer Discussion 11 11-18-2017 02:49 PM
Installing Crankout Sect. of Window Chickadee Newmar Owner's Forum 18 09-26-2009 08:17 AM
Window Vent Question azstork Monaco Owner's Forum 5 05-24-2009 08:58 AM
engine noise in dash tofran Winnebago Industries Owner's Forum 5 09-18-2008 05:20 PM
Garmin mounting - vent - beanbag - windshield or other? ctcamper Technology: Internet, TV, Satellite, Cell Phones, etc. 5 06-22-2008 09:19 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.