Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-17-2022, 08:54 AM   #15
Junior Member
 
Join Date: Apr 2022
Posts: 12
Quote:
Originally Posted by Mr.Mark View Post
What you are explaining happened to me when my RED HAT valve failed on my '08 Dynasty. I mentioned it above in post #4.

Safe travels,
Mark
Mark, I took your advise tried tapping it but no luck. I guess I will order one and try that. Thanks
Jrb7911 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-17-2022, 08:59 AM   #16
Senior Member
 
pduggs's Avatar
 
Monaco Owners Club
Join Date: Mar 2014
Location: Somewhere Nice
Posts: 1,399
Quote:
Originally Posted by Jrb7911 View Post
Thanks Paul. I have all valves set just like in your picture so were good there. I emptied the fresh tank and plugged into city water with the autofill switch in the down position and its just filling the fresh water tank. Very slow stream coming out the faucets. The autofill switch has a red light on and shuts off when I flip it to the middle or up. It continues to fill in all positions. Any other ideas? Appreciate all the help guys.
If itís filling in all positions thatís a problem. As guys have said the Red Hat valve may be the culprit. It is located by the water pump behind the Manabloc. Itís light green with a red hat design on it. I took mine off and took it apart. There is a membrane that goes bad or is dirty. I had a thread on it a few years back. You might search for it under my screen name. Or search ďRed Hat.Ē
__________________
2008 Monaco Dynasty Squire
Paul & Luci
pduggs is offline   Reply With Quote
Reply

Tags
monaco, monaco dynasty, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monaco Dynasty :: 2000 Monaco Dynasty Regent Timaz iRV2 Owners Registry 0 06-03-2018 11:47 AM
Monaco Dynasty Barron III :: 1997 Monaco Dynasty Barron III ctmdr iRV2 Owners Registry 0 01-17-2018 09:52 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.