RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-03-2014, 12:59 PM   #1
Junior Member
 
Join Date: Apr 2013
Posts: 28
No turn signals

Sorry wrong thread

This one has me Last time I had the trailer behind the coach my turn signals stopped working.

Flashers work, all fuses I can find for the lights are good and clean and show power. What i can't find /figure out is if the flashers use a diffrent flasher relay than the turn signals.

I have checked under the dash and can only find one flasher relay and it works when the flashers are turned on. This is driving me crazzy as I don't like not having turn signals towing or not.....

36' 1999 Holiday rambler Endeavor
rockwrangler is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-10-2014, 10:20 PM   #2
Senior Member
 
Robi.1014's Avatar
 
Monaco Owners Club
Freightliner Owners Club
Join Date: Oct 2009
Location: Arlington, VA
Posts: 921
My rig's schematic shows a 20-amp fuse for "Hazard Flasher", and two 15-amp fuses, one each for left and right turn signals. I'll keep looking, but these circuits are documented over several different pages (tough to follow this late at night!!).

So the inference is that the rear turn (and flasher) lights have a common electrical path to the rear of the coach, but at the electrical bay (up front), there are different relays and fuses serving these similar functions.
__________________
Robi & Dale ---- Go Navy ----
2016 Winnie TOUR 42'
Tow: '08 Buick Lucerne
Robi.1014 is offline   Reply With Quote
Old 01-11-2014, 07:34 AM   #3
Member
 
Monaco Owners Club
Join Date: Jun 2013
Location: Orange Park, Florida
Posts: 69
does the coach turn signals work or just the trailer not working?
Quicktree is offline   Reply With Quote
Old 01-11-2014, 07:51 AM   #4
Senior Member
 
mrv8outboard's Avatar
 
Tiffin Owners Club
Join Date: Jul 2011
Location: Cape Cod
Posts: 348
If the unit is based on a Ford chassis it is most likely the multifunction switch. You can try WD-40, remove disassemble and clean or new.
mrv8outboard is offline   Reply With Quote
Old 01-11-2014, 02:55 PM   #5
Senior Member
 
CJScepter's Avatar
 
Monaco Owners Club
Join Date: Sep 2008
Location: McCleary,wa
Posts: 366
On my 2003 HR the turn signals and flashers are different, they use different coach taillight assy's. I once had the left turn on the toad quit working, but all worked fine on the coach. Looked a long time on this one and finally replaced coach left turn bulb(that was working!) it fixed the problem???? I didn't argue with success!
John G.
__________________
John and Cherrie
2003 Holiday Rambler Scepter 40DST
Pushed By 2003 Ford Explorer
CJScepter is offline   Reply With Quote
Old 01-12-2014, 09:25 AM   #6
Senior Member
 
joeplazek's Avatar
 
Join Date: Jul 2011
Location: CAISTOR CENTRE
Posts: 638
There is a row of relays in the engine bay. I had problems with the spades loosing connection. Just wiggled them and on came the signals. On mine the front signals still worked although.

joe
joeplazek is offline   Reply With Quote
Old 01-13-2014, 09:58 AM   #7
Junior Member
 
Join Date: Apr 2013
Posts: 28
I have been all over this thing and cannot find the turn signal relay. The hazzard lights all work when the flasher switch is pulled so I would assume there is a fuse or relay that I'm missing some where. ERRR

Thanks for the help
rockwrangler is offline   Reply With Quote
Old 01-13-2014, 10:19 AM   #8
Senior Member
 
Join Date: Jan 2013
Posts: 104
Turn flasher different from 4 ways, may be in somewhere around or above steering column, get down there with flashlight and look around, feel around? Good luck! LT.
ltfishin is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.