RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-02-2013, 06:51 AM   #1
Senior Member
 
Join Date: Apr 2010
Posts: 195
Oil Pressure gauge question

Hello Group,

Trying to help a neighbor. He has a '03 Windsor. The oil pressure analog gauge reads erratic, either correct, then "0" and then full scale. Like a loose wire?

The Aladdin shows the oil pressure properly.

It appears the Aladdin is getting it's info off the engine data cable and the dash gauge is just that and uses a oil pressure sender separate from the data cable signal.

Is this correct? IF so, where would the dash gauge sender be located on the engine.? All the other dash gauges read properly.

Thanks Jim
'96 Sahara 3540, 300 CAT
__________________

jlb27537 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-02-2013, 08:32 AM   #2
Member
 
wizzo442's Avatar
 
Monaco Owners Club
Join Date: Nov 2009
Posts: 53
It could be a bad connection at the engine sender, but the most likely problem is the sender itself. You can try cleaning the connection at the sender to see if that works. I just had to replace the one on my '06 Cummins ISL because my guage was doing exactly the same thing. The Aladdin uses a different sender than the analog guage does, that's why it reads OK. On my Cummins, the sender WAS NOT a Cummins part. I had to get it from Monaco and I needed the engine serial number to get it. (Had to get that from Monaco also as I could not find the number on my engine, but giving them the VIN will get you the engine info). Problem fixed.
__________________

__________________
Wizzo 442
2006 Monaco Diplomat
40PDQ
wizzo442 is offline   Reply With Quote
Old 02-02-2013, 09:01 PM   #3
rex
Senior Member
 
rex's Avatar
 
Monaco Owners Club
Join Date: Jan 2001
Location: Foley, AL
Posts: 1,247
Jim there are two oil pressure sensors on the engine. One is screwed into the engine and the ECM is connected to that one.

The dash gauge is connected to the sensor that is located somewhere around the oil filter. It is in a slightly different position depending on the engine. It will have either one or two wires (both types were used depending on Monaco or gage requirements). See the picture for what to look for.
Attached Thumbnails
Click image for larger version

Name:	Oil sensor.jpg
Views:	52
Size:	52.7 KB
ID:	32966  
Attached Images
  
__________________
Rex

2001 Monaco Diplomat 40' PDQ - 08 Honda CR-V
rex is offline   Reply With Quote
Old 08-10-2013, 10:14 PM   #4
Junior Member
 
Join Date: Jul 2013
Posts: 1
I replaced the oil pressure sensor on the side of the engine and the gauge is still reading on the high side.I will look for the other sensor near the oil filter.THANKS!!!!!!
bigblue81 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×