Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2021, 01:12 PM   #1
Senior Member
 
dbircky's Avatar
 
Monaco Owners Club
Solo Rvers Club
Coastal Campers
Join Date: Mar 2020
Posts: 586
Power Gear/Valid Air Fault

Last evening, after having all six rear tires replaced, the Valid Air panel is showing a fault, rapid flashing of both power and travel buttons and a single red dot in for the right rear wheels. The dot is the one closest to the driver. If I hold the travel button down, the vehicle display shows all green lights. The MH looked level sitting in their parking lot. Additionally, the parking brake light didnít immediately go off when that brake was released (stayed on for two or three minutes). After shutting off the engine, I pulled the fuses fir the system and turned off both chassis and house battery circuits. Everything looked fine, all 10 bags inflated, no sound of leaking air with 110 lbs in both tanks. Restarted and headed down the road. Within 2 miles the alarm was going off and the same fault showing. Will be heading back to the shop, but wondering if any experts with this system have an idea what happened. Iím guessing a sensor or something got knocked off, but canít reconcile in my mind why the fault doesnít immediately show. Air pressure stayed over 105 psi on the way home. The shop is only 10 miles from the barn, I stopped once on the way home and cut all power again, and the same thing happened. As the entire trip is all 45 mph or less, I canít say if the active leveling is working as it should going down the road, but Iím guessing not as it will not engage the auto mode when parked. Any ideas?

2009 Monaco Camelot 42pdq with Power Gear/Valid Air (factory installed) air only leveling.

I contacted the tire shop this morning, they are sending me (at their expense) to a local HDT service company for diagnosing/repairs. Does anyone know if OTR trucks run a similar system? I don't have a pit to get underneath to clearly see all the parts.


Thank you.
__________________
2009 Monaco Camelot 42PDQ
2011 JK
dbircky is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-10-2021, 01:22 PM   #2
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 7,905
Only thing I can suggest is a reboot of the Valid system. Hold power button down for 10sec till it beeps.

Could be your parking brake switch is failing also.
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is online now   Reply With Quote
Old 06-10-2021, 03:25 PM   #3
Senior Member
 
robertj1979's Avatar
 
Join Date: Oct 2012
Location: Charlotte, NC
Posts: 192
I had a similar problem a couple of years ago. I contacted Valid tech support and they suggested the control pad needed to be replaced and is a common problem with Monaco. Cost was around $300. Tech guy advised the controller frequently has moisture problems and circuits go bad because most of them are improperly located close to the window on the Monaco. Simple plug and play five minute installation and have not had a problem since. Mine was on a 2012 so if yours has never been replaced would suspect it could be the problem. It is possibly related to the tire change but just thought would mention that if you have a problem in the future or no other issues found. I do not believe OTR trucks would run that system and mine is an air only level system also.
__________________
Robert and Marisa
2012 Monaco Knight 40 DFT
2012 Jeep Rubicon
robertj1979 is offline   Reply With Quote
Old 06-10-2021, 05:15 PM   #4
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 3,702
You may have a couple issues, but from your description, your nason switch needs replacing. If the "PARK" light doesn't come on and go off within 5 seconds of pushing or pulling your brake plunger, replace the switch. It's mounted on the brake plunger.
Just dump all the air in the system before removing the switch.

https://www.uatparts.com/freightline...fsc-1749-1907/
__________________
Bill & Brigitte
06 Windsor PEQ, Cummins 400 ISL
2014 Honda CRV
windsorbill is offline   Reply With Quote
Old 06-11-2021, 12:12 PM   #5
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 3,702
woops, I put wrong link in above for the nason switch. This is what I have in my coach.

https://www.radwell.com/Shop?source=...SABEgI-CPD_BwE
__________________
Bill & Brigitte
06 Windsor PEQ, Cummins 400 ISL
2014 Honda CRV
windsorbill is offline   Reply With Quote
Old 06-21-2021, 11:09 AM   #6
Senior Member
 
dbircky's Avatar
 
Monaco Owners Club
Solo Rvers Club
Coastal Campers
Join Date: Mar 2020
Posts: 586
Just to close out and what the problem was:

Tire installation tech somehow bent right rear air line enough to create a leak when line was under pressure. This showed as a fault when excessive air was leaking. Lines were replaced and everything is working as it should be now.
__________________
2009 Monaco Camelot 42PDQ
2011 JK
dbircky is online now   Reply With Quote
Reply

Tags
air, power, power gear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Valid/Active Air fault dbircky RV Systems & Appliances 0 06-10-2021 06:22 AM
Valid/Power gear Leveling compressor Michbill Monaco Owner's Forum 8 04-15-2021 06:18 PM
Valid Power gear leveling ken bauer RV Systems & Appliances 2 09-28-2020 09:04 PM
Power gear/ Valid air leveling Michbill Monaco Owner's Forum 5 08-18-2014 08:00 AM
Valid auto leveler fault code Oh-one Monaco Owner's Forum 1 08-13-2012 08:43 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.