RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-25-2020, 07:36 PM   #1
Member
 
Join Date: Sep 2020
Posts: 30
Relay clicking

2003 Cayman 36PBD

This just started.

When I am off shore power, no gen, no inverter, I can hear a relay clicking behind the main AC breaker panel in the overhead cabinet in the bedroom. Also, the small electrical display/control panel flickers on and off in conjunction with the relay clicking.

If I plug in shore power, start the genset or turn on inverter, the clicking stops and the control panel operates normally.

Maybe a weak or bad relay??
Socal18 is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-25-2020, 07:48 PM   #2
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 3,194
Sounds like a bad battery set.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : https://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 09-25-2020, 07:57 PM   #3
Member
 
Join Date: Sep 2020
Posts: 30
Quote:
Originally Posted by Jim_HiTek View Post
Sounds like a bad battery set.


Batteries are only a year old. Ill load test them tomorrow to be sure theyre good.
Socal18 is online now   Reply With Quote
Old 09-25-2020, 08:07 PM   #4
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 3,194
Okay, than look for a corroded terminal associated with the wiring that feeds that system.

Whack things with a rubber mallet...my favorite test tool. Then go check operation. You might have to crawl under the RV looking for wire terminals from the batts. RV's have lots of them attached to the chassis.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : https://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 09-26-2020, 06:34 PM   #5
Senior Member
 
Join Date: Apr 2018
Posts: 958
Do you have an instahot at the sink?
shootist is offline   Reply With Quote
Old 09-26-2020, 07:27 PM   #6
Member
 
Join Date: Sep 2020
Posts: 30
Quote:
Originally Posted by shootist View Post
Do you have an instahot at the sink?


No I dont
Socal18 is online now   Reply With Quote
Old 09-27-2020, 10:24 AM   #7
Junior Member
 
vidref's Avatar
 
Join Date: May 2012
Location: Canyon, TX
Posts: 24
I had this same scenario.
On a hunch, I equalized the batteries and solved the problem.
vidref is offline   Reply With Quote
Old 09-27-2020, 12:53 PM   #8
Senior Member
 
Join Date: Apr 2018
Posts: 958
Reason I asked is monaco put 3 different relays inside the 120 breaker panels, aquahot, engine heat and instahot. So pull the cover off the main panel , not the inverter 120 panel and you may see 2 relays there.
shootist is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay clicking in 1/2 bath BodieJames Newmar Owner's Forum 7 06-15-2018 05:30 AM
Clicking relay Phoelix Vintage RV's 7 12-19-2017 07:18 PM
Clicking, like a relay MIDMONDN Winnebago Industries Owner's Forum 9 06-06-2017 08:26 PM
Clicking relay ALAG321 Gulf Stream Owner's Forum 3 11-21-2010 06:48 AM
Relay clicking sound from rear of MH movin-on Winnebago Industries Owner's Forum 4 08-04-2008 02:46 PM


All times are GMT -6. The time now is 07:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.