RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-19-2015, 12:01 PM   #1
Senior Member
 
Billinwoodla's Avatar
 
Join Date: Apr 2013
Posts: 156
Side camera

Hi folks. My right sided side camera is intermittent when I put on my blinker. It might work for an entire trip, then it is a no show. The blinker works fine. I'm not great at electrical issues, but am guessing it is a ground issue or loose connection somewhere. Any thoughts on the most common spot in the circuit to check or the most problematic?
Thanks
Bill
2008 Monaco Monarch
__________________

Billinwoodla is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-20-2015, 05:25 AM   #2
Senior Member
 
ShapeShifter's Avatar


 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2010
Location: Buffalo, NY
Posts: 1,632
Start with the easy ones: check the connection where it plugs into the back of the monitor, make sure it's clean and tight.
__________________

__________________
Adam and Sue, and a pack of little furballs
2007 Holiday Rambler Endeavor 40PDQ Limited Edition - Cummins ISL 400
2013 Ford F-150 FX4 toad - USGear Unified Tow Brake, Roadmaster Blackhawk II Tow bar, Blue Ox baseplate
Home base near Buffalo NY, often on the road to a dog show
ShapeShifter is offline   Reply With Quote
Old 06-20-2015, 06:00 AM   #3
Senior Member
 
nodine's Avatar
 
Monaco Owners Club
Join Date: Jan 2003
Location: Knoxville, TN, USA
Posts: 3,637
Quote:
Originally Posted by Billinwoodla View Post
Hi folks. My right sided side camera is intermittent when I put on my blinker. It might work for an entire trip, then it is a no show. The blinker works fine. I'm not great at electrical issues, but am guessing it is a ground issue or loose connection somewhere. Any thoughts on the most common spot in the circuit to check or the most problematic?
Thanks
Bill
2008 Monaco Monarch
Occasionally I have the same problem and so far have been able to fix it by unplugging the connector in the front cap and spraying it with contact cleaner.

Bob
__________________
Bob and Pam
2006 Diplomat 40PDQ
2013 Silverado Z71 CrewCab
nodine is offline   Reply With Quote
Old 06-20-2015, 06:52 AM   #4
Senior Member
 
Mike Canter's Avatar
 
Join Date: Apr 2008
Location: Freeport, ME
Posts: 4,707
I agree with Bob. Check and clean the connector inside the front generator compartment that comes directly out of the mirror assemble. I believe the monitor has only one connection for video. The other place would be the video switching unit under the front dash.
__________________
Mike Canter
"Gunner" USN Retired, Airdale
2004 Monaco Signature 44' Conquest. Detroit 60
Mike Canter is offline   Reply With Quote
Old 06-20-2015, 08:03 AM   #5
Senior Member
 
Join Date: Mar 2012
Posts: 192
I had the same issue and it was a bad conection. Abour 6" from the camera head [ inside the mirrow arm ] is a connection. it is hard to get to.
Jim E
06 exec
bigjim8499 is offline   Reply With Quote
Old 06-22-2015, 04:36 PM   #6
Senior Member
 
Billinwoodla's Avatar
 
Join Date: Apr 2013
Posts: 156
Thanks fellas!
__________________

Billinwoodla is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Voyager Side Camera Issue Lukeaa Monaco Owner's Forum 10 08-06-2015 12:21 PM
Propane Leak from one side? dkperez 5th Wheel Discussion 17 04-24-2015 02:10 AM
Rear camera system acerv47 Technology: Internet, TV, Satellite, Cell Phones, etc. 1 09-15-2014 04:41 PM
Rear camera repair Don The Ham Winnebago Industries Owner's Forum 6 07-01-2014 10:18 PM
Power to rear camera - upgraded system 04Beast Newmar Owner's Forum 10 01-28-2014 05:07 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×