RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-06-2019, 08:19 AM   #1
Member
 
Holiday Rambler Owners Club
Join Date: Aug 2016
Location: Lansdale, PA
Posts: 64
Slide out problem

2005 Holiday Rambler Ambassador 40 PLQ

My front drivers side slide won't retract. Pressing the button produces no click or sound of any sort. Where is the fuse for this circuit? Does anyone have a link to the electrical schematic from button to motor?

Thanks
Joe
__________________

Joedarock is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-06-2019, 09:27 AM   #2
Senior Member
 
RamiDav's Avatar
 
Join Date: Jan 2016
Posts: 1,418
Other slides work ?
__________________

RamiDav is online now   Reply With Quote
Old 04-06-2019, 10:39 AM   #3
Junior Member
 
turbo700's Avatar
 
Join Date: Sep 2017
Location: Anchorage, Ak
Posts: 24
Check for power at slide motor. Mine quit working last year didn't make a sound. It was fried when I checked under rubber cover.
__________________
2004 Monaco Windsor 40 PST, ISL 400HP
turbo700 is offline   Reply With Quote
Old 04-06-2019, 11:38 AM   #4
Senior Member
 
falconman's Avatar


 
Join Date: Apr 2008
Location: On the Road
Posts: 1,159
Electric or hydraulic?
If hydraulic the fuses should be near the pump/ solenoids. Mine is under the step.
__________________
Dan & Arlene
2005 Monaco Dynasty Diamond IV
Chasing the good weather
falconman is offline   Reply With Quote
Old 04-06-2019, 01:17 PM   #5
Senior Member
 
xydial's Avatar
 
Join Date: Oct 2013
Posts: 387
Check the relays located at the top of the Battery Bay. The fuse and the four relays are in the plastic enclosure. You can switch relays by unplugging them.


If the relay clicks check the voltage at the plug on the motor.

Had a similar problem last year with the bedroom wardrobe slide and found that the wires in the connector had never been crimped when built!!
__________________
2005 Monaco Knight 40PLQ
2013 Ford Edge
xydial is offline   Reply With Quote
Old 04-06-2019, 02:40 PM   #6
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Location: UK
Posts: 535
I don't know if it was a retro fitment or from the factory but on mine the bay doors under the slides have a push switch which can sometimes stick, a quick fix is to open the door and push the switch a few times or (on mine) you can short the connections to the switch.
ElvistheKing is offline   Reply With Quote
Old 04-06-2019, 07:58 PM   #7
Senior Member
 
xydial's Avatar
 
Join Date: Oct 2013
Posts: 387
Quote:
Originally Posted by ElvistheKing View Post
I don't know if it was a retro fitment or from the factory but on mine the bay doors under the slides have a push switch which can sometimes stick, a quick fix is to open the door and push the switch a few times or (on mine) you can short the connections to the switch.
This model does not have door interlocks.
xydial is offline   Reply With Quote
Old 04-07-2019, 04:49 AM   #8
Member
 
Holiday Rambler Owners Club
Join Date: Aug 2016
Location: Lansdale, PA
Posts: 64
Fixed it!
There's a relay for the slide in the fuse compartment in the battery bay. Jiggled it and the slide began working. I'll replace the relay and spray the contacts with DeOxit just in case.

Thanks for the suggestions!

Joe
__________________

Joedarock is offline   Reply With Quote
Reply

Tags
problem, slide, slide out



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide out not all the way out on the bottom. Also, where do I find trim for the Slide harmonybrew Fleetwood Owner's Forum 0 09-04-2017 12:06 PM
Slide out topper roller rubs slide out F4Gary Class A Motorhome Discussions 2 07-07-2016 07:11 AM
Slide out cover over fridge slide out southwest 5th Wheel Discussion 8 08-21-2015 04:33 PM
WH Slide out side slide out clearence different. sumterjim Damon 2 03-24-2010 04:33 PM
Slide out is stuck out.... ciscofreak 5th Wheel Discussion 7 03-29-2007 02:12 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×