Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-23-2018, 04:26 PM   #1
srh
Senior Member
 
srh's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 1,388
Smart Steering Electrical Issue - Need Input Please!

As I alluded to in one of my earlier posts, I had some issues with my wipers and cruise control. The wipers would work once in a while and not other times. Similarly, my cruise control. I could turn it on and off, but the Set rarely worked, the Resume would work a little more than the Set, especially after driving it for a while, but not normally

I took it in to a shop (Speed Wrench in Hudsonville, MI). Make a long story short, I got charged several hours of labor plus $400+ for the Clock Spring that they replaced and was told that all worked except the Cancel button for cruise. After paying $1,100 + when I tried to drive it home nothing would work. The cruise wouldn't Set, or Resume at all, the wipers, I turned on, but would not turn off.

Took the coach back to the shop, and it has been there for over a week. I talked to the shop a couple of days ago, they told me when they try to manually trace the wiring the wipers and the cruise both work, but when they start the engine they don't work. They have contacted Monaco, and several other sources, and were told that there is a "Control" module that may be bad, but they can't get their hands on a "Control" module as no one is making it. They told me there a possible source in Australia that they are trying to contact. I haven't heard much more.

Has anyone had an issue similar to this?

Thanks in advance for your help!
__________________
2005 HR Navigator 45PBQ
Detroit Diesel Series 60 14.0L
PGA Decore & Exterior
srh is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-23-2018, 04:56 PM   #2
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 5,360
Northwest RV Supply has the control modules for the smartwheel. nwrvsupply.com: Search Results

Last week I was troubleshooting my own smart wheel problem. The troubleshooting guide from Smartwheel is pretty good. As I was testing for voltage on one of the connector pins, the wire just pulled right out of the crimp for the terminal. So fixing that connection fixed the problem. I suggest you also check yours, just grab each wire near the connector and give it a little tug.

Good luck.
__________________
Mike --- 2005 Beaver Patriot Thunder CAT C13 525HP, Vicksburg 42ft, with HydraLift ---
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 11-23-2018, 05:03 PM   #3
srh
Senior Member
 
srh's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 1,388
Quote:
Originally Posted by CountryB View Post
Northwest RV Supply has the control modules for the smartwheel. nwrvsupply.com: Search Results

Last week I was troubleshooting my own smart wheel problem. The troubleshooting guide from Smartwheel is pretty good. As I was testing for voltage on one of the connector pins, the wire just pulled right out of the crimp for the terminal. So fixing that connection fixed the problem. I suggest you also check yours, just grab each wire near the connector and give it a little tug.

Good luck.
It seems to me that something like this maybe the problem. But, I'm not the mechanic and what do I know!. I will, however, pass this on to the shop. Thanks, Mike.
__________________
2005 HR Navigator 45PBQ
Detroit Diesel Series 60 14.0L
PGA Decore & Exterior
srh is offline   Reply With Quote
Old 11-23-2018, 06:19 PM   #4
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 8,414
I had a similar problem. I had been working on the radio and when I drove the rig I had no controls.



Went in and looked and found a wire was loose on the control module, it looked like someone had tried to halfway repair it before. I soldered the pin back onto the wire and connected it back to module and everything worked. That was 9 years ago.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 11-23-2018, 07:15 PM   #5
srh
Senior Member
 
srh's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 1,388
Quote:
Originally Posted by jacwjames View Post
I had a similar problem. I had been working on the radio and when I drove the rig I had no controls.



Went in and looked and found a wire was loose on the control module, it looked like someone had tried to halfway repair it before. I soldered the pin back onto the wire and connected it back to module and everything worked. That was 9 years ago.
That is interesting as I just had my Kenwood Display replaced, first with a Jensen and then with a Pioneer. A tech did it. I'm wondering if in the process something got either disconnected or a wire broken. I will mention that to the shop and hope they follow-up. Thanks for chiming in.

BTW, Jim, would you happen to know what the control module looks like and where is it located?
__________________
2005 HR Navigator 45PBQ
Detroit Diesel Series 60 14.0L
PGA Decore & Exterior
srh is offline   Reply With Quote
Old 11-23-2018, 09:31 PM   #6
Senior Member
 
Join Date: Jul 2016
Posts: 615
The control module is a small black box with many wires and connectors going into it. On our Monaco it is located right behind the radio/stereo in the dash console.

Irishguy
irishguy is offline   Reply With Quote
Old 11-24-2018, 02:03 AM   #7
Senior Member
 
Happycarz's Avatar
 
Monaco Owners Club
Join Date: Sep 2007
Location: Scottsdale, AZ
Posts: 2,137
Many coaches have the VIP Controller module located in the bottom of left console. That is, the same console that has the transmission selector.
__________________
Harry

2008 Monaco Camelot 40' PDQ
Happycarz is offline   Reply With Quote
Old 11-24-2018, 05:30 AM   #8
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 5,360
Quote:
Originally Posted by irishguy View Post
The control module is a small black box with many wires and connectors going into it. On our Monaco it is located right behind the radio/stereo in the dash console.

Irishguy
@Irish guy,
Doesn't your control box look like the ones I linked to in the second post?

I would not call that box small. On the '05 Beaver/Monaco it's mounted in the front run/electrical bay (under driver's window). Of course it can be located anywhere Monaco decided to mount it.
__________________
Mike --- 2005 Beaver Patriot Thunder CAT C13 525HP, Vicksburg 42ft, with HydraLift ---
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 11-24-2018, 06:05 AM   #9
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 8,414
Quote:
Originally Posted by srh View Post
That is interesting as I just had my Kenwood Display replaced, first with a Jensen and then with a Pioneer. A tech did it. I'm wondering if in the process something got either disconnected or a wire broken. I will mention that to the shop and hope they follow-up. Thanks for chiming in.

BTW, Jim, would you happen to know what the control module looks like and where is it located?

Mine control module was right behind the radio maybe ~1 foot back. Close enough that when I pulled the radio out and started working on it that the wire was dislodged.


The wire was not long enough for me to easily pull it out out from under the dash to repair. I ended up buying a small battery powered soldering tool and was able to solder it while it was still tucked in the dash.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 11-24-2018, 06:13 AM   #10
Senior Member
 
Monaco Owners Club
Join Date: Sep 2013
Posts: 2,072
The VIP Smart Wheel module should be in the Front Run Bay. https://www.vipwheels.com/technical-support
__________________
2007 Monaco Signature Noble III 45' ISX 600HP
hypoxia is offline   Reply With Quote
Old 11-24-2018, 10:34 AM   #11
Senior Member
 
Join Date: Jul 2016
Posts: 615
Quote:
Originally Posted by CountryB View Post
@Irish guy,
Doesn't your control box look like the ones I linked to in the second post?

I would not call that box small. On the '05 Beaver/Monaco it's mounted in the front run/electrical bay (under driver's window). Of course it can be located anywhere Monaco decided to mount it.
Yep that's what I have as well. I guess to me I consider it small but it's all a matter of perspective perhaps. It's a about the size of an ipad.

Irishguy
irishguy is offline   Reply With Quote
Old 11-24-2018, 11:51 AM   #12
srh
Senior Member
 
srh's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Feb 2012
Posts: 1,388
Quote:
Originally Posted by CountryB View Post
Northwest RV Supply has the control modules for the smartwheel. nwrvsupply.com: Search Results

Last week I was troubleshooting my own smart wheel problem. The troubleshooting guide from Smartwheel is pretty good. As I was testing for voltage on one of the connector pins, the wire just pulled right out of the crimp for the terminal. So fixing that connection fixed the problem. I suggest you also check yours, just grab each wire near the connector and give it a little tug.

Good luck.
Mike:
Sorry, I missed this. Let me see if I get this, the control box is available through Northwest RV Supply. Is that correct?

Thanks everyone for chiming in!
__________________
2005 HR Navigator 45PBQ
Detroit Diesel Series 60 14.0L
PGA Decore & Exterior
srh is offline   Reply With Quote
Old 11-24-2018, 12:13 PM   #13
Senior Member
 
Damion's Avatar


 
National RV Owners Club
Freightliner Owners Club
Join Date: Sep 2017
Location: Rice Lake, Wisconsin
Posts: 726
I've also soldered the head light wires to my board where the plug in burnt up!
__________________
2003 National Tradewinds LTC 7374 FL XC-Chassis IFS, Steer Safe, 8.3 ISC 350 Cummins, 3000MH Allison, 2015 Equinox, Blue Ox Tow-Bar, Brake Master Air Over Hyd
Damion is offline   Reply With Quote
Old 11-24-2018, 12:34 PM   #14
Junior Member
 
Join Date: Jun 2016
Location: Boerne,TX
Posts: 5
Quote:
Originally Posted by srh View Post
As I alluded to in one of my earlier posts, I had some issues with my wipers and cruise control. The wipers would work once in a while and not other times. Similarly, my cruise control. I could turn it on and off, but the Set rarely worked, the Resume would work a little more than the Set, especially after driving it for a while, but not normally

I took it in to a shop (Speed Wrench in Hudsonville, MI). Make a long story short, I got charged several hours of labor plus $400+ for the Clock Spring that they replaced and was told that all worked except the Cancel button for cruise. After paying $1,100 + when I tried to drive it home nothing would work. The cruise wouldn't Set, or Resume at all, the wipers, I turned on, but would not turn off.

Took the coach back to the shop, and it has been there for over a week. I talked to the shop a couple of days ago, they told me when they try to manually trace the wiring the wipers and the cruise both work, but when they start the engine they don't work. They have contacted Monaco, and several other sources, and were told that there is a "Control" module that may be bad, but they can't get their hands on a "Control" module as no one is making it. They told me there a possible source in Australia that they are trying to contact. I haven't heard much more.

Has anyone had an issue similar to this?

Thanks in advance for your help!

I just replaced the Smart steering module in my 2012 Endeaver. It took about 2 months to get. RV Shop Online in Baton Rouge ordered mine .
glarredondo is offline   Reply With Quote
Reply

Tags
electric, electrical, steering



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need input on loft model/ heartland please! Karen_Rocco 5th Wheel Discussion 3 04-25-2017 06:26 PM
I have AC Input with 110 but not with 50 or 30 amp input Bluefoot53 Country Coach Owners Forum 15 06-27-2016 09:57 PM
Is Countertop Smart Oven electrical load an issue? DGBPokes Newmar Owner's Forum 4 02-11-2016 01:03 PM
smart visor vs power smart visor tncruiser Class A Motorhome Discussions 3 11-05-2010 11:28 PM
I need some input from you folks...please DonnaP iRV2.com General Discussion 18 09-04-2007 02:44 PM


All times are GMT -6. The time now is 10:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.