RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-25-2014, 12:29 PM   #1
Senior Member
 
JRPA's Avatar


 
Monaco Owners Club
Join Date: Aug 2008
Location: Las Vegas
Posts: 287
Trim ark keypad doesn't work.

The Trimark remote key fob locks & unlocks the entry door and all cargo doors. The keypad handle lights up but the keypad doesn't seem to be working. The doorbell button doesn't do anything nor do any of the touch buttons. The buttons on our keypad are numbered 1 through 4 so I assume the code must likewise be numbers from 1 to 4 but all the reset codes I have seen had bigger numbers.

I found the control box in the compartment next to passengers seat but it didn't have a reset button so I unplugged the power connection and plugged it back in and still nothing.

Any suggestions on how I might be able to get the keypad on door handle working would be appreciated.
__________________

__________________

Bob & Pearl
www.youtube.com/justpassingthru
2007 Monaco Camelot 42' PDQ
JRPA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-25-2014, 12:55 PM   #2
Senior Member
 
38 Special's Avatar
 
Monaco Owners Club
Join Date: Aug 2010
Location: Irondale, Alabama
Posts: 470
I had to replace mine when it quit working like yours. I called Trimark direct and they were great. Also sent me a relay and wiring instructions to change the wiring to something they approve. They said Monaco got the power from a place that was not acceptable and they felt this contributed to the failures.
__________________

__________________
2008 Monaco Camelot 42 DSQ
Irondale, Alabama
38 Special is offline   Reply With Quote
Old 11-25-2014, 01:31 PM   #3
Senior Member
 
JRPA's Avatar


 
Monaco Owners Club
Join Date: Aug 2008
Location: Las Vegas
Posts: 287
"I had to replace mine when it quit working like yours"

What did you replace? The keypad or control box?

Thanks for the info

Bob
__________________

Bob & Pearl
www.youtube.com/justpassingthru
2007 Monaco Camelot 42' PDQ
JRPA is offline   Reply With Quote
Old 11-25-2014, 01:38 PM   #4
Senior Member
 
Norm Mac's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2012
Location: Central Massachusetts
Posts: 808
Bob, Has this ever worked for you? or is this a new coach for you?

It may need replacing, but it also may just need to be reprogrammed.

We added the keypad to our unit and I think I still have the owners manual around somewhere if you think it might help.
__________________
Norm & Ellen Proud to be one of the HOOTS
2015 Newmar DutchStar 4369
If I knew retirement was so much fun, I would have done it in my twenties!
Norm Mac is offline   Reply With Quote
Old 11-25-2014, 01:47 PM   #5
Senior Member
 
JRPA's Avatar


 
Monaco Owners Club
Join Date: Aug 2008
Location: Las Vegas
Posts: 287
Norm
The keypad hadn't worked for us at all but we have only owned coach for 6 months. I was hoping there was some kind of code or reset procedure. I don't have the keypad manual so I haven't been able to make any progress on getting the keypad working.

If you could PM me any reset info or code that would be great. If it isn't too big a copy of the manual would be super.

Thanks
__________________

Bob & Pearl
www.youtube.com/justpassingthru
2007 Monaco Camelot 42' PDQ
JRPA is offline   Reply With Quote
Old 11-25-2014, 02:13 PM   #6
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 6,055
Do you hear a beep when you push the buttons?
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 11-25-2014, 02:20 PM   #7
Senior Member
 
JRPA's Avatar


 
Monaco Owners Club
Join Date: Aug 2008
Location: Las Vegas
Posts: 287
No beep at all when I push buttons. Haven't found any fuse for keypad but hoping it could be something like no power to keypad due to blown fuse or something.
__________________

Bob & Pearl
www.youtube.com/justpassingthru
2007 Monaco Camelot 42' PDQ
JRPA is offline   Reply With Quote
Old 11-25-2014, 03:43 PM   #8
Senior Member
 
JRPA's Avatar


 
Monaco Owners Club
Join Date: Aug 2008
Location: Las Vegas
Posts: 287
Is there supposed to be a connection to either of these plugs?
Red connection says "PSH BTN"

Blue connection says "LED"

The photo didn't upload to show connection but I will try again
__________________

Bob & Pearl
www.youtube.com/justpassingthru
2007 Monaco Camelot 42' PDQ
JRPA is offline   Reply With Quote
Old 11-25-2014, 03:52 PM   #9
Senior Member
 
JRPA's Avatar


 
Monaco Owners Club
Join Date: Aug 2008
Location: Las Vegas
Posts: 287
Pic of Trimark module, I don't see any plug in that would be plugged into either of these plugs but it would seem like they are missing especially since that's what isn't working (keypad & backlight to keypad)?

There is a connector plugged into all of the other connections and the white one labeled. "POWER" does have 12 volts to it.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	59
Size:	209.4 KB
ID:	79946  
__________________

Bob & Pearl
www.youtube.com/justpassingthru
2007 Monaco Camelot 42' PDQ
JRPA is offline   Reply With Quote
Old 11-25-2014, 04:31 PM   #10
Senior Member
 
38 Special's Avatar
 
Monaco Owners Club
Join Date: Aug 2010
Location: Irondale, Alabama
Posts: 470
Quote:
Originally Posted by Bob & Pearl View Post
"I had to replace mine when it quit working like yours"

What did you replace? The keypad or control box?

Thanks for the info

Bob
The keypad. If you are getting beeps when the buttons are pressed, a reprogram should do it. If the keypad is dead, I really doubt a reprogram will bring it back to life.

But, do free stuff first!!!!
__________________

__________________
2008 Monaco Camelot 42 DSQ
Irondale, Alabama
38 Special is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Slide Trim smlranger Country Coach Owners Forum 9 11-01-2014 09:31 PM
Trip Tek keypad problem. boltdave Winnebago Industries Owner's Forum 0 09-08-2014 03:50 PM
Vinyl roof line trim replacement question jbesdale Monaco Owner's Forum 2 07-16-2014 05:36 PM
Questions for RVers that work on the road. Engle MH-General Discussions & Problems 8 01-12-2014 04:36 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×