Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-01-2022, 11:03 AM   #1
Junior Member
 
Join Date: Aug 2022
Posts: 10
Valid aux air pump

Hello all, I have a 2008 Monaco dynasty and I'm having problems with the valid aux air pump. The pump will not run, I have checked the fuse which is good. I replaced the 90-120 air sensor and that did nothing. I also removed the pump and hot wired the pump which did rotate. I have noticed that there is no air in the line to the 90-120 sensor? How do I get air in the line? The engine was running prior to line being removed and no air present. Thank you everyone.
Ron Stennes is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-01-2022, 11:12 AM   #2
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 51,481
Hi ! Welcome to IRV2! We're sure glad you joined us!

Hopefully someone will be along to help.

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 08-01-2022, 09:25 PM   #3
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 4,150
Quote:
Originally Posted by Ron Stennes View Post
Hello all, I have a 2008 Monaco dynasty and I'm having problems with the valid aux air pump. The pump will not run, I have checked the fuse which is good. I replaced the 90-120 air sensor and that did nothing. I also removed the pump and hot wired the pump which did rotate. I have noticed that there is no air in the line to the 90-120 sensor? How do I get air in the line? The engine was running prior to line being removed and no air present. Thank you everyone.

Monaco did plumb many of the coaches wrong, mine included, but even if it was plumbed incorrectly, that wouldn't stop the air from getting to the sensor.

The way it should be plumbed, is there should be a check valve immediately after the pump. If your pump is producing air, that check valve may have failed closed. There is nothing else between the pump and the sensor.
__________________
Bill & Brigitte
06 Windsor PEQ, Cummins 400 ISL
2014 Honda CRV or 2012 Jeep
windsorbill is offline   Reply With Quote
Old 08-01-2022, 09:42 PM   #4
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 9,027
Have you opened the drain screw on the bottom of the small leveling air tank?

If the compressor is functional, and there's 12v power to it, that should get it running.
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 08-02-2022, 06:10 AM   #5
Junior Member
 
Join Date: Aug 2022
Posts: 10
I don't see a check valve anywhere but I will look around.
Ron Stennes is offline   Reply With Quote
Old 08-02-2022, 08:26 AM   #6
Senior Member
 
Join Date: Apr 2018
Posts: 2,224
Quote:
Originally Posted by Ron Stennes View Post
I don't see a check valve anywhere but I will look around.
Mine is rt on the airline at the pump discharge. Looks like a steel hose fitting
shootist is offline   Reply With Quote
Old 08-02-2022, 10:24 AM   #7
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 4,150
Quote:
Originally Posted by Ron Stennes View Post
I don't see a check valve anywhere but I will look around.
yea, they are hard to spot if you don't know what to look for. Almost looks like a coupling.

It should be connected right to the pump.

Post some pictures if you can't find it.
__________________
Bill & Brigitte
06 Windsor PEQ, Cummins 400 ISL
2014 Honda CRV or 2012 Jeep
windsorbill is offline   Reply With Quote
Old 08-02-2022, 01:10 PM   #8
Junior Member
 
Join Date: Aug 2022
Posts: 10
Found out there was no relay, so have one on order. Borrowed one from the smart wheel and the pump worked but not producing air. Took the pump out and the piston is shot.
Ron Stennes is offline   Reply With Quote
Old 08-02-2022, 02:09 PM   #9
Senior Member
 
Join Date: Jul 2000
Posts: 3,537
The Valid pump is mounted in a bad spot

Gets road grime and they do not last long
__________________
Moisheh
2008 Dynasty 42' Diamond IV
1988 Bluebird PT38
2009 Silverado Toad
moisheh is offline   Reply With Quote
Old 08-02-2022, 02:35 PM   #10
Junior Member
 
Join Date: Aug 2022
Posts: 10
Ordered new pump from e-trailer. Their is a "T" right out of the pump is that possibly the air check valve? One line goes to the sensor and the other goes off to who knows where, feels like e goes through the wall? Still have to figure that out.
Ron Stennes is offline   Reply With Quote
Old 08-02-2022, 02:49 PM   #11
Senior Member
 
windsorbill's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: CA
Posts: 4,150
Quote:
Originally Posted by Ron Stennes View Post
Ordered new pump from e-trailer. Their is a "T" right out of the pump is that possibly the air check valve? One line goes to the sensor and the other goes off to who knows where, feels like e goes through the wall? Still have to figure that out.
The T could be the check valve. The line going through the wall probably is going to your air reserve tank, trace it out.
__________________
Bill & Brigitte
06 Windsor PEQ, Cummins 400 ISL
2014 Honda CRV or 2012 Jeep
windsorbill is offline   Reply With Quote
Old 08-02-2022, 06:47 PM   #12
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 9,027
Quote:
Originally Posted by Ron Stennes View Post
Ordered new pump from e-trailer. Their is a "T" right out of the pump is that possibly the air check valve? One line goes to the sensor and the other goes off to who knows where, feels like e goes through the wall? Still have to figure that out.
Have you located the leveling air tank?
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Old 08-02-2022, 07:56 PM   #13
Junior Member
 
Join Date: Aug 2022
Posts: 10
No haven't found the leveling tank yet
Ron Stennes is offline   Reply With Quote
Old 08-02-2022, 09:06 PM   #14
Senior Member
 
96 Wideglide's Avatar
 
Holiday Rambler Owners Club
Join Date: Aug 2010
Posts: 9,027
Well, that's where the other end of the line from the 'T' should be heading.
__________________
Ben & Sharon
2008 43' Holiday Rambler Scepter PDQ
96 Wideglide is offline   Reply With Quote
Reply

Tags
air, pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aux 1 / Aux 2 Switch - 2020 Coachmen Mirada 35BH greybirds2 Forest River Owners Forum 3 07-16-2020 11:59 AM
Powergear Valid Air Leveling DoubleDs95 Monaco Owner's Forum 16 09-16-2016 06:28 PM
Air Leveling System Leak on Signature with Valid Trueline Leveling System hawkeye78299 Monaco Owner's Forum 2 07-06-2015 07:40 PM
Power gear/ Valid air leveling Michbill Monaco Owner's Forum 5 08-18-2014 08:00 AM
Valid Air Leveling Compressor Jeep trekker Monaco Owner's Forum 14 07-22-2014 09:02 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.