RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-16-2013, 07:54 PM   #1
Junior Member
 
Holiday Rambler Owners Club
Join Date: Nov 2012
Location: Cape Canaveral, FL
Posts: 4
Weird jack problem

I have Power Gear Jacks. Jack panel would not power up. Also,turn signals would not work. Replaced fuse to fix turn signals and the jack panel started working again.Thought it was a coincidence. Has happened twice now! Any thoughts?
__________________
Marc & Alison LeBlanc
2001 Holiday Rambler Admiral
2014 Jeep Cherokee Trailhawk
rvmarc is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-22-2013, 12:23 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 20,859
Sounds kind of odd , if you have the Power Gear manual see what size fuse is required for the jack operation.
Any idea if it's the signals or the jacks blowing the fuse ? Guess I should have asked that first
Is this a new problem or a new to you coach ?

BTW; A belated Welcome to iRV2.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 09-22-2013, 04:24 AM   #3
Senior Member
 
nodine's Avatar
 
Monaco Owners Club
Join Date: Jan 2003
Location: Knoxville, TN, USA
Posts: 3,734
Quote:
Originally Posted by rvmarc View Post
I have Power Gear Jacks. Jack panel would not power up. Also,turn signals would not work. Replaced fuse to fix turn signals and the jack panel started working again.Thought it was a coincidence. Has happened twice now! Any thoughts?
Have the Power Gear panel powered up and someone watching it while you move wires and things in the location where you have been working.

Bob
__________________
Bob and Pam
2006 Diplomat 40PDQ
2020 Chevy Sonic
nodine is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.