Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Monaco Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2022, 09:48 AM   #1
Member
 
05 American Eagle's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: Mapleton, IL
Posts: 79
Windshield Wipers Not Working

2009 Monaco Signature with Smart Wheel.

First, one of the wiper switches would not work, now all of them are inoperative. When I did a search no Monaco motorhomes came up.

Anyone else have a similar issue that was fixed?
__________________
Don Higgins
Author of "But Who Will Save The Children"
05 American Eagle is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-29-2022, 03:16 PM   #2
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,687
Do the rest of the smartwheel functions work.

Here is a link to VIP troubleshooting, but you have to know which controller you have.
https://www.imminet.com/immi-vip-whe...oubleshooting/
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 06-30-2022, 12:22 AM   #3
Member
 
05 American Eagle's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: Mapleton, IL
Posts: 79
Quote:
Originally Posted by jacwjames View Post
Do the rest of the smartwheel functions work.

Here is a link to VIP troubleshooting, but you have to know which controller you have.
https://www.imminet.com/immi-vip-whe...oubleshooting/

Yes, they work. Cruise is fubar because of the Radar system, but the switches speed up the idle when I need it.
__________________
Don Higgins
Author of "But Who Will Save The Children"
05 American Eagle is offline   Reply With Quote
Old 06-30-2022, 04:21 AM   #4
Senior Member
 
ZackMan's Avatar
 
Join Date: Jan 2013
Location: Delaware
Posts: 314
05 American Eagle,

I experienced the exact same issue and used a spare steering wheel control switch pod pair that I had. Once I replaced the defective side that included the windshield wipers, there were no more issues.

May I suggest you review the VIP troubleshooting process as well as contact VIP at imminet.com. VIP was bought by IMMI in 2017.

There may be some additional troubleshooting steps that may not be covered in the literature.
ZackMan is offline   Reply With Quote
Old 06-30-2022, 07:52 AM   #5
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,687
Do you know what master controller you have???

Check the troubleshooting guide.


I looked at my fuse panels. I do have a 10 amp circuit breaker for the wipers, you might check to see if you have a fuse or CB.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 06-30-2022, 11:39 PM   #6
Member
 
05 American Eagle's Avatar
 
Monaco Owners Club
Join Date: Jun 2011
Location: Mapleton, IL
Posts: 79
Quote:
Originally Posted by jacwjames View Post
Do you know what master controller you have???

Check the troubleshooting guide.


I looked at my fuse panels. I do have a 10 amp circuit breaker for the wipers, you might check to see if you have a fuse or CB.

Appears to be the 214 version. Checked fuse and it is good. Checking troubleshooting guide now.
__________________
Don Higgins
Author of "But Who Will Save The Children"
05 American Eagle is offline   Reply With Quote
Reply

Tags
wind, windshield, wipers



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wipers Not Working HDBiker Dave Newmar Owner's Forum 4 10-16-2018 09:54 AM
Windshield wipers - link for finding proper wipers WriteOn Gear and Product Discussions 6 07-30-2018 11:39 AM
Windshield wipers stopped in the "up" position, not working!!! Roamin Mike RV Systems & Appliances 1 05-27-2016 04:58 PM
'12 F53 windshield wipers not working H3OHIO Ford Motorhome Chassis Forum 2 11-22-2014 03:33 PM
Windshield Wipers Not Working standardbob National RV Owner's Forum 4 06-30-2012 07:09 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.