RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Damon
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-15-2011, 06:20 PM   #1
Junior Member
 
ghoodnc's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 11
Damon Challenger Auto Park (LOCKED) HeLp

Hi all...first I am a newbee at the world of R/V. I recently picked up a 1097 Damon Challenger from a friend of mine. Besides a good bath and a few minor issues, seemed like would be a fun adventure.

I drove it home last Sunday, with almost no issues. I pulled in the drive and shut off. Last Saturday I started to pull it over to give it a bath and it will not move! There is a auto park dash light on.

Thanks to this fourm, it at least told me what to look for. I found the green switch on the frame rail in a box. I checked the fuild and seems to be almost full. Where do I go from here?? Any help would be appreciated.

Greg
__________________

ghoodnc is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-15-2011, 06:38 PM   #2
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 20,890

Try this link for now and if you think you need anymore information try a search here for "auto brake" and you'll get a ton of places to look.
__________________

__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 03-15-2011, 06:42 PM   #3
Junior Member
 
ghoodnc's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 11
Thank you

Giving it a try now...

Greg
ghoodnc is offline   Reply With Quote
Old 03-15-2011, 06:48 PM   #4
Junior Member
 
ghoodnc's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 11
Thanks, this gentleman new what his issue was. I dont have a clue. I read some of the forums but didnt see where anyone was locked yet or how to release it. I did find the box with the two switches and resevoir. But do not see any issues.
ghoodnc is offline   Reply With Quote
Old 03-15-2011, 07:00 PM   #5
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 20,890
This was the all important link within the link above it seems to be the place everyone gets directed to with auto brake problems.
olduserbear
__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 03-15-2011, 07:09 PM   #6
Senior Member
 
4Knights's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Join Date: Jan 2011
Posts: 1,798
Send a PM to oldusedbear on this forum, he's the expert. Send me your email via pm and I'll forward everything he sent me
Ron
__________________
Ron & Wendy-Kansas
94 Pace Arrow 34 ft
25 yr Army retired 2006
4Knights is offline   Reply With Quote
Old 03-16-2011, 08:05 PM   #7
Junior Member
 
ghoodnc's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 11
ghoodnc@yahoo.com Thank you all
ghoodnc is offline   Reply With Quote
Old 03-16-2011, 08:38 PM   #8
Senior Member
 
4Knights's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Join Date: Jan 2011
Posts: 1,798
I just sent you all the emails, PDFs and pics Roger sent me. It will fill your inbox so start downloading have fun and safe travels
Ron
__________________
Ron & Wendy-Kansas
94 Pace Arrow 34 ft
25 yr Army retired 2006
4Knights is offline   Reply With Quote
Old 03-20-2011, 06:45 PM   #9
Junior Member
 
ghoodnc's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 11
Thank you all..I have read all the emails, and ordered a new (RGS). It arrived on Saturday, So I will install it first thing in the am. Fingers crossed that this is what the issue is.
ghoodnc is offline   Reply With Quote
Old 03-20-2011, 06:50 PM   #10
Senior Member
 
4Knights's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Join Date: Jan 2011
Posts: 1,798
Be very careful when you change it out.... Do not strip or back out the thin metal/aluminum nut in front of the RGS. It's explained in the emails
Good luck
Ron

Ron & Wendy 94 Pace Arrow 454
__________________
Ron & Wendy-Kansas
94 Pace Arrow 34 ft
25 yr Army retired 2006
4Knights is offline   Reply With Quote
Old 03-21-2011, 07:41 PM   #11
Junior Member
 
ghoodnc's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 11
Well....first thing this moring I crawled under the R/V. I replaced the (RGS) Rotten Green Switch..Praying as I tighten that this resolves the issue. Double checking the fuild just before I slid out from under. With fingers crossed as I turn the key to start. She starts up fine....With the Auto Park Light on.....I put it in Drive.......Bam! The auto park light is gone and the unit moves again.

Thanks to Ron...Outsedbear...He has helped another in need.

Have a good day!
ghoodnc is offline   Reply With Quote
Old 03-21-2011, 07:46 PM   #12
Senior Member
 
4Knights's Avatar
 
Oklahoma Boomers Club
Fleetwood Owners Club
Join Date: Jan 2011
Posts: 1,798
Yeah! Clap! now when the next person posts the same problem you have to chime in.
happy trails

Ron & Wendy 94 Pace Arrow 454
__________________
Ron & Wendy-Kansas
94 Pace Arrow 34 ft
25 yr Army retired 2006
4Knights is offline   Reply With Quote
Old 03-21-2011, 08:27 PM   #13
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP" & Lehigh Acres Fl
Posts: 20,890
Thank you for the update they are just as important as the original post if not more so at times.
__________________

__________________
John & Cathy R.
06 Pace Arrow 38L Workhorse W24
08 14 Lincoln MKX AWD, 06 Lincoln Mark LT 4X4
See My RV Upgrades
JohnRR is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'96 Damon Challenger Steering column moves DamonBill Damon 3 02-09-2011 08:32 AM
Damon Challenger bobski Class A Motorhome Discussions 5 11-27-2010 10:58 PM
PLEASE HELP! Damon Challenger 5th. MANUAL annyoklee 5th Wheel Discussion 0 08-07-2010 05:51 PM
Auto Park Light came on gatorcruz MH-General Discussions & Problems 5 07-06-2009 02:19 PM
Shift Level locked in Park Bob (WA0MQE) Workhorse and Chevrolet Chassis Motorhome Forum 1 05-13-2009 07:03 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×