Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-24-2022, 03:19 PM   #1
Junior Member
 
Thor Owners Club
Freightliner Owners Club
Join Date: May 2022
Posts: 2
2017 Thor Palazzo charging house batteries underway

The House batteries on our RV do not charge while underway and the aux start button does not work. Has anyone else had these problems? do you have any fixes for them? Thank you.
unkel is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-24-2022, 04:40 PM   #2
Senior Member
 
Join Date: Mar 2021
Posts: 314
Quote:
Originally Posted by unkel View Post
The House batteries on our RV do not charge while underway and the aux start button does not work. Has anyone else had these problems? do you have any fixes for them? Thank you.
Probably the battery isolator relay (boost relay). You need to verify if it works or not. This relay connects your house batteries to the chassis batteries. There is usually a device that activates the relay to keep the house batteries charged from the chassis while driving.

Your Aux Start button manually activates this relay.

Good luck
gjames50 is offline   Reply With Quote
Old 05-24-2022, 05:15 PM   #3
Senior Member
 
triplewide's Avatar
 
Join Date: Mar 2015
Location: Greensboro, NC
Posts: 2,231
X 2 what gjames50 posted
__________________
1998 Min Winnie, 2000 Winbago Journey, 2015 ACE 29.3
2016 Thor Miramar 34.2
triplewide is offline   Reply With Quote
Old 05-24-2022, 05:30 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 30,347
Get someone to press the boost start button on and off while you listen near the batteries. You should hear it clunking on and off.

If you do, that doesn't mean it's making a connection internally, they fail often.
twinboat is offline   Reply With Quote
Old 05-25-2022, 07:04 PM   #5
Junior Member
 
Thor Owners Club
Freightliner Owners Club
Join Date: May 2022
Posts: 2
It was the Aux start relay causing both problems. I replaced it and everything works as it should. Thank you all for your help!
unkel is offline   Reply With Quote
Old 05-26-2022, 04:59 AM   #6
Senior Member
 
triplewide's Avatar
 
Join Date: Mar 2015
Location: Greensboro, NC
Posts: 2,231
Thanks for posting your solution.
__________________
1998 Min Winnie, 2000 Winbago Journey, 2015 ACE 29.3
2016 Thor Miramar 34.2
triplewide is offline   Reply With Quote
Old 06-01-2022, 05:42 AM   #7
Senior Member
 
Thor Owners Club
Mid Atlantic Campers
Coastal Campers
Carolina Campers
Join Date: Jul 2018
Location: Warrenton Va
Posts: 248
I've seen that problem before.

There is a cable that runs from the BIM (battery isolation module) to the house batteries. If somebody changed a house battery and neglected to connect that cable, the behavior would be exactly as you describe.
__________________
2017 Thor Freedom Elite 23H
WileyOne is offline   Reply With Quote
Reply

Tags
batteries, charging, house batteries, palazzo, thor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The alternator not charging the house batteries while underway. jagmoor Entegra Owner's Forum 17 07-31-2018 04:14 PM
House Batteries Not Charging When Underway RonLC Forest River Owners Forum 2 07-16-2018 05:55 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.