Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-28-2021, 10:48 AM   #1
Junior Member
 
Join Date: Apr 2016
Location: St. Louis, Misery
Posts: 21
Generator Start Switch Doesn't Work

The generator works fine BUT I had a new battery installed and now the in-house generator switch doesn't function. The battery lights show a full charge. When I hit the generator switch, the battery lights go to zero, the LP Detector beeps, and the generator doesn't start. I run the chassis engine and start the generator form the generator's start switch, on the generator. Ideas? Thanks, Bob
BobDye1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-28-2021, 11:05 AM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 28,607
Bad connection on house battery cable.

Starts with engine running because the boost/charging solenoid is closed and is using the chassis battery.
twinboat is online now   Reply With Quote
Old 10-04-2021, 01:52 PM   #3
Junior Member
 
Join Date: Apr 2016
Location: St. Louis, Misery
Posts: 21
Doesn't explain everything

At the beginning, the house battery indicators read a full charge. When I hit the generator switch in the HOUSE, the house battery drops to zero and the LP Detector beeps. It doesn't seem that a bad battery connection would give those results. Something seems to 'short' out or a relay is tripped/not tripped///
BobDye1 is offline   Reply With Quote
Old 10-04-2021, 01:54 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 28,607
Quote:
Originally Posted by BobDye1 View Post
At the beginning, the house battery indicators read a full charge. When I hit the generator switch in the HOUSE, the house battery drops to zero and the LP Detector beeps. It doesn't seem that a bad battery connection would give those results. Something seems to 'short' out or a relay is tripped/not tripped///
Classic bad connection symptons.
twinboat is online now   Reply With Quote
Old 10-04-2021, 08:51 PM   #5
Senior Member
 
Join Date: Mar 2003
Location: Meridian, Idaho USA
Posts: 229
I agree with Twinboat.
__________________
Mnoel
18 Aria 3901-"The Wined Up Bus"
2016 Wrangler JKUR
Mnoel is offline   Reply With Quote
Old 10-05-2021, 06:47 AM   #6
Senior Member
 
Sweetbriar's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Jul 2011
Posts: 3,496
Had the same happen with a car. Everything look OK. Lights bright, radio worked, 12+VDC at the battery terminals. Roll the key from on to start and everything died. Cleaned both the positive and negative cable terminals at the battery and the problem never happened again.
__________________
2006 Hurricane 31D built on a 2006 Ford F53
Sweetbriar is online now   Reply With Quote
Old 10-07-2021, 09:54 AM   #7
Junior Member
 
Join Date: Apr 2016
Location: St. Louis, Misery
Posts: 21
Nope - Still Doesn't Work

Cleaned all contacts - problem still exists. I spoke with a technician at our local RV place and he suggested that a relay had been thrown - behind the fuse panel. Any other ideas????
BobDye1 is offline   Reply With Quote
Old 10-07-2021, 10:10 AM   #8
Senior Member
 
OldWEB's Avatar
 
Join Date: Sep 2018
Posts: 402
You said...
Quote:
Originally Posted by BobDye1 View Post
The generator works fine BUT I had a new battery installed and now the in-house generator switch doesn't function. Bob
and the problem started. So which battery was installed? I am thinking they neglected to connect a wire, my guess is a negative cable and the control panel dies when a start is attempted.
Wiring problems can be weird and currents can flow in other areas to satisfy itself, hence the panel working until a large draw is made...
OldWEB is offline   Reply With Quote
Reply

Tags
generator, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
D/C disconnect switch doesn't work unless motor is running VC63 Ford Motorhome Chassis Forum 13 05-22-2021 01:47 PM
Generator dash switch doesn’t work but does with manual switch on gen Sandy Swede Monaco Owner's Forum 19 06-28-2020 10:01 AM
Chassis disconnect switch doesn't work? Coachmen Joe Class A Motorhome Discussions 6 09-03-2019 06:26 AM
Batteries are good, volt gauge doesn't move, engine doesn't start patrickjoly Class A Motorhome Discussions 9 10-18-2018 02:04 AM
Porch light switch doesn't work inside light Samflhomes National RV Owner's Forum 4 06-14-2015 09:23 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.