Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-16-2021, 07:14 PM   #1
Junior Member
 
Join Date: Apr 2018
Posts: 2
V10 e450

Love my 22FE Freedom Elite. But the Ford v10, 6.8L engine chirp/squeals at exactly 2100 rpm. Anybody else have that problem?
tedlmac is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-16-2021, 07:33 PM   #2
Senior Member
 
nvs4602's Avatar
 
Forest River Owners Club
Join Date: Jun 2017
Posts: 794
Probably the belt tension pulley needs replaced. This is a common problem on all vehicles.
__________________
2017 Coachmen Leprechaun 311FS
2020 Jeep Trailhawk Elite (Toad)
nvs4602 is offline   Reply With Quote
Old 06-17-2021, 07:51 AM   #3
Senior Member
 
Jayco Owners Club
Join Date: May 2016
Location: North Texas
Posts: 473
Welcome to the IRV2 forums. A lot of people have reported this and changed the belt and idler, however there is a modification that many have done as well adding another pulley. Check this out and you can also search for similar threads.

https://www.irv2.com/forums/f87/best...-518788-2.html

~Craig
__________________
2010 Jayco GreyHawk 31SS
craigav is online now   Reply With Quote
Old 06-22-2021, 06:33 PM   #4
Junior Member
 
Join Date: Jul 2013
Posts: 11
Check the Catalytic converter

Had the same problem with mine. When under load it would “scream” and no one could figure out why, even was producing codes for cylinder #3 had multiple misses. Changed the belts, tension rollers, pvc, also changed the plugs and other ignition componets. when we were at Elkhart this year we stopped by the Ford Dealership that provides the chassis to Thor. The mechanic starts the engine and says the catalytic converter was bad/clogged and causing back pressure to the manifold and leakage. The “screaming” was from the manifold leakage. Replaced the catalytic, repaired the leakage, ....4,000 miles no more chirping, or screaming.
So check the catalytic and manifold leaks first. Make sure the tempature going in and tempature going out is close.

Ron
2014 Thor Challenger 37GT
lvmatador is offline   Reply With Quote
Old 06-22-2021, 06:57 PM   #5
Senior Member
 
tap4154's Avatar
 
Join Date: Apr 2019
Posts: 1,125
What year is it? Before January 26 2010 they required a 99.5 inch belt, after that they put on 100.25 inch belt. I have no idea why Ford changed the spec on that, but mine is the earlier shorter one and never has a problem at 2100 rpm, as many people report. Lots of people put on that extra tensioner, but I wonder if they put the shorter belt on if that might even solve it?
tap4154 is online now   Reply With Quote
Reply

Tags
e450, v10



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lund Bug Deflector fit on an E450/V10? Old Radios Class C Motorhome Discussions 6 06-07-2014 12:50 PM
03 E450 v10 Radiator replacement to all alum jboat32 Class C Motorhome Discussions 3 07-18-2013 08:28 PM
e450/v10 service henryn Ford Motorhome Chassis Forum 6 03-25-2013 04:32 AM
Class C with Ford v10 E450 engine svg67 Class C Motorhome Discussions 6 11-06-2012 06:41 PM
2001 coachmen e450 v10 oil pump dampoo Class C Motorhome Discussions 4 11-18-2011 01:10 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.