Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Navistar MaxxForce Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2014, 05:01 PM   #1
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Diagnostic code "spn 3359 fmi 31

On my 2013 HR Endeavor with Maxx Force 10 I have a check trans light and the diag that reads out on the lcd shows the above code. I have no idea where to find information on these codes.

Any help appreciated.

Larry

2013 HR Endeavor 43 PKQ
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-09-2014, 05:55 PM   #2
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,420
Sorry that I can't help you, but I would be giving Navistar a call and see what they can tell you. Wish you the best.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Old 06-27-2014, 02:02 AM   #3
Senior Member
 
Elictrix's Avatar
 
Join Date: May 2014
Posts: 120
Did you get this sorted?
Elictrix is offline   Reply With Quote
Old 06-27-2014, 09:17 AM   #4
Senior Member
 
Dawgs's Avatar
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Dec 2013
Location: Fayetteville, GA
Posts: 175
You may want to call Alliance Coach in Wildwood and give them the code. They know these coaches inside and out. I'd run over there and have them run a diagnostic on the transmission. Should be free since the Allison comes with a 2 year warranty.
__________________
2013 Holiday Rambler Endeavor DFT-tag
Maxxforce 10 RR10R
Dawgs is offline   Reply With Quote
Old 06-27-2014, 07:40 PM   #5
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Smile Fixed it was a build issue

Quote:
Originally Posted by Elictrix View Post
Did you get this sorted?
Yes, replaced TCM connector; following is what I posted on the HRRVC Ramblin-Pushers, 419, egroup;

I thought I should follow up on my issue and let you know what has happened.
I made a couple of calls and made arrangements to take the coach to Hill Truck sales in South Bend, the shop in Elkhart was to busy to see me in a reasonable time. Prior to my appointment I did the 5 presses of the up/down arrows on the shift pad and go the codes. The owners manual made it look like a big problem. Everything seemed to work ok and the transmission temp was always in range. Hill put their computer on it and told me there was a missing wire in the harness between the TCM and transmission. Couldn't do anything. Said it was safe to drive.
Sent note to mctech and they said the shop needed to call them and they would figure out what to do. He couldn't believe it was a missing wire, neither could I. So I drove the rig and we are now in Gillette WY.

I took the coach to Interstate Powersystems, They found that the plug on the TCM had a broken connector "pin" really the socket that attaches to a pin on the TCM. It would not lock into the 80 pin connector. So basically when the Hill tech put a test lead to check it just pushed the plug pin/socket out a little making him think there was a missing wire.

Since it is a Monaco issue it is not covered under warranty by Allison. They called mctech and they agreed to pay for a new connector. So tomorrow, when UPS arrives with the part, Interstate will install, I will pay the $800 or so and hopefully get my money back from Monaco/HR. That is what mctech said to do.

Long way to get to a bad pin in a connector but....

Larry K
'13 Endeavor 43 PKQ
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 07-20-2014, 06:28 AM   #6
Senior Member
 
Monaco Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2007
Location: Somewhere, USA
Posts: 314
Blog Entries: 1
Monaco, more correctly Allied, sent me a check for the amount of the bill.
__________________
Larry and Suzette
2013 HR Endeavor 43 PKQ
2006 Jeep Liberty toad, SMI AFO Brake controller
Larry and Suzette is offline   Reply With Quote
Old 07-20-2014, 09:00 AM   #7
Senior Member
 
Traps90's Avatar
 
Monaco Owners Club
Join Date: Sep 2010
Location: Alberta
Posts: 1,420
Glad to hear that your fixed up and they took care of it all for you.
__________________
Trap, Jan and the Pup
2013 Monaco Diplomat 43dft
2010 Black Jeep Liberty
Traps90 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Dometic Freezer and Ice Maker are acting up! Error Code 'CALL ERR 13' Craig N Deb RV Systems & Appliances 56 09-12-2020 04:32 PM
Location of paint code TXredfish Newmar Owner's Forum 5 05-03-2014 08:49 AM
Diagnostic codes password on a Cat c9 krivanj Fleetwood Owner's Forum 11 02-15-2014 12:11 PM
Onan Marquis Gold 5500 Code 13 shutdown 757driver RV Systems & Appliances 20 10-29-2013 04:42 AM
Onan 10K Diesel code 36 thahn RV Systems & Appliances 1 09-10-2013 06:02 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.