Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-27-2021, 07:02 PM   #1
Junior Member
 
Join Date: Jul 2012
Location: Vancouver, B.C.
Posts: 4
Banks Ottomind turbo module

We LOVE our 2002 Bounder with 5.9 Cummins. It had Banks Ottomind turbo tuner installed by previous. owner and ran nicely for us for about 5000 miles. First trouble was loss of boost during very heavy rain. I relocated the module to a much drier climate in engine comp. and cleaned electrical connections. It ran perfectly for many more miles. Last few trips it has been acting up with intermittent loss of boost and EGT indications on gauge.
Banks tech support has bailed saying the unit is obsolete and there is no replacement or upgrade. All electrical connections have been checked. I’d be happy to have it put back to stock but Cummins won’t touch it due to the Banks modification……
bearair is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-27-2021, 10:38 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,593
Welcome to iRV2.

Have you checked other possibilities , like possibly the air filter sustained damage from the rain ?
Do you get a CEL at any time ?
Do you know if your 5.9 has the VP-44 injection pump or is it one of the first with the HPCR ( High Pressure Common Rail ) Cummins injection system ?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-28-2021, 10:15 AM   #3
Senior Member
 
Smitty77's Avatar
 
Join Date: Aug 2010
Location: Over the next hill, around the next curve...
Posts: 5,091
If the Ottominder brains are shot, some have been lucky calling around to RV Salvage Yards and or E-Bay to locate used replacements. But I admit it's always a gamble buying used! Here is E-Bay: https://www.ebay.com/sch/i.html?_fro...omind&_sacat=0

Best of luck to you,
Smitty
__________________
07 Country Coach Magna Rembrandt 45' ISX600
Roo II was our 04 Country Coach Allure 40'
OnDRoad for The JRNY! Enjoy life...
Smitty77 is offline   Reply With Quote
Old 09-28-2021, 10:21 AM   #4
Junior Member
 
Join Date: Jul 2012
Location: Vancouver, B.C.
Posts: 4
Not sure what a CEL is ……if it’s a warning light or code we’ve had none. Fuel pump is VP-44. New air filter installed last year. Problem still persists.
bearair is offline   Reply With Quote
Old 09-28-2021, 10:25 AM   #5
Junior Member
 
Join Date: Jul 2012
Location: Vancouver, B.C.
Posts: 4
Thanks - after the dead-end I got speaking with tech reps at Banks - I just want it back to stock!
bearair is offline   Reply With Quote
Old 09-28-2021, 11:39 AM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,593
Quote:
Originally Posted by bearair View Post
Thanks - after the dead-end I got speaking with tech reps at Banks - I just want it back to stock!
Perhaps a search for an installation manual and , reverse the process .


CEL ( Check Engine Light ) so no light or codes.

I'm assuming your coach is built on a Freightliner chassis .

If so be aware that Freightliner with Cummins could have a fuel filter strainer ,
hidden in the wiring above the passenger side rear air bag .
If the filter is there and partially plugged all sorts of performance issues are possible .

http://www.irv2.com/forums/f26/the-t...er-328852.html

Since the thread the following diagram has come to light.
Attached Thumbnails
Click image for larger version

Name:	Freightliner strainer location.jpg
Views:	7
Size:	201.8 KB
ID:	344488  
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-28-2021, 01:46 PM   #7
Junior Member
 
Join Date: Jul 2012
Location: Vancouver, B.C.
Posts: 4
Thanks Skip - I have the install manual and reversing the install is my fall-back plan. Thx for the tip re: fuel strainer. I’ll be looking for that as soon we get home from this trip.
bearair is offline   Reply With Quote
Old 09-28-2021, 02:05 PM   #8
Senior Member
 
Mr_D's Avatar
 
Country Coach Owners Club
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 37,647
Quote:
Originally Posted by bearair View Post
We LOVE our 2002 Bounder with 5.9 Cummins. It had Banks Ottomind turbo tuner installed by previous. owner and ran nicely for us for about 5000 miles. First trouble was loss of boost during very heavy rain. I relocated the module to a much drier climate in engine comp. and cleaned electrical connections. It ran perfectly for many more miles. Last few trips it has been acting up with intermittent loss of boost and EGT indications on gauge.
Banks tech support has bailed saying the unit is obsolete and there is no replacement or upgrade. All electrical connections have been checked. I’d be happy to have it put back to stock but Cummins won’t touch it due to the Banks modification……
Banks didn't "bail on you"! The subcontractor that made the boxes went out of business many years ago and they never picked up another manufacturer. They are encapsulated in epoxy so fixing them is impossible.
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft, HWH Active Air
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '21 Jeep JLU Rubicon Ecodiesel
Mr_D is offline   Reply With Quote
Reply

Tags
turbo



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To Banks or Not To Banks F4Jock Class A Motorhome Discussions 28 07-14-2019 05:22 PM
Banks Ottomind and 2003 ECU Ex120pilot Workhorse and Chevrolet Chassis Motorhome Forum 5 08-01-2012 08:59 AM
Banks Turbo quit-safe to drive? Dave1956 Newmar Owner's Forum 9 03-30-2011 12:25 PM
Banks Turbo Booster ?? Dave1956 Cummins Engines 1 03-27-2011 04:58 PM
Banks Ottomind RgrDgr Workhorse and Chevrolet Chassis Motorhome Forum 3 06-10-2006 08:29 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.