Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-21-2016, 03:09 PM   #1
Junior Member
 
marlin263's Avatar
 
Join Date: Jul 2016
Posts: 5
cummins 300hp stumbles

Hello. I just purchased a new to me 2007 tiffin allegro bay. It has a cummins front diesel engine with 50,000 miles and an Allison five speed transmission. I drove it home 350 miles and had no issues. On my first trip after driving with a bug in tow for 250 miles my engine started stumbling or hesitating. I noticed as I went on hills on the expressway the motorhome hesitating and loosing speed(65mph). Check engine light came on. I pulled over at a walmart and sat there engine off for thirty minutes. Got back on the road no problema engine was strong and no hesitation. On my return home roughly same distance engine started hesitating again. I noticed if I drove around 50mph the hesitating would stop. Now the check engine light is gone and fault codes are gone. I am new to rving. Anyone has any light to shed on my problem.
marlin263 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-21-2016, 03:14 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 27,955
Have the fuel filters changed. 90% of diesel issues are fuel related and the # 1 low power fix is filters.
twinboat is offline   Reply With Quote
Old 07-21-2016, 03:14 PM   #3
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 944
I would start with a new fuel filter or three.
znt1186 is online now   Reply With Quote
Old 07-21-2016, 03:31 PM   #4
Junior Member
 
marlin263's Avatar
 
Join Date: Jul 2016
Posts: 5
Thanks

I just found a mechnic with the diagnostic tool. Unfortunatley the CW in Katty where I purchased has not been able to get me any maintenance history. I will start with filter change. Thanks. Just want to start traveling safely.
marlin263 is offline   Reply With Quote
Old 07-21-2016, 03:39 PM   #5
Senior Member
 
DMTTRANSPORT's Avatar
 
Join Date: May 2014
Location: Henderson, Nevada
Posts: 1,224
Could be water in the tank....
__________________
2005 Newmar DS 4023, Spartan Chassis, ISL 370 Cumapart, 2008 Jeep Rubicon 4dr, 2015 Kia Soul, 1969 Italian & 2004 Akita
DMTTRANSPORT is offline   Reply With Quote
Old 07-21-2016, 06:20 PM   #6
Senior Member
 
Freightliner Owners Club
Join Date: Mar 2002
Location: Western WA
Posts: 1,288
Go to a Cummins shop and have them run the diagnostics on your engine to determine exactly why you got the check engine light and what it is telling you.
__________________
'07 Winnebago Journey 34H, ISB-02, MH2500
Toad - '08 Ford Taurus X
Blue Ox, Aventa
US Gear UBS
FleetMan is offline   Reply With Quote
Old 07-21-2016, 08:50 PM   #7
Senior Member
 
JohnBoyToo's Avatar
 
Monaco Owners Club
Join Date: May 2012
Location: DFW, Tex-US
Posts: 6,196
mine too did fine until towing our jeep in the North Carolina mountains and it starved for fuel a couple of times going uphill....
fuel filters and it's a 6 second dragster again ! oh, I mean 600 second dragster
__________________
'11 Monaco Diplomat 43DFT RR10R pushed by a '14 Jeep Wrangler JKU. History.. 5'ers: 13 Redwood 38gk(junk!), 11 MVP Destiny, Open Range TT, Winn LeSharo, C's, popups, vans, tents...
JohnBoyToo is offline   Reply With Quote
Old 07-22-2016, 01:07 PM   #8
Junior Member
 
marlin263's Avatar
 
Join Date: Jul 2016
Posts: 5
Got my fingers crossed. Mechanic said fuel filter needed changing.
marlin263 is offline   Reply With Quote
Old 07-22-2016, 02:47 PM   #9
Junior Member
 
marlin263's Avatar
 
Join Date: Jul 2016
Posts: 5
Wow great site. You guys hit it on the spot. Fuel filter done. Thank you.
marlin263 is offline   Reply With Quote
Old 07-22-2016, 09:59 PM   #10
Senior Member
 
JohnBoyToo's Avatar
 
Monaco Owners Club
Join Date: May 2012
Location: DFW, Tex-US
Posts: 6,196
that's great - now go enjoy it !
__________________
'11 Monaco Diplomat 43DFT RR10R pushed by a '14 Jeep Wrangler JKU. History.. 5'ers: 13 Redwood 38gk(junk!), 11 MVP Destiny, Open Range TT, Winn LeSharo, C's, popups, vans, tents...
JohnBoyToo is offline   Reply With Quote
Old 07-29-2016, 04:07 PM   #11
Junior Member
 
marlin263's Avatar
 
Join Date: Jul 2016
Posts: 5
How many filters do I have to change? On my way to fix refrigerator stalled 3 times. Limped to service going 25mph😢😢
marlin263 is offline   Reply With Quote
Old 07-30-2016, 07:58 AM   #12
Senior Member
 
Winnebago Owners Club
Join Date: Feb 2008
Posts: 728
Quote:
Originally Posted by marlin263 View Post
How many filters do I have to change? On my way to fix refrigerator stalled 3 times. Limped to service going 25mph😢😢
Marlin,
Get to a Cummins repair shop and have them run a diagnostic check. It could be a bad lift pump which will affect the injector pump. Lift pump is cheap. Injector pump is $$$$.
charles tuit is offline   Reply With Quote
Reply

Tags
cummins



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manifold broke in half on 300hp Cummins Bobmn Cummins Engines 10 02-08-2012 09:25 PM
hard to start 300hp cummins wmckay Cummins Engines 6 12-03-2011 09:42 AM
Onan Diesel Stumbles Only When Coach Moving DonBaja Monaco Owner's Forum 2 07-21-2011 08:03 PM
300HP Cummins fuel mileage motofamily Cummins Engines 20 11-29-2010 11:04 AM
2002 Expedition, 300HP Cummins Problem willm4473 Fleetwood Owner's Forum 5 08-24-2010 08:31 AM


All times are GMT -6. The time now is 04:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.