Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-12-2014, 04:57 PM   #1
Junior Member
 
Join Date: Aug 2013
Location: Home
Posts: 21
Cummins ISC Multiple Problems

Good day,

We purchased an '04 Winnebago Vectra in June 2013 with 42.5k miles with a Cummins ISC rated at 350 hp. In the last year we have driven about 6k miles and experienced a series of minor and not so minor problems. I am new to both the RV and diesel engine worlds, and I just don't know if this is part of the experience or not. My questions are:

1. Could one or more of these issues be related?
2. Is there an underlying problem yet to be diagnosed?
3. Given our current location (the middle of South Carolina and heading up the East coast soon), is there a knowledgable Cummins/Freightliner dealer in the area who can address our problems and give us confidence that we will have a reliable coach?

Background:
We are the third owners. We have good maintenance records from the first owner (about 35k miles with no issues) and nothing from the second owner. The coach is about 1000 lbs under GVWR and we are not towing anything yet. We plan to start towing our Honda CRV.

In chronological order (pardon in advance for the lengthy post):

1. Early July 2013: Check engine light and greatly reduced power.
The DC Cummins dealer found only two inactive codes (328 and 329 w/ a description of power derate and possible engine dies). They indicated that an ECM update was required but could not apply it. Finally they changed the fuel filter (single filter on this '04 engine) as their only action. Continued 750 miles home to MA without further problems.
Note: This trip was in the middle of a heat wave with temperatures in the upper 90's to over 100. Engine temp ranged from 185 to 200 and transmission temp ranged from 145 to 180.
2. Early August 2014: Generator stops under load.
After a full PM at our local Freightliner shop, the generator would not start normally. It would restart after priming and cranking several times. After three trips back to Freightliner they replaced the new fuel filter. No additional problems since.
3. Sept 2014: Multiple dashboard lights came on, the warning buzzer sounded and the engine lost power while climbing a steep hill in VT. Everything returned to normal within a few seconds before the coach stopped rolling. Temps were normal.
The Freightliner shop found no problems. This has not reoccurred.
4. Oct 2014: Check engine light came on intermittently on a short trip for about 15 minutes. No loss in power. No active codes. The light may have been related to climbing moderate hills.
5. Stored for winter with full tank.
6. Early April 2014: Drove from storage to home (about 40 mi) and to scales for weight check (about 50 mi).
7. Late April 2014: Engine would not start; ran roughly for short period and died with the check engine light on.
I changed the fuel filter and found the fuel to be clear but with a significant amount of small, black, particles that settled to the bottom of a clear container. Had the coach towed for service.
The shop was not concerned with the condition of the fuel sample I gave them. The ECM returned codes indicating that the fuel pump was gone and had damaged the ECM. On a second reading, the ECM failed completely. I verified that they checked the lift pump before replacing the fuel pump and ECM. Engine ran normally.
8. May 2014: Travelled from MA to VT to SC.
a. Engine and transmission ran much hotter than normal with ambient temperature in the mid 80s just one day. We were on I-87 in NY and PA. I had to slow down to 50 and downshift on moderate hills to keep water under 215 and transmission under 205. I know these are not extreme but they are very different from what I have ever seen before, especially the transmission temperature. The next day temperatures returned to normal (transmission back to 145) under very similar driving conditions.
b. Later in the trip the check engine light flashed briefly a few times, came on for about a minute a few times and then went out. I was on easy, rolling hills in NC with ambient temperature in the upper 80s.
I purchased a ScanGuage after reading this site, but it reported no codes.

I appreciate thoughts and suggestions.

Safe travels,
BandBRetired
2004 Winnebago Vectra
BandBRetired is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-12-2014, 10:08 PM   #2
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 24,411

Some previous posts say there is a Freightliner dealer in Gaffney, NC that is very good.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 06-13-2014, 09:12 AM   #3
Senior Member
 
AFChap's Avatar
 
Winnebago Owners Club
Spartan Chassis
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 5,154
Quote:
Originally Posted by Ray,IN View Post

Some previous posts say there is a Freightliner dealer in Gaffney, NC that is very good.
I believe the Gaffney location is not just a dealer, but is in fact the Freightliner factory. That would be my recommendation for service.

Couple of comments...
- The engine likely has two fuel filters, one with a fuel-water separator on the bottom. Some owners have found a second filter that has never been changed.
- The generator has its own small in-line fuel filter inside the bottom of the generator that has its own service schedule.
- Check engine light should not be affected by hills, etc. It is trying to say something, question is what.
- The one day with high temps (215 is high to me!) is strange ...sounds like the engine was lugging down for some reason or you were dragging an anchor! ...exhaust brake hung? ...bad fuel/fuel starvation? (would also have poor power/acceleration)
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
2003 Winnebago Ultimate Advantage 40e
towing 2017 Jeep Grand Cherokee Limited
Blog at www.pjrider.com
AFChap is offline   Reply With Quote
Old 06-13-2014, 09:35 AM   #4
Junior Member
 
Join Date: Aug 2013
Location: Home
Posts: 21
Thanks, I will look then up.

Bob
BandBRetired is offline   Reply With Quote
Old 06-13-2014, 11:46 AM   #5
Senior Member
 
dsbike's Avatar
 
Winnebago Owners Club
Join Date: Jan 2010
Location: Bolivia, NC
Posts: 1,399
Freightliner in Gaffney SC. highly recommended. I have had service there & also attended Camp Freightliner. They are a few miles away from the Factory on a college campus property, I think it is Cherokee/Spartanburg Community College. Their phone # is 1 (855)253-0421
__________________
Dan Sees, , 2013 Winnebago Journey 42e, 2014 Featherlite Car Hauler 3110 17.5', 2008 Mazda MX5,
2008 Toyota FJ Cruiser,2018 mercedes Benz GLA 250
dsbike is offline   Reply With Quote
Old 06-13-2014, 05:40 PM   #6
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2006
Location: Michigan
Posts: 859
BandB... you've got quite a list with many items. May or may not be related.

I have the same coach, same engine. I'll give you a few thoughts with the caveat that I'm not a mechanic, just an owner who's gone through similar.

First, spot on go to the Gaffney guys. Attend Camp Freightliner when you can (it is taught there) and have them look at your issues. They are simply the best.

Now, on my '04 Vectra with the ISC 350, there was only ONE fuel filter. The engine manufacturer gives the specs, but the chassis builder (with input from the RV manufacturer who's buying the chassis) add things like the fuel filters. I suspect yours is the same. And if you do a bit of Googling you'll find that the filter likely is after the lift pump. See this thread...

Motorhome Magazine Open Roads Forum: Class A Motorhomes: 2000-2004 Cummins ISC owners beware

I had a lot of issues until I had my Freightliner/Cummins shop install a 2nd filter before the lift pump. Not a cheap fix but took care of a lot of issues for me. I'd suggest you have Gaffney look things over and get their suggestion.

Second, depending on when your 04 was built you may have a VDC module, or the slightly newer (at that time) MMDC. On my unit it's under the floor in the engine compartment mounted on the firewall accessed through the floor panel. Yours may be different depending on which floorplan you have. Point is, this is the nerve center for the gauges, other stuff and has a big cable that plugs into it. Might try reseating it. The VDC in particular has been known to have cold-solder problems (google again) and might be causing some of your momentary issues. Mine loosened once and caused my panel to blink, turbo to cut in and out, etc. Reseated and no issues since.

Just a few thoughts based on my experiences... your mileage may vary, etc.
__________________
Ed & Joie
2004 Vectra 40KD
Freightliner Chassis and Cummins ISC
emiddleb is offline   Reply With Quote
Old 06-15-2014, 09:24 AM   #7
Junior Member
 
Join Date: Aug 2013
Location: Home
Posts: 21
Ed & Joie,

I very appeciative of your time in answering my post. It's good to meet up with someone with the same coach (we have the 40AD). The Vectra really matches our needs, but these nagging problems are draining our mental and monetary reserves.

Almost every reply has endorsed Gaffney. I was hesitant at first because every other experience we have had so far at other dealers has taken a minimum of three weeks with only partial success.

Thanks again and safe travels.

BandBRetired
Bob and Beryl
2004 Vectra 40AD w/ Cummins ISC
BandBRetired is offline   Reply With Quote
Old 06-16-2014, 07:44 AM   #8
Senior Member
 
mrv8outboard's Avatar
 
Tiffin Owners Club
Join Date: Jul 2011
Location: Cape Cod
Posts: 352
I too endorse Gaffney as well as it is Freightliner's CCCC in house shop. That said they are not Cummins (that is what they said to me) and anything Cummins must go to Cummins. They sent my coach to Cummins Atlantic in Spartanburg, SC and they were awesome. They were both great.
mrv8outboard is offline   Reply With Quote
Old 06-16-2014, 12:45 PM   #9
Senior Member
 
SteveLevin's Avatar
 
Join Date: Feb 2010
Location: Sunnyvale, CA
Posts: 1,195
I too have been suffering with engine heat issues that past year (but haven't been using the coach that much). When we first had it, at 1900rpm in 4th gear (our ISC is rated at just 300hp) it would climb any grade in the western US without getting above 205 on the water temp under any conditions. After moving to Wyoming, every trip since then has required thermal management on the big grades. No one has had any idea. We just got back to California so the shop I trust (R Mechanic in Livermore) can look at it, but it's very frustrating to me.

Steve
__________________
The Green Machine -- 2000 Mountain High Coachworks Summit (Spartan chassis / Cummins ISC)
...and F-Troop: Fearghus, Fiona, and Frankie (Cairn Terriers)
SteveLevin is offline   Reply With Quote
Old 06-22-2014, 04:52 PM   #10
Junior Member
 
Join Date: Jun 2013
Posts: 13
ISC issues

I have a Winnebago Ultimate Freedom with an ISC 350 (the predecessor to the Vectra). I experienced the exact same issues over the course of 18 months with varying severity. After several trips to Cummins I finally purchased Insite and performed my own troubleshooting. The issue was a failing crankshaft position sensor. There are two of them and they are quite difficult to get to but after replacing them all my derate, stalling and starting issues were resolved. You should have codes when the engine derates so have cummins check again.

Your generator problems (and fuel filter issues) are a separate issue and sound like you may have algae in your fuel tank. A friend of mine with a Cummins 330 battled algae for a long time. There are some strong fuel additives that can help. Cummins use to make an algae additive but last time I tried to buy some it wasn't available. He ultimately had his tank removed and cleaned. It had over 10 gallons of crud in it it.
TSM35 is offline   Reply With Quote
Old 06-24-2014, 11:01 AM   #11
Senior Member
 
Coma's Avatar
 
Monaco Owners Club
Join Date: Nov 2010
Location: The Emerald Coast
Posts: 1,759
Quote:
Originally Posted by TSM35 View Post
I have a Winnebago Ultimate Freedom with an ISC 350 (the predecessor to the Vectra). I experienced the exact same issues over the course of 18 months with varying severity. After several trips to Cummins I finally purchased Insite and performed my own troubleshooting. The issue was a failing crankshaft position sensor. There are two of them and they are quite difficult to get to but after replacing them all my derate, stalling and starting issues were resolved. You should have codes when the engine derates so have cummins check again.

Your generator problems (and fuel filter issues) are a separate issue and sound like you may have algae in your fuel tank. A friend of mine with a Cummins 330 battled algae for a long time. There are some strong fuel additives that can help. Cummins use to make an algae additive but last time I tried to buy some it wasn't available. He ultimately had his tank removed and cleaned. It had over 10 gallons of crud in it it.
X2 on the sensors. There is another one, an oil pressure sensor. Somewhere in your vintage Cummins went to a switch for the ECM, I had multiple derates and warning light/stop lights, too. There is a separate sender for the dash oil pressure gauge.

I shock treat once a year and maintenance treat when in FL for algae. I still had the Aqua-Hot filter plug. The engine filters, I just changed, were clear when cut open.

Don't get discouraged on your ISC. It is a great motor, once you work through your issues.
__________________
Jim and Jennie, Cats=Bittles and Potter, 2000 Dynasty 350 ISC
2013 Silverado 4x4 Towed with R1200GS in bed.
PROV23:4 Do not wear yourself out to get rich; have the wisdom to show restraint.
Coma is offline   Reply With Quote
Old 06-25-2014, 09:05 AM   #12
Junior Member
 
Join Date: Jun 2013
Posts: 13
Quote:
Originally Posted by Coma View Post
I shock treat once a year and maintenance treat when in FL for algae. I still had the Aqua-Hot filter plug. The engine filters, I just changed, were clear when cut open.
How do you shock treat your fuel system? I just saw Power Service BIO KLEEN for the first time at Walmart but wasn't sure if it was any good. I used Cummins algea killer in the past but they don't sell it anymore. Ever since my CAPS pump went out I use Diesel Kleen Max HP formula to improve lubrication of metal and seals, it also really helps with power and makes the engine run much smoother. Our ISC's weren't designed for the low sulfur diesel so additives are a good idea and much to my surprise they really work.

I agree the ISC is a great engine however if it sits for too long sensors corrode and other bad things happen. Once a month when not in use I drive it 30 miles to the truck wash and get it cleaned just to run it for about an hour. I run the generator the entire time as well. Since doing this, especially in the winter, all my spring time squawks have gone away.
TSM35 is offline   Reply With Quote
Old 06-25-2014, 12:52 PM   #13
Senior Member
 
Coma's Avatar
 
Monaco Owners Club
Join Date: Nov 2010
Location: The Emerald Coast
Posts: 1,759
Quote:
Originally Posted by TSM35 View Post
How do you shock treat your fuel system? I just saw Power Service BIO KLEEN for the first time at Walmart but wasn't sure if it was any good. I used Cummins algea killer in the past but they don't sell it anymore. Ever since my CAPS pump went out I use Diesel Kleen Max HP formula to improve lubrication of metal and seals, it also really helps with power and makes the engine run much smoother. Our ISC's weren't designed for the low sulfur diesel so additives are a good idea and much to my surprise they really work.

I agree the ISC is a great engine however if it sits for too long sensors corrode and other bad things happen. Once a month when not in use I drive it 30 miles to the truck wash and get it cleaned just to run it for about an hour. I run the generator the entire time as well. Since doing this, especially in the winter, all my spring time squawks have gone away.
I have used a couple different brands, currently I have a Racor product. Maintenance dose is 1.25oz per 100 gal. Shock is double, 2.5 oz per 100 gal. I read somewhere that Optilube is the best lubricity adder. I will go to it when I use up my Stanadyne blue performance supply.

Agree on a monthly run, seems to keep the bogey men away.
__________________
Jim and Jennie, Cats=Bittles and Potter, 2000 Dynasty 350 ISC
2013 Silverado 4x4 Towed with R1200GS in bed.
PROV23:4 Do not wear yourself out to get rich; have the wisdom to show restraint.
Coma is offline   Reply With Quote
Old 06-29-2014, 02:18 PM   #14
Junior Member
 
Join Date: Aug 2013
Location: Home
Posts: 21
Thank You, All

I want to thank everyone who has taken the time to offer ideas, recommendations and encouragement. I find it scary how many things can go wrong.

We have dates with both Cummins in Spartanburg and Freightliner in Gaffney. Wish us luck.

Beryl and Bob
w/ Morgan and Moira (Newfoundlands)
'04 Winnebago Vectra 40AD
BandBRetired is offline   Reply With Quote
Reply

Tags
cummins



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cummins ISC valve train issues garberz Monaco Owner's Forum 42 09-16-2015 01:16 AM
Garmin 760 dezl lmt problems THERAPY GUY Newmar Owner's Forum 2 03-03-2014 01:03 PM
Cummins Supports Gvnmt Efforts to Develop GHG Standards for Medium and HD Vehicles DriVer RV Industry Press 0 02-18-2014 12:40 PM
EGR soot cleaning to have less replacement problems tom chelbana Cummins Engines 2 02-14-2014 09:09 PM
Cummins 2.8L TD Engine Powers Concept Vehicle DriVer RV Industry Press 1 02-06-2014 10:55 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.