Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2023, 06:07 AM   #1
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
FASS Pump Noise?

How many of you after installing and running it for some time experience a high pitch noise? I have some other weird sounds I canít explain here almost like debris in the particulate filter. FASS says itís normal and gives me answer it seems anytime I ask about it. Generally they say that can be normal? If the pressures are good donít worry about it. My pressure is good at 17 and amp draw around 5.7amp which is in its range of normal.
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-26-2023, 06:10 AM   #2
Senior Member
 
andy29847's Avatar
 
Join Date: Oct 2013
Posts: 1,611
Is you pump mounted using a rubber barrier?

I can hear mine if the engine is not running.
andy29847 is online now   Reply With Quote
Old 03-26-2023, 06:50 AM   #3
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
Yes and it didnít make any noises originally. Itís a high pitch noise not related to mounts.
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 08:37 AM   #4
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 13,186
Have you changed the filters at all???
When I changed mine the pump sounded a little different but then settled down.

Are the fittings tight, any chance it might be sucking air.

What about the return line, how did you do it?? Maybe run a temporary return back through your fill neck and see if the noise changes?


Although you say pressure is good, I wonder if something is partially blocking the suction line. You could pull the suction line off the fitting and stick it in the tank (after cleaning it really good) and see if that changes the sound.


What other variables can you easily check????
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 03-26-2023, 08:46 AM   #5
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
I plan on changing the water separator filter before leaving to go home from here in FL. I have both but will start with that one. The one tech said that noise is normal at times????? All whisper quite early on in the change over. Fittings seem to be tight return is the typical setup weíve all choose to do. Suggested I do the bucket test, but I donít want to get into that mess down here in Florida so I will be changing the water filter and see what goes on after that. I posted somewhere on one of these two sites that I blew a fuse on the motor while arriving at a campground 400 + miles into my trip and once I change the fuse, I drove another 600+ miles down here to Florida and never had another issue. If I remember correctly I didnít have the height pitch noise at that point. Iíll be changing that filter and report back. Just was curious if anyone else has experienced that noise.
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 09:02 AM   #6
Registered User
 
Join Date: Jan 2023
Posts: 353
Can't say I have heard a high pitch noise from my FASS. I do know when it is time to change filters, the noise is different. I always change both filters at the same time.
My son changes FASS filters in his truck about every 25k miles. I usually do it every 2 years, or when necessary. Like this year, got some bad fuel and went through 4 sets of filters in 1 week until the tank cleared. Carry an extra set!
Reprobate is offline   Reply With Quote
Old 03-26-2023, 09:08 AM   #7
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
Yeah this new install has about 1200 mi on them. They suggested changing the water filter first🤷 I get a different suggestion from everyone Iíve spoke to at FASS.
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 09:10 AM   #8
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
FASS Pump Noise?

Quote:
Originally Posted by jacwjames View Post
Have you changed the filters at all???
When I changed mine the pump sounded a little different but then settled down.

Are the fittings tight, any chance it might be sucking air.

What about the return line, how did you do it?? Maybe run a temporary return back through your fill neck and see if the noise changes?


Although you say pressure is good, I wonder if something is partially blocking the suction line. You could pull the suction line off the fitting and stick it in the tank (after cleaning it really good) and see if that changes the sound.


What other variables can you easily check????


I thought about pulling the feed line off the pump and blow down thru it into the tank to see if it clears it up?
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 09:11 AM   #9
Senior Member
 
Join Date: Apr 2018
Posts: 3,327
I changed the water separator first, didnít help, it was the primary filter clogging that caused the noise. I was at 14.5 lbs but the noise had been there for a month. Donít get cheap, I cut open the primary and it had black little pieces in it from my tank. I donít expect it again now that itís been cleaned.
__________________
2004 Dynasty 4
shootist is online now   Reply With Quote
Old 03-26-2023, 09:15 AM   #10
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
FASS Pump Noise?

Quote:
Originally Posted by shootist View Post
I changed the water separator first, didnít help, it was the primary filter clogging that caused the noise. I was at 14.5 lbs but the noise had been there for a month. Donít get cheap, I cut open the primary and it had black little pieces in it from my tank. I donít expect it again now that itís been cleaned.


Ok good to know, they said 14-18 is the psi range but said donít wait till it goes to 14.
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 09:16 AM   #11
Registered User
 
Join Date: Jan 2023
Posts: 353
Quote:
Originally Posted by tmw188 View Post
Yeah this new install has about 1200 mi on them. They suggested changing the water filter first I get a different suggestion from everyone Iíve spoke to at FASS.
That's too bad.
I only deal with the diesel performance shop that installed it, never talked directly with FASS.
I have to say, I have been impressed with the FASS overall. In my extended family, we have 6 FASS lift pumps in use. Never a problem with any of them.
You can hear them running when I switch on the key, but nothing after the engine is started. The noise I hear is just a normal hum.
I would have the installer recheck the installation (kinked lines, bad connections, excessive sealant on connections, etc.
I would still change both filters, just to eliminate that factor entirely. And you don't have to use FASS filters. I'm still not sold on the new water separator w/o the drain valve
Good luck and let us know the outcome.
Reprobate is offline   Reply With Quote
Old 03-26-2023, 09:26 AM   #12
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
FASS Pump Noise?

I was the installer whisper Quiet initially. Iím sure one or both filters might cure it. Yeah I donít like the new water separator filter either. Itís just a sponge basically🤷
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 11:51 AM   #13
Senior Member
 
tmw188's Avatar


 
Monaco Owners Club
National RV Owners Club
Workhorse Chassis Owner
Join Date: Dec 2013
Location: St. Charles MO
Posts: 4,912
Send a message via AIM to tmw188
Reprobate what water separator are you using in place of their filter? I know they mentioned you can use a different filter but without looking up the video or calling them I was curious if you have changed it. They mentioned the filter they use is an accumulative absorption type material.
__________________
2002 Monaco Windsor 40PST 2019 Equinox 1.5L, Blue OX Aventa LX tow bar, Roadmaster EZ5 baseplate, SMI Stay-In-Play Duo, TireSafeGuard TPMS
tmw188 is offline   Reply With Quote
Old 03-26-2023, 11:58 AM   #14
Senior Member
 
Alpine36's Avatar


 
Alpine Owners Club
Join Date: Oct 2019
Location: Hoodsport Wa
Posts: 2,703
Mine developed the high pitched whine after about 5,000 miles.
No drop in pressure whatsoever. Changed both FASS filters to the new, larger size. End of whine. I figure after 5,000 miles the tank contents have been filtered hundreds of times over.
__________________
2000 Alpine 36 FDS #74058
04 Jeep Wrangler TJ
"On the road to find out..."
Alpine36 is offline   Reply With Quote
Reply

Tags
noise, pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FASS pump--bypassing the lift pump Vanwill Cummins Engines 21 03-11-2023 03:22 PM
Fass fuel pump install Raybo Cummins Engines 57 06-01-2020 06:13 PM
Question For Those With a FASS Pump dons2346 Country Coach Owners Forum 2 05-29-2018 04:38 PM
Fass pump installation Raybo Spartan Motorhome Chassis Forum 9 07-15-2017 05:43 PM
AirDog Raptor, FASS or stock Carter lift pump noserider Cummins Engines 19 08-08-2015 06:26 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.