Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-29-2018, 07:29 AM   #1
Senior Member
 
Wanderer23's Avatar
 
Join Date: Aug 2017
Location: Paradise, Texas
Posts: 159
How to clear engine maintenence code

When I start the coach and activate my backup camera the TripTek system shows an engine maintenance blinking column and a small blinking oil symbol in the upper corner of the screen.

Engine oil was changed 300 miles ago. Cummins ISL 400

Dipstick level is fine. No oil leaks anywhere on or under the engine.

No oil or smoking in exhaust pipe.

Oil pressure is fine, both at idle and at running speed.

No start up dash indicator lights blinking or on.

How do I reset the maintenance page? I've tied RESET on the TripTek panel with no luck. It does, however, bring up a page asking for mileage by using the up and down arrows. It only then advances digit at a time...........???

I have no owners/operating manual for the TripTek.

Suggestions/advice will be greatly appreciated.

Thanks
__________________
Karen & Barry, Dogs Tinker & Toby
2007 American Tradition 42V, Cummins 400ISL,10KW Gen,Hydro Hot,TPMS,Garmin RV770,2017 Ram Lone Star 4x4 Toad,RVi3
Wanderer23 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-29-2018, 09:47 AM   #2
Senior Member
 
Join Date: Dec 2013
Location: Lake Havasu City, AZ & Plover, WI
Posts: 4,766
I do not have the Tripteck system, but what works on my Jeep is to disconnect the power to the computed for ten seconds. I just pull the negative cable from the battery. I'm sure there is a command that will do it, but until you know,,,,,,
__________________
2013 43 QGP Allegro Bus
2013 Avalanche
CJ7 Rock Crawler
Crasher is offline   Reply With Quote
Old 05-29-2018, 10:10 AM   #3
Senior Member
 
FIRE UP's Avatar


 
Join Date: Dec 2009
Location: Out there, somewhere
Posts: 9,049
Quote:
Originally Posted by Wanderer23 View Post
When I start the coach and activate my backup camera the TripTek system shows an engine maintenance blinking column and a small blinking oil symbol in the upper corner of the screen.

Engine oil was changed 300 miles ago. Cummins ISL 400

Dipstick level is fine. No oil leaks anywhere on or under the engine.

No oil or smoking in exhaust pipe.

Oil pressure is fine, both at idle and at running speed.

No start up dash indicator lights blinking or on.

How do I reset the maintenance page? I've tied RESET on the TripTek panel with no luck. It does, however, bring up a page asking for mileage by using the up and down arrows. It only then advances digit at a time...........???

I have no owners/operating manual for the TripTek.

Suggestions/advice will be greatly appreciated.

Thanks
Wanderer,
I have the Trip-tek and have cleared numerous "maintenance" codes for engine, trans, gen, etc. I'd have to dig around my manual for the Trip-Tek but, something in the back of this old feeble brain tells me it might be that once you toggle down to the blinking notice, you might have to hold both the up and down arrows at the same time to get it to the point where you can use the "Reset" to clear it. Or, even when you first start up the coach, hold both arrows to see where that takes you. Again, done it several times but, at the moment, can't quite jog the memory as to the procedure.
I'll dig around and find my online manual and see if I can get what you need.
Scott

On edit:
Ok, I found my manual in my files, here ya go:
Attached Files
File Type: pdf TripTek_2510_Manual.pdf (551.4 KB, 30 views)
__________________
2004 ITASCA HORIZON 36GD, 2011 GMC Sierra 1500 4x4 Toad '18 Honda Africa Twin Adventure Sports DCT
Retired-29.5 yrs, SDFD, Ham - KI6OND
Me, Karla and the Sophie character, (mini Schnauzer)
FIRE UP is offline   Reply With Quote
Old 06-06-2018, 07:36 AM   #4
Senior Member
 
Wanderer23's Avatar
 
Join Date: Aug 2017
Location: Paradise, Texas
Posts: 159
Still have those blinking indications for engine maintenance. Tried everything mentioned by your suggestions. Even called TripTek......useless.

Checked my generator too. Full serviced 3 months ago. Only 20 hrs running since then.

Guess I'll just ignore it and check my written down my maintenance dates, etc.
__________________
Karen & Barry, Dogs Tinker & Toby
2007 American Tradition 42V, Cummins 400ISL,10KW Gen,Hydro Hot,TPMS,Garmin RV770,2017 Ram Lone Star 4x4 Toad,RVi3
Wanderer23 is offline   Reply With Quote
Reply

Tags
engine



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Preventive Maintenence edaa53 Cummins Engines 8 03-27-2014 09:18 PM
Hitch maintenence already? Roll Toads and Motorhome Related Towing 2 09-07-2013 01:15 PM
maintenence tracking on a computer Graniteman Class A Motorhome Discussions 11 02-03-2012 01:15 PM
Busy weekend doing some maintenence. Pics the4js Winnebago Industries Owner's Forum 7 12-05-2011 10:01 PM
Differencial lube maintenence ozzy Workhorse and Chevrolet Chassis Motorhome Forum 4 09-14-2007 06:58 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.