Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-19-2010, 08:00 PM   #1
Senior Member
 
Essex-Spensive's Avatar
 
Join Date: Jun 2010
Location: New Stanton, PA
Posts: 240
ISX High Exhaust Temp Light ON

I have an ISX 650 Cummins. It only has 5,000 miles on it and the High Exhaust Temp Light comes on about every 50 miles and stays on for 50 to 75 miles. I am driving on the interstates and not doing any city driving. The regen light doesnt come on just the HEST light does. The book says it should but only on occassion and when in slow or stop and go traffic. I feel the fuel mileage is taking a beating when this happens also.

This just doesnt seem right, my 425 ISL only regenerated about every 5,000 miles.

Anyone else having these problems with the ISX engine?
__________________
Bill & Nancy
2019 Essex 4579
New Stanton, PA
Essex-Spensive is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-19-2010, 08:10 PM   #2
Senior Member
 
FlyingDiver's Avatar
 
Newmar Owners Club
Join Date: May 2007
Location: Somewhere....
Posts: 4,054
Never seen that light on mine. We're over 26k miles now.

joe
__________________
2008 King Aire 4562, Spartan K3(GT) w/ Cummins ISX 600
2014 Jeep Grand Cherokee Overland 5.7L V8 Hemi w/ Blue Ox Aventa LX Tow Bar and baseplate, SMI Air Force One brake
FlyingDiver is offline   Reply With Quote
Old 07-19-2010, 08:29 PM   #3
Senior Member
 
RVDude's Avatar
 
Join Date: Sep 2006
Posts: 1,339
Maybe a call to Cummins might be the best place to ask?
You got 5yr warranty on that beast and it's brand new.
__________________
2007 and 7/8ths Newmar Essex 4502
RVDude is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Temp Batteris bsellers Winnebago Industries Owner's Forum 2 03-11-2010 10:18 PM
TST High Temp Problem Nonno MH-General Discussions & Problems 9 06-25-2009 10:08 PM
Exhaust Brake switch night light bullydogs1 Monaco Owner's Forum 6 06-11-2009 09:23 AM
Exhaust brake inoperative Happycarz Monaco Owner's Forum 34 05-27-2008 05:18 PM
Temp gauge vs idiot light accuracy Jim&MaryJo Alpine Coach Owner's Forum 8 08-18-2006 02:31 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.