Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2014, 08:23 AM   #1
Senior Member
 
Bill2's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Jan 2009
Location: Somewhere on the road
Posts: 609
Loss of power momentarily ISL 380

While driving down the interstate we suddenly lost power and the gauges went back-and-forth this only happened 2 times and it was like seconds then the power came back and we went on down the road this is on a 2014 Phaeton ISL 380 Cummins engine I stopped at a Cummins shop and they say it sounds like a wiring problem they couldn't look at it now so I went on down the road. My question is has anyone else had this kind of problem?
Thanks in advance
Bill
__________________
Bill O'Dell,Retired U.S. Army, Retired LEO, 2014 Tiffin, Phaeton, QBH, 2023 Chevrolet Taho 4x4 Extended Cab
Bill2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-10-2014, 08:31 AM   #2
Senior Member
 
algolfer's Avatar
 
Join Date: Aug 2013
Location: Cameron Park, California
Posts: 150
I had the same problem. Happened twice in about 2,000 miles. Took it into the shop and they checked out the wiring but could not find anything. Hooked up their computer and found some old codes. Cleared out the codes and have not had the problem in over 5,000 miles.
algolfer is offline   Reply With Quote
Old 06-12-2014, 07:36 AM   #3
Senior Member
 
Bill2's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Jan 2009
Location: Somewhere on the road
Posts: 609
Thanks for the reply I was hoping for more
__________________
Bill O'Dell,Retired U.S. Army, Retired LEO, 2014 Tiffin, Phaeton, QBH, 2023 Chevrolet Taho 4x4 Extended Cab
Bill2 is offline   Reply With Quote
Old 06-12-2014, 08:24 AM   #4
Senior Member
 
BeltoneMagoo's Avatar
 
Monaco Owners Club
Join Date: Mar 2011
Location: Texas
Posts: 400
Has it been sitting awhile? Are you sure of your fuel sources? I would change my fuel filters for a start. I have had a similar problem in the past that I am sure was caused by water in the fuel. It wasn't enough to light the dash light but it sure caused some concerns.
Good luck and safe travels!
__________________
Doug & Connie
2001 Holiday Rambler Imperial 41ft PBD 370hp ISL AF1 braking system
2001 Subaru Forester manual toad
BeltoneMagoo is offline   Reply With Quote
Old 06-12-2014, 08:36 AM   #5
Senior Member
 
PushedAround's Avatar
 
Tiffin Owners Club
Join Date: Sep 2012
Location: Ambler, PA
Posts: 2,853
Blog Entries: 7
I would check the battery connections and the grounds. It seems like a system wide problem, so start where the power comes from first. If not that, then maybe the ignition switch or associated wiring.
__________________
Larry & Cheryl Oscar, Louie, Ranger & Henry (our Springers)
PushedAround is offline   Reply With Quote
Old 06-14-2014, 03:53 PM   #6
Senior Member
 
britcon's Avatar
 
Join Date: Mar 2011
Posts: 754
Had a similar issue with my 2014 Ventana with ISL 400 in Freightliner chassis. Pulled out of our camp space, and while hooking up the toad, gauges went crazy flipping back and forth, red check engine light on. Engine was running fine at idle. Tried shutting down and restarting - still had problem. Called freightliner and they had me read the codes, said it was computer related, but couldn't tell for sure what the issue was. Told me it was OK to drive into Freightliner in Phoenix ( 80 Miles ). Next day started up to head in for service and everything was normal. Freightliner spent 4 hours going thru wiring harness - they could see the codes but could not find any loose connections or other wiring issues. Told me OK to drive - if it happens again try to get to shop while still having issues ( with no Tach, or Speedo ?? ) So far, with another 3000 miles on clock, has not recurred.
__________________
2014 Newmar Ventana 4037 / 4018
2015 Jeep Grand Cherokee Ltd.
1940 Chevrolet Pickup
britcon is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of power ARFFMAN Ford Motorhome Chassis Forum 19 04-11-2014 07:48 PM
2003.Discovery help no ignition power Alanboss Class A Motorhome Discussions 3 03-28-2014 07:05 AM
No power to coach unless RV is running dvleemin Class A Motorhome Discussions 9 03-27-2014 08:33 PM
No DC power to motorhome glow4004 Monaco Owner's Forum 12 12-02-2013 10:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.