Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2021, 03:25 PM   #1
Junior Member
 
Join Date: Jun 2016
Posts: 22
Sporadic codes 2006 Freightliner 5.9

Coach has about 38k on it, codes started happening just doing down the freeway. It's odd because every time I check it, the codes are different, coach seems to run fine, doesn't smoke. The codes are there an active even if the ignition is on but the engine has't been started.

I've check all the grounds I could find, they all seem tight. I have two constant codes, but they change every time I check them. The are both always "out of calabration and Mech System not responding". The codes I've gotten are as follows. I've tried tracking them down, but don't find any info on any of them via google:

2111 mech system not responding
2111 Out of Calibration
next run cycle this was replaced with
24639 out of calibration
24639 mech system not responding
Next key cycle
-22465 out of Calibration
-22465 mech system not responding
Next Key cycle
-18369 out of calibration
-19369 mech system not responding
next key cycle
-32657 out of calibration
-32657 mech system not responding
and etc..........

I've also removed all power to the coach/eng for 20 minutes to rest the computer, no luck, still spawning random codes.

I've unplugged the EGR connections which increases the code count, and those go away after I plug them back in. Same with the VGT turbo connector, I just haven't been able to find what's causing these randomly odd constant codes.

Any help would be greatly appreciated.

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-04-2021, 10:05 AM   #2
Junior Member
 
Join Date: Jun 2016
Posts: 22
Quote:
Originally Posted by Nitro71455 View Post
Coach has about 38k on it, codes started happening just doing down the freeway. It's odd because every time I check it, the codes are different, coach seems to run fine, doesn't smoke. The codes are there an active even if the ignition is on but the engine has't been started.

I've check all the grounds I could find, they all seem tight. I have two constant codes, but they change every time I check them. The are both always "out of calabration and Mech System not responding". The codes I've gotten are as follows. I've tried tracking them down, but don't find any info on any of them via google:

2111 mech system not responding
2111 Out of Calibration
next run cycle this was replaced with
24639 out of calibration
24639 mech system not responding
Next key cycle
-22465 out of Calibration
-22465 mech system not responding
Next Key cycle
-18369 out of calibration
-19369 mech system not responding
next key cycle
-32657 out of calibration
-32657 mech system not responding
and etc..........

I've also removed all power to the coach/eng for 20 minutes to rest the computer, no luck, still spawning random codes.

I've unplugged the EGR connections which increases the code count, and those go away after I plug them back in. Same with the VGT turbo connector, I just haven't been able to find what's causing these randomly odd constant codes.

Any help would be greatly appreciated.

--Rich
Dang... 55 Views and nothing. I knew this would be an odd issue, but I wasn't hoping not this odd...... Any help would be greatly appreciated.

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 10-04-2021, 01:31 PM   #3
Senior Member
 
Join Date: Jul 2018
Posts: 190
Those donít look like actual Cummins fault codes. ?
randomledder is offline   Reply With Quote
Old 10-04-2021, 02:00 PM   #4
Junior Member
 
Join Date: Jun 2016
Posts: 22
Yeah, but those are the SPN's the built in dash monitor is showing under the "Service" section.
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 10-04-2021, 06:32 PM   #5
Senior Member
 
Join Date: Jul 2018
Posts: 190
Sporadic codes 2006 Freightliner 5.9

I tried crossing them. They donít even make sense as SPN numbers. What is your ESN?
randomledder is offline   Reply With Quote
Old 10-04-2021, 07:53 PM   #6
Junior Member
 
Join Date: Jun 2016
Posts: 22
Quote:
Originally Posted by randomledder View Post
I tried crossing them. They donít even make sense as SPN numbers. What is your ESN?
It's the unit that came with the coach as part of the dash, I forget the name of it.

Something interesting to note that I discovered tonight, If I pull a connector of, so the EGR Temp sensor, it will then show 3 codes, but all three codes are the same, sometimes it's the right code, but sometimes it's the -xxxxx code (all 3 of them).

So weird.
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 10-05-2021, 08:23 AM   #7
Junior Member
 
Join Date: Jun 2016
Posts: 22
Quote:
Originally Posted by Nitro71455 View Post
It's the unit that came with the coach as part of the dash, I forget the name of it.

Something interesting to note that I discovered tonight, If I pull a connector of, so the EGR Temp sensor, it will then show 3 codes, but all three codes are the same, sometimes it's the right code, but sometimes it's the -xxxxx code (all 3 of them).

So weird.
The above happens with any connector that's pulled, I was just using the EGR temp sensor an example.

Another thought I just had is what are the checks that are performed with the Key on without the engine started? I get an active SPN with the key on, it comes up within two seconds of turning the key on.

--Rich
Nitro71455 is offline   Reply With Quote
Old 10-22-2021, 11:42 AM   #8
Junior Member
 
Join Date: Jun 2016
Posts: 22
Update,

I went for a trip and caught valid codes while going down the road. It seems the VP is going out on the turbo, I was getting SPN 641's that were changing to the weird codes as they were clearing out for some reason.

Symptoms, low on power until about 25mph
Jake Brake does't work like it should.

With that said, what's the recommended turbo for a 06, 5.9 with VP? Something that offers a bit more power would be great, but if it needs to stock so be it as well.

Thanks everyone.

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Reply

Tags
freightliner



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Aire slides wonít Come in and jacks sporatic Rdhplano Newmar Owner's Forum 2 07-25-2018 03:55 PM
Sporatic water pump macthick Country Coach Owners Forum 1 09-24-2017 04:17 PM
Engine ecm codes with chassis battery off will codes be saved smballou Cummins Engines 2 02-26-2017 12:39 PM
Check engine light freightliner with no codes Farmer Steve Newmar Owner's Forum 9 08-13-2015 01:06 PM
Sporatic electric problem in 99 Executive GregHensel Monaco Owner's Forum 3 06-27-2013 02:00 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.