Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Cummins Engines
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2022, 03:41 PM   #1
Junior Member
 
Join Date: Nov 2019
Posts: 14
Sudden power loss, white smoke and CEL on.

RV was running fine and strong, arrived at camp site and had to climb small, uneven incline. When we tried to maneuver into our spot we lost engine power, had white smoke and check engine light came on.

After some playing around by a couple of mechanics on site, we were able to leave the camp site but still had intermittent power loss accompanied by check engine light. It generally ran fine for the 10 mile ride home but here and there the light came on and we had obvious momentary power loss.

Now we are parked in driveway and we still have white smoke and check engine light at idle. Starts fine, idles fine, revs fine in park.

RV has 55000 miles. Recently changed lift pump, fuel lines, fuel filter, overflow return valve. 5.9 Cummins 24v ISB pusher/Allison Tranny. 1999 Winnebago Adventurer. Boost gauge was showing boost on the way home. Mechanics opened turbo housing and determined turbo was ok and disconnected air filter and we still had the problem. Full tank of fuel with recent Diesel Mechanic in a Bottle treatment added at fill up. Also, smoke is real strong and burns eyes, acrid smelling.
2019rvlife is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-14-2022, 09:57 PM   #2
Senior Member
 
Join Date: Jul 2018
Posts: 289
What code is the check engine light?
randomledder is offline   Reply With Quote
Old 07-15-2022, 08:48 AM   #3
Senior Member
 
Join Date: Dec 2013
Location: Lake Havasu City, AZ & Plover, WI
Posts: 5,793
White smoke usually means anti freeze getting into the combustion chamber. Have you checked your radiator level?
__________________
2013 43 QGP Allegro Bus ( SOLD )
2013 Avalanche
2000 AEV TJ
Crasher is offline   Reply With Quote
Old 07-15-2022, 05:49 PM   #4
Junior Member
 
Join Date: Nov 2019
Posts: 14
Original code info was generally injector or fuel related. I think pin 11 was mentioned. I checked with tech today and he doesn't have the info saved so he is going to check it again as soon as he can get back here. Next time I will capture that info for future reference.

He seemed to think it was some type of electrical issue since this problem seems to be intermittent and came on suddenly. Today I noticed smoke was intermittent at idle and CEL didn't come on right away. It came on after 7-10 minutes of idling.
2019rvlife is offline   Reply With Quote
Old 07-15-2022, 05:54 PM   #5
Junior Member
 
Join Date: Nov 2019
Posts: 14
Also, oil has no foam or water in it. No smell of antifreeze with exhaust. Just acrid smoke.
2019rvlife is offline   Reply With Quote
Old 07-19-2022, 09:03 PM   #6
Junior Member
 
Rcook1956's Avatar
 
Join Date: Sep 2021
Location: Allison Park, Pennsylvania
Posts: 26
White smoke with power loss

I had the same problem with my Cummins and it turned out to be the injection pump. The lift pump had been replaced previously but I installed a Fass system but still white very acrid smoke and power loss. So the injection pump was next, hard job but doable. I did all the work myself so I saved a bundle.
Rcook1956 is offline   Reply With Quote
Reply

Tags
power, power loss



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 ISB white smoke at Idle & black smoke on acceleration Pschweizer Cummins Engines 16 03-23-2022 07:00 PM
Sudden Electrical Power Loss JPL2 Newmar Owner's Forum 13 03-13-2016 08:15 AM
1997 3126 white smoke and power loss Big11beard Caterpillar Engine Forum 6 06-16-2015 03:08 PM
sudden loss of all power - help! BudtheDiplomat Monaco Owner's Forum 11 03-04-2011 11:20 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.