RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Caterpillar Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-21-2020, 02:28 PM   #1
Senior Member
 
Join Date: Oct 2009
Posts: 909
Cat dies throttle over 1500rpm little help please

07 C15 Cat. Been sitting for a few months in storage. Getting ready to head south for winter. Picked up from storage. Ran fine for maybe 5 miles and then engine just died. Started up and would run fine until I gave more throttle above 1500rpm. Engine would just die like it was starved for fuel??Limped home and put in fuel additive. Let idle through 25 gallons of fuel. Added more additive and 60 gallons of fresh diesel. Headed to shop to have oil change. Same thing, ran fine for 8 miles then just died. Limpted to service center running under 1500 rpm. That service center doesn't work on RVs? Center that does 25 miles away. Limpted for 20 miles below 1500 rpm. Last five miles she ran fine 2000 rpm. I'm still convinced it is bad fuel.
Any thoughts guys? Oh forgot to add, the generator, in storage would run for awhile then die also. After additive and fresh fuel it would run fine and not die.

Thanks in advance for any suggestions
FLYING BUTCH is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-21-2020, 03:00 PM   #2
Senior Member
 
Join Date: Oct 2009
Posts: 909
Found out it was an oil sensor. In case anyone else has same problem.

Safe travels all
FLYING BUTCH is offline   Reply With Quote
Old 10-21-2020, 03:20 PM   #3
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 5,306
Doesn't make sense that the Generator would die too - if it all due to a bad engine oil pressure sensor. I think you may have two problems. Perhaps contaminated fuel. Could be algae in the fuel tank.

I would change the engine fuel filters to be safe - although clogged engine fuel filters would still not explain the generator shutting down. Possibly you need to change the Gen fuel filter too now.

Did the engine "check Engine" light come on? I would expect there to be a warning light and a fault code for the oil pressure sensor failure.

Good luck
__________________
Mike --- 2005 Beaver Patriot Thunder CAT C13 525HP, Vicksburg 42ft, with HydraLift ---
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 10-22-2020, 11:11 AM   #4
Senior Member
 
Join Date: Oct 2009
Posts: 909
1500

Not the sensor. Still dies. Cat service can not find problem??
FLYING BUTCH is offline   Reply With Quote
Old 10-22-2020, 11:24 AM   #5
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 21,306
Have you changed fuel filters ?

Your issue and time line in storage sounds like classic , filter issues .
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 10-22-2020, 06:21 PM   #6
Senior Member
 
Join Date: Oct 2009
Posts: 909
Changed all the filters. Cat dealer said it kept shutting off when they tried to drive around lot. No fault light. I did get fault light a couple times after it had died and sit for awhile. Cat dealer said they couldn’t get it started once after it died. This afternoon they drove it for an hour with no problems??? Really odd
FLYING BUTCH is offline   Reply With Quote
Old 10-22-2020, 06:58 PM   #7
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 21,306
Time to start looking for the really weird possibilities .

For an number of years Freightliner chassis used a third fuel filter /strainer , more of a debris catcher , in the fuel line before the primary filter water separator. It was in the supply line above the rear suspension .
Can't overlook a problem in the fuel tank that could be partially blocking the pick up tube . Big clump of something that gets pulled against the pick up once in a while .
Bad fuel filler caps , does your coach build pressure in the fuel tank the way mine does ?

Does your fuel system have a manual primer pump ; once the engine stalls can you use the primer pump to help start it ?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is online now   Reply With Quote
Old 10-22-2020, 08:50 PM   #8
Cat
Senior Member
 
Join Date: Jan 2005
Posts: 1,173
Try changing Heui actuation pressure sensor. Its a cheap troubleshooting try. It can cause intermittent problems.
Cat is offline   Reply With Quote
Old 10-23-2020, 05:41 AM   #9
Senior Member
 
Join Date: Oct 2009
Posts: 909
run

Thanks for all the posts guys. I will be passing's g on to the Cat dealer. There is no problem with engine starting right back up. I don't think my gas tank builds up pressure. I don't have books on rv. Not sure if it is a freight liner chassis? 07 Beaver Marquis
FLYING BUTCH is offline   Reply With Quote
Old 10-23-2020, 07:57 AM   #10
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 5,306
The Beaver uses the Roadmaster S-series chassis.

I'm surprised that Cat shop cant figure it out, especially since it died on them and would not immediately restart. That would be the time to verify fuel pressure and check for the injector "firing signal". And with the CAT ET scan tool they should be able to see everything ECM related and review the history of just prior to the shutdown.

Here's a video on troubleshooting a "no start" on CAT. Maybe your mechanic should watch it.

__________________
Mike --- 2005 Beaver Patriot Thunder CAT C13 525HP, Vicksburg 42ft, with HydraLift ---
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 10-23-2020, 08:57 AM   #11
Senior Member
 
Join Date: Oct 2009
Posts: 909
Generator is running fine. No fault codes show up when engine dies. Engine just flat dies when applying more throttle. Will start right back up. Drive under 1500 rpm no problem. Give a little throttle and dies like you turned the key off. Now that is most of the time. Drove it 20 miles under 1500 rpm then gave it more throttle and ran fine. Again yesterday at cat dealer kept shutting down. when they were driving around their lot. Then they took it out and it ran fine for an hour?? They said once they couldn’t get it started and the got a “no power at the key switch@ reading. They had trouble getting it started. I have never had a problem getting it restarted. Don’t know why they replaced the sensor but that didn’t do anything for running problem
FLYING BUTCH is offline   Reply With Quote
Old 10-23-2020, 04:52 PM   #12
Senior Member
 
CountryB's Avatar
 
Monaco Owners Club
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 5,306
Quote:
Originally Posted by Cat View Post
Try changing Heui actuation pressure sensor. Its a cheap troubleshooting try. It can cause intermittent problems.
He has a C15.
__________________
Mike --- 2005 Beaver Patriot Thunder CAT C13 525HP, Vicksburg 42ft, with HydraLift ---
*SMC-Bvr-Mnco History/Chassis Info https://1drv.ms/f/s!AtvAXw_lfqbToxXYREK9YdBP08Jn
*SMC-Bvr-Mnco Wiring Diagrams https://1drv.ms/f/s!AtvAXw_lfqbTm0WTuuNqpn9a8hCh
CountryB is offline   Reply With Quote
Old 10-25-2020, 10:08 AM   #13
Senior Member
 
Join Date: Oct 2009
Posts: 909
Cat dealer replaced fuel pressure sensor ($35 amazon-cat $165?) labor $1375 WTF!! Anyone know how long it could possibly take to replace this sensor? Worst thing it didn't cure the problem. Picked it up Saturday and of course died several times while I limpted to a truck shop. Don't know if it is related but Cat tech said once when they were driving it it died with their computer hooked up to it, they got message "no power to key switch". Just noticed no head lights and no cruise control. All coming out of smart wheel?? Wonder if there is a connection. It just dies like someone turned off switch. Now it does it at all speeds above idle. Lots of fault code warnings showing up.
Thanks to listening to sorry. Imagine you all have been there at one time or another.
Any ideas guys?

safe travels
FLYING BUTCH is offline   Reply With Quote
Old 10-25-2020, 12:07 PM   #14
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,468
Could be the clock spring. A guy I know has an 07 CC and he had to replace his, no wipers, no cruse, no lights. They say everything goes through the smart wheel. and turn signal controller.

2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Reply

Tags
cat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ONAN 5500 Start but then dies...throttle controller? TwoDog RV Systems & Appliances 3 01-21-2020 12:41 PM
Cat expert HELP 3126 kitty idles fine will not throttle up dmorris189 Freightliner Motorhome Chassis Forum 25 02-13-2016 05:45 AM
starter battery dies..and dies artro Newmar Owner's Forum 4 08-10-2007 11:37 AM


All times are GMT -6. The time now is 08:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.