Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Caterpillar Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-23-2014, 02:41 PM   #1
Senior Member
 
DragRacer68's Avatar
 
Join Date: Apr 2013
Location: Missouri
Posts: 168
Help! Started losing power steering

Started hearing a intermittent squealing and then started losing power steering. Hydraulic reservoir is magically empty. Added 2 gallons still not on dipstick. No visible leaks. Can the hydraulic pump leak into the engine? Oil level is high. Help, out on the road now. Thanks.
__________________
2000 Newmar Dutch Star 3858 Freightliner chassis 300hp CAT engine
DragRacer68 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-23-2014, 03:01 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 19,927
Is your engine oil level 2 gallons over-filled? Does your hydraulic pump, besides powering the steering also power the cooling fan? I'm not sure the crankcase and power steering could ever mix. Have you identified the origin of the squealing? Are the belts all at proper tension?

I wouldn't just put more fluid in until you figure out where the other disappeared, too much chance of major damage possible.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 05-23-2014, 03:31 PM   #3
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by DragRacer68 View Post
Started hearing a intermittent squealing and then started losing power steering. Hydraulic reservoir is magically empty. Added 2 gallons still not on dipstick. No visible leaks. Can the hydraulic pump leak into the engine? Oil level is high. Help, out on the road now. Thanks.
DragRacer68
Sorry to hear of your problem.
I don't think the hydraulic power steering fluid can get into the engine.

In any case, it might be better to ask that question on the Freightliner Motorhome Chassis Forum - iRV2 Forums or on the Newmar Owner's Forum - iRV2 Forums.
(IMO that is not as much a "Cat engine problem" as it is a "Freightliner chassis problem").
Good luck.
Mel
'96 Safari
mel s is offline   Reply With Quote
Old 05-24-2014, 03:24 AM   #4
Senior Member
 
stink's Avatar
 
Join Date: Apr 2012
Posts: 1,414
If your ps pump is like mine, its mounted on the rear of the air compressor. If a seal blowes between the ps pump and the air compressor fluid might get thru into the crankcase thru the air compressor.
__________________
Dave and Laura & two cats
02 Discovery with Accord toad
retired auto rv tech and teacher, wife rt nurse
stink is offline   Reply With Quote
Old 05-26-2014, 02:39 PM   #5
Senior Member
 
DragRacer68's Avatar
 
Join Date: Apr 2013
Location: Missouri
Posts: 168
Thanks guys. Managed to get it parked back at home. Pretty sure it's leaked into the engine. Gotta look into getting it off and replacing the seal or the entire pump now. Doesn't look too bad to get to.
__________________
2000 Newmar Dutch Star 3858 Freightliner chassis 300hp CAT engine
DragRacer68 is offline   Reply With Quote
Old 05-27-2014, 10:40 AM   #6
Senior Member
 
akeyzoo's Avatar
 
Join Date: May 2013
Posts: 961
Where would 2 gallons go in your engine? Notice excess oil from slobber tube? Notice anything different about your crankcase oil? I presume you rig is a rear radiator, my hydraulic pump runs my fan and PS. Yours likely just PS.

You say it isn't leaking because you never see any on ground or? Reason I ask is that it could perhaps be a line or the steering gear box itself and thus no fluid in engine bay.

Good luck!

Chris
__________________
------------------------------------
American Revolution 40L CAT C9
Samsung 197, TireMinder, Ready Brute Elite with Wrangler
akeyzoo is offline   Reply With Quote
Old 05-27-2014, 10:47 AM   #7
Senior Member
 
DragRacer68's Avatar
 
Join Date: Apr 2013
Location: Missouri
Posts: 168
Well, the engine oil level is WAY full on the dipstick....like 3"+ too high. I have a side radiator with hydraulic fan so I'd say it powers that along with the steering. The hydraulic pump bolts to the back of the air compressor which is bolted to the engine. Spoke to Freightliner....no rebuild, only new pump is an option according to them. Bargain price on new pump...$1300 roughly....Plus labor to replace, plus engine oil change. Damn. :(
__________________
2000 Newmar Dutch Star 3858 Freightliner chassis 300hp CAT engine
DragRacer68 is offline   Reply With Quote
Reply

Tags
power, steering



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Uugghhh... No power but shore power TPLI Class C Motorhome Discussions 22 05-08-2014 09:41 PM
Banks Power Ultimate RV Power System - any experience? Dusterella Toads and Motorhome Related Towing 5 04-11-2014 02:38 PM
2003.Discovery help no ignition power Alanboss Class A Motorhome Discussions 3 03-28-2014 07:05 AM
Discovery: Power Steering Fluid JMA1181 Fleetwood Owner's Forum 2 08-12-2013 09:40 AM
No House Power until I started the engine AnimalCop Class A Motorhome Discussions 6 07-14-2013 01:28 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.