Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Caterpillar Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-24-2017, 05:16 PM   #1
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,531
No oil pressure but I have oil pressure

A few months back I got a new oil pump installed at Peterson Cat in Portland to fix my high oil pressure at startup of 130psi down to 87psi, that part works great. I had another problem just before that where the oil pressure would jump to 86psi on my Silverleaf and 40psi on the dash gauge then it would go all over the place (silverleaf only) down to Opsi sometimes so I changed out the oil sender to the ECM, 3 wire setup. I thought I had fixed the problem.
2 weeks ago we headed to Steamboat Rock State Park a 800mi round trip and about 30mi out my Silverleaf started to do the same thing, oil pressure all over the place so I pulled over and turn it off for a minute then everything was good for the rest of the trip there.
When we started home about 20 minutes later my oil pressure went to O the the Stop and Check Engine light came on and started to defuel then would go to 3psi or so then start to go again so I found a place to pull over then it died but the dash oil pressure was reading 20psi. Restarted and took about 5 minutes setting there started to look better and I got back on the road. Drove 300mi no problems running 47 to 50psi on both gauges.
I think there is a problem with the ECM, what do you all think.
Will try and post pictures of my cell phone.
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-24-2017, 05:24 PM   #2
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,531
Here are a few pictures
Click image for larger version

Name:	20170914_152251.jpg
Views:	117
Size:	58.6 KB
ID:	177701Click image for larger version

Name:	20170914_152237.jpg
Views:	112
Size:	75.3 KB
ID:	177702
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Old 09-25-2017, 07:48 PM   #3
Registered User
 
Join Date: Oct 2010
Posts: 1,446
put a mechanical gauge on it and see what's really going on.
VanDiemen23 is offline   Reply With Quote
Old 09-25-2017, 07:54 PM   #4
Senior Member
 
saddlesore's Avatar


 
Foretravel Owners Club
Join Date: Apr 2016
Location: Home is Where WE PARK IT...
Posts: 4,997
Relief valve in the engine oil pump could be sticking open....
__________________
Retired truckdriver, Full Timing in a Foretravel.
Escapees of Box Elder, South Dakota
....Whether our shack is moving or parked.. We are still home.
saddlesore is offline   Reply With Quote
Old 09-25-2017, 10:20 PM   #5
Cat
Senior Member
 
Join Date: Jan 2005
Posts: 1,270
Is it possible you have 2 oil pressure sensors? Unplug the sensor you replaced and see if your silverleaf gauge goes to zero. Although possible its not likely the ECM is the problem. Most likely its the wiring to the sensor-- do you have any diagnostic codes for oil pressure sensor?
Cat is offline   Reply With Quote
Old 09-26-2017, 08:11 PM   #6
Senior Member
 
2 Stroker's Avatar
 
Join Date: Nov 2009
Location: Warren, Oregon
Posts: 2,531
Quote:
Originally Posted by Cat View Post
Is it possible you have 2 oil pressure sensors? Unplug the sensor you replaced and see if your silverleaf gauge goes to zero. Although possible its not likely the ECM is the problem. Most likely its the wiring to the sensor-- do you have any diagnostic codes for oil pressure sensor?
Cat, could it be that I have 3 oil pressure sensors, well I do. Could not see the third sender I have all the books and it only shows 2 sender and I replaced the one I thought went to the ECM. I went to Peterson on Monday and showed the same guy that I worked with on my oil pump, about 2hrs of his time and I showed him the sender I changed and he said that is not a Cat sender
So he got on the PC and gave me all the info I needed, O rings and sender so I installed everything today, ran for about 1 hour so far it looks good. Will take it on a run in the morning, about 50 miles. I think it will be OK.
Thanks for the help on the oil pump Cat and the info on my motor.
2 stroker
__________________
2006 Country Coach Inspire 360 40ft Genoa Designer Series, Samsung 197 RR
Cat C9--STEEL & COPPER Bolt Together Radiator w/ updated rubber mounting
SilverLeaf 330 Magnum 2812 PSW 2011 Ford Edge Sport-Air Force One
2 Stroker is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
*sob* But.. but.. BUT I DON'T WANNA go home! MTSam Outdoors RV Owner's Forum 31 09-04-2018 05:46 AM
Sorry, but I can't help but ask SissyBoyBob 5th Wheel Discussion 27 05-15-2015 12:21 PM
Low oil pressure | erratic oil pressure | inconsistant oil pressure GlennLever Cummins Engines 45 08-28-2014 09:24 AM
Have no idea where to put this to attract attention, but I have fridge issues!! Mikey-KE7LBB RV Systems & Appliances 11 10-22-2011 11:40 AM
Water Pressure This is what I am using!!! But looking for a Pressure regulator??? Latitude MH-General Discussions & Problems 17 06-13-2008 06:35 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.