Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > POWER TRAIN GARAGE FORUMS > Powerstroke Engine Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-26-2014, 08:58 PM   #1
Member
 
jimws's Avatar
 
Join Date: Feb 2012
Posts: 61
2007 F350 6.0 l - check engine warning icon

Pulling my camper approx. 2 hrs on I- 95 & stopped at rest area & shut off engine. Started engine approx 15 min. later & check engine icon is lit & remains lit. Engine runs good, turbo boost appears good, no noticeable change in performance. Checking maint. manual it says to let the truck idle 5-10 mins after pulling at high speed. Did I screw something up when I shut the engine down?
__________________
2015 Ford F-350 DRW pulling a 2012 Mobile Suite 36TKSB3
Life is short, don't worry, be happy & God Bless
Jim & Sallie
jimws is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-26-2014, 09:10 PM   #2
Senior Member
 
Foretravel Owners Club
Join Date: Apr 2010
Posts: 511
Had similar issue with the 2011 6.7, it was erratic, come on for a day and off for a few days, then back on, took to Ford dealer (warranty) they replaced the EGR assy and solved the issue.
No idea if related to your case. But a quick scan at Ford will tell the story.
Dave M
Genset is offline   Reply With Quote
Old 04-26-2014, 10:41 PM   #3
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
You need something to scan. A CEL is a major code. Get the Torque app or a ScanGaugeII to find something out.
jesilvas is offline   Reply With Quote
Old 04-27-2014, 09:41 PM   #4
Senior Member
 
wingnut60's Avatar
 
Join Date: Aug 2004
Location: Wherever we are
Posts: 4,155
Shouldn't have been the quick shutdown--lot of people drive the same way with no problems. As said above, have the codes read.
Joe
__________________
'16 40QBH Phaeton
'15 38RSSA Mobile Suites--traded
'05 36TK3 Mobile Suites--retired but not forgotten
wingnut60 is offline   Reply With Quote
Old 05-01-2014, 02:58 PM   #5
Member
 
jimws's Avatar
 
Join Date: Feb 2012
Posts: 61
Thanks for the feedback. I was fortunate & found a ford certified master mechanic & he fixed me up. Problem centered around the EGR & found I had a fan clutch problem as well.
__________________
2015 Ford F-350 DRW pulling a 2012 Mobile Suite 36TKSB3
Life is short, don't worry, be happy & God Bless
Jim & Sallie
jimws is offline   Reply With Quote
Old 06-21-2014, 06:46 AM   #6
Senior Member
 
broadrun's Avatar
 
Monaco Owners Club
Join Date: Jul 2012
Posts: 700
It's always the EGR with these 6.0's. Trust me, I have two (Excursion and Super Duty). Part of my once a year maintenance routine now is to pull the EGR valve and clean it to ensure the valve opens freely without sticking at all.

So far this has worked for me. Both my vehicles are still throwing the P0299 and P0299P so I still have some work to do...

-Rob
broadrun is offline   Reply With Quote
Old 08-02-2014, 05:48 PM   #7
Senior Member
 
Join Date: May 2014
Location: Huntsville, AL/Helen, GA
Posts: 1,401
I paid $75 twice at a diesel shop this year on a cold start issue. I could have saved $ by running by Advance Auto Parts or AutoZone and they would have read the same codes for free. That's my place to start with problems.

Call me cheap. Sometimes their diagnosis works, and sometimes it doesn't.
Bamaman is offline   Reply With Quote
Old 08-04-2014, 05:44 PM   #8
Senior Member
 
Thor Owners Club
Join Date: Jun 2011
Posts: 2,893
On those 6.0 I would replace the oil cooler as well. We had an 06 F350 SD and I had a mountain of issues with it.....thankfully all covered under the Ford extended warranty.
Fred1609 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Check engine light on Lloydu Newmar Owner's Forum 57 10-08-2014 02:52 PM
Engine Won't Start, etc. rv dreamer National RV Owner's Forum 7 03-16-2014 11:57 AM
check engine light???? offshore Workhorse and Chevrolet Chassis Motorhome Forum 18 06-10-2013 04:29 PM
Warm Engine When Not Running Bangorbob Class A Motorhome Discussions 20 06-08-2013 09:38 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.