Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-24-2021, 11:32 AM   #1
Junior Member
 
Join Date: Jul 2021
Posts: 3
2002 Newmar KS Workhorse chassis problems?

We bought a 2002 Newmar Kountry Star. No owners manual and we only have half of front dash fuse panel that functions. Replaced with new from Newmar and still no change. Need wiring info so we can track wiring to see what's happened. Any help is grateful. Please, hopefully someone has some I for regarding our unit. HELP PLS!!
TonyDawnE is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-24-2021, 05:59 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,313
Welcome to iRV2 .

The Newmar front fuse panel will have two supply wires , one from a circuit breaker from a battery feed , the second from a circuit breaker that is fed from an aux ignition relay .
Which half of the fuse panel , isn't getting power , items that should work when the ignition key is off ( battery feed ) or systems that Newmar installed that should only work when the key is on ( engine running).

Did the panel you replaced look like the photo below ?
Attached Thumbnails
Click image for larger version

Name:	IMG_0007 (480x640).jpg
Views:	10
Size:	204.3 KB
ID:	337099  
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-25-2021, 06:28 AM   #3
Senior Member
 
vettenuts's Avatar
 
Join Date: Nov 2013
Posts: 5,164
2002 Newmar KS workhorse chasis problems?

Have you signed up for Newgle on the Newmar website? Some of the chassis schematics are available from them. Also, the Navistar Workhorse website has some schematics and system diagrams. If you canít find your year, go a few newer if need be as they are very similar and should provide some help in your diagnosis.

I will need to look, but I may have some photos of that breaker panel from my 2005 when we had it and I connected the 12v wire for the seven pin trailer connector. Let me know if interested and I will go through my archives.
__________________
2015 Tiffin Phaeton 40QBH
2018 Chevrolet Colorado Toad
Roadmaster Tow Setup
vettenuts is offline   Reply With Quote
Old 07-25-2021, 01:02 PM   #4
Senior Member
 
edgray's Avatar
 
Join Date: Oct 2002
Location: Madison, MS
Posts: 9,716
Quote:
Originally Posted by TonyDawnE View Post
We bought a 2002 Newmar Kountry Star. No owners manual and we only have half of front dash fuse panel that functions. Replaced with new from Newmar and still no change. Need wiring info so we can track wiring to see what's happened. Any help is grateful. Please, hopefully someone has some I for regarding our unit. HELP PLS!!
WELCOME to iRV2.com
I can't tell "which" fuse panel you are working with, because some are provided with the chassis, while others are added by the coach builder for "house" connections.
IF you want to find the electrical schematics for the chassis-provided panels and wiring, you need to determine "which" Workhorse chassis you have and scroll down this long list to find the exact model and year: Workhorse Technical Info
edgray is offline   Reply With Quote
Old 07-26-2021, 06:04 AM   #5
Junior Member
 
Join Date: Jul 2021
Posts: 3
Same panel, the battery side works. No power to the ignition side. But the ignition wire that hooks to it is hot just no power going through the board.
TonyDawnE is offline   Reply With Quote
Old 07-26-2021, 06:07 AM   #6
Junior Member
 
Join Date: Jul 2021
Posts: 3
Quote:
Originally Posted by Skip426 View Post
Welcome to iRV2 .

The Newmar front fuse panel will have two supply wires , one from a circuit breaker from a battery feed , the second from a circuit breaker that is fed from an aux ignition relay .
Which half of the fuse panel , isn't getting power , items that should work when the ignition key is off ( battery feed ) or systems that Newmar installed that should only work when the key is on ( engine running).

Did the panel you replaced look like the photo below ?
Same panel, brand new from Newmar. Battery side works. Tested ignition wire and it's got power. No distribution into panel though.
TonyDawnE is offline   Reply With Quote
Old 07-26-2021, 07:58 AM   #7
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,313
Quote:
Originally Posted by TonyDawnE View Post
Same panel, brand new from Newmar. Battery side works. Tested ignition wire and it's got power. No distribution into panel though.
Two power distribution ( fuse ) boards; original and replacement ; with the same problem.
You've tested power to the ignition power stud , and have power there ; but nothing at the fuses, or off the board through the multiple connectors ?
I'll be at the coach later today , and look at my board to see if anything comes to mind as far as a possible cause.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-26-2021, 04:46 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,313
Ok , now first off , although the fuse panels look the same , there can be differences .
So first picture the board info from the supplier .

Second picture , partial photo of the board diagram , indicating there is an , ignition relay on the board .
Third picture , the ignition relay , red box , in relation to the aux ignition power stud , red arrow .
Sorry about photo angles , the fuse panel and diagram are under the dash , and can't get a good angle for photos.
Some where in one of the multiple connectors of wires to the board , there must be an activation wire for the , board mounted ignition relay , which wire and where Newmar decided to get power from the Workhorse ignition circuit is the big question .
I leave tomorrow for a two week trip , so I can't pull my board to trace the printed circuitry on the back side . So I'd hope that Newmar can supply the info , at least to the multiple connector and activation wire .
If they can't , I'd ask that you post pictures of both sides of you original board , and I'll try and figure it out from those .
Some of the wires to multiple connectors are labeled and maybe those could provide a clue .
Attached Thumbnails
Click image for larger version

Name:	IMG_0939.JPG
Views:	4
Size:	315.2 KB
ID:	337376   Click image for larger version

Name:	IMG_0935.JPG
Views:	4
Size:	194.8 KB
ID:	337377  

Click image for larger version

Name:	IMG_0938.JPG
Views:	8
Size:	522.7 KB
ID:	337378  
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
ems, newmar, problem, problems, workhorse



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Workhorse Chasis Antilock Brake Sensor Replacement lslongoria Workhorse and Chevrolet Chassis Motorhome Forum 5 02-18-2013 07:44 PM
Alpine chasis vs New Tiffen Chasis RVRONINPA Alpine Coach Owner's Forum 1 10-05-2007 09:03 AM
Workhorse chasis on a Sightseer 30B? BigRedLancer Winnebago Industries Owner's Forum 3 05-13-2005 07:41 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.