Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-31-2015, 03:00 PM   #1
Junior Member
 
Join Date: Mar 2015
Posts: 1
2005 Bounder W22 chassis, hazards and turn signals not working!

Where can I locate the fuses as well as the flasher or turn signal relays? Under the dash? Engine compartment? Thanks for the help!
jjordan is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-31-2015, 03:14 PM   #2
Community Administrator
 
CLIFFTALL's Avatar


 
Join Date: Aug 2009
Posts: 50,389
Blog Entries: 1
Welcome to irv2. I've moved your post here to our Workhorse section. I had the Ford chassis and those fuses were under the hood. Cliff
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
CLIFFTALL is offline   Reply With Quote
Old 03-31-2015, 08:11 PM   #3
Senior Member
 
edgray's Avatar
 
Join Date: Oct 2002
Location: Madison, MS
Posts: 10,197
my owners manual shows "under hood" fuse block. TS switch circuit is a 15amp fuse labeled "hazard".
edgray is online now   Reply With Quote
Old 03-31-2015, 09:17 PM   #4
Senior Member
 
Brazel's RV Performance's Avatar
Official iRV2 Sponsor
 
Join Date: Jun 2008
Location: Centralia, WA
Posts: 1,216
Blog Entries: 6
Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1427854582.080893.jpg
Views:	137
Size:	240.0 KB
ID:	90210

This is the under hood fuse box layout.
__________________
Jon Brazel
Ultra RV Products 800-417-4559
Brazel's RV Performance 877-786-1576
Brazel's RV Performance is offline   Reply With Quote
Reply

Tags
bounder, chassis



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Bounder Fuse Box Problem whit5751 Ford Motorhome Chassis Forum 8 12-29-2014 05:32 PM
Brake Lights and Turn Signals Not Working slimjim69 Ford Motorhome Chassis Forum 7 09-09-2014 10:35 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.