Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-25-2008, 03:24 PM   #1
Junior Member
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Sep 2004
Location: Keller, Texas
Posts: 26
My transmission started to have a hard downshift and hard upshift in 1st and 2nd gear. I checked the fluid and added some fluid. I test drove the rv and the trans light came on and it only would go in 2nd gear. I had the rv towed to a allison shop to see what was wrong. They tried to get the codes off the transmission but their computer connection wouldn't work. I am going to take the rv to another shop tomorrow to have them check out the problem. Has anyone else had this problem. I have 49000 miles on the rv and it is no longer under warranty. I spent $5000 more for the workworse with the allison over the ford. I now wish I had gotten the ford.
Dolphin 2002 5355
rednlh is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-25-2008, 03:24 PM   #2
Junior Member
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Sep 2004
Location: Keller, Texas
Posts: 26
My transmission started to have a hard downshift and hard upshift in 1st and 2nd gear. I checked the fluid and added some fluid. I test drove the rv and the trans light came on and it only would go in 2nd gear. I had the rv towed to a allison shop to see what was wrong. They tried to get the codes off the transmission but their computer connection wouldn't work. I am going to take the rv to another shop tomorrow to have them check out the problem. Has anyone else had this problem. I have 49000 miles on the rv and it is no longer under warranty. I spent $5000 more for the workworse with the allison over the ford. I now wish I had gotten the ford.
Dolphin 2002 5355
rednlh is offline   Reply With Quote
Old 07-25-2008, 06:58 PM   #3
Senior Member
 
Full-Timers's Avatar
 
Workhorse Chassis Owner
Rexhall Owners Group
Join Date: Feb 2003
Location: Everywhere,USA
Posts: 1,464
If it's any consolation, I have heard more problems with Ford transmissions than Alison. Once you get it fixed, which is probably an easy fix, you WILL be glad you got an Alison.
__________________
Full-Timers
in a
2003 Rexhall Aerbus 3550BSL
W22 Workhorse
Full-Timers is offline   Reply With Quote
Old 07-29-2008, 07:03 PM   #4
Senior Member
 
tropical36's Avatar
 
American Coach Owners Club
Join Date: Jul 2007
Location: SW Florida
Posts: 2,724
There's another thread that talks about reseting the computer...maybe by disconnecting the chassis battery for 5 mins or so....just a thought.
__________________
07 Revolution LE 40E_1 1/2 Baths_Spartan MM Chassis_06 400HP C9 CAT_ Allison 3000
Dinghy_2010 Jeep Wrangler JKU ISLANDER
1998 36ft. National Tropi-Cal Chevy Model 6350 (SOLD)
tropical36 is offline   Reply With Quote
Old 07-30-2008, 02:30 AM   #5
Senior Member
 
Max Hubrich's Avatar
 
Workhorse Chassis Owner
Join Date: Mar 2007
Location: Pikeville, NC
Posts: 1,774
Rednlh,

Here is the thread Tropical36 is refering to- I think.
__________________
Max H,
2002 Newmar Mountain Aire, 37', 3778, W-22, 8.1 Vortac, Ultra Power upgrade, CAI (cold air intake), Taylor wires, colder plugs, Koni shocks.
Max Hubrich is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Allison 1000 Transmission Service/Piscataway NJ GerryB54 Allison Transmission Forum 8 10-11-2008 03:28 PM
Allison 1000 Transmission Thudman Workhorse and Chevrolet Chassis Motorhome Forum 16 08-03-2008 08:32 AM
ALLISON 1000 TRANSMISSION rednlh Workhorse and Chevrolet Chassis Motorhome Forum 6 06-06-2007 06:26 PM
Allison 1000 transmission service advice lionel_046 Workhorse and Chevrolet Chassis Motorhome Forum 14 02-13-2007 01:02 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.