Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-13-2006, 08:57 PM   #1
Senior Member
 
Workhorse Chassis Owner
Join Date: Oct 2004
Location: California Desert
Posts: 357
My cruise control stopped working during my last trip. I've verified that the 10A fuse marked "cruise" in the external fuse block is OK. I've not gotten around to checking the internal fuse block yet, and want to minimize the time I have to stand on my head to get at it. Do any of the fuses in that block have anything to do with the CC?
__________________
2004 Southwind 32VS
2014 C-Max toad
Workhorse chassis
wilanddij is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-13-2006, 08:57 PM   #2
Senior Member
 
Workhorse Chassis Owner
Join Date: Oct 2004
Location: California Desert
Posts: 357
My cruise control stopped working during my last trip. I've verified that the 10A fuse marked "cruise" in the external fuse block is OK. I've not gotten around to checking the internal fuse block yet, and want to minimize the time I have to stand on my head to get at it. Do any of the fuses in that block have anything to do with the CC?
__________________
2004 Southwind 32VS
2014 C-Max toad
Workhorse chassis
wilanddij is offline   Reply With Quote
Old 01-14-2006, 09:47 AM   #3
Senior Member
 
Paulin's Avatar
 
Join Date: Sep 2003
Location: No. CA
Posts: 405
Check your ABS and stop/tail light systems. When ours went out it turned out to be the stop light fuse. I believe all those systems interact with each other.
__________________
Paulin
Paulin is offline   Reply With Quote
Old 01-14-2006, 01:22 PM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: Oct 2004
Location: California Desert
Posts: 357
Thanks much. I did find that the 20A "Stop/Haz/AuxFan" fuse was blown. Haven't had a chance to test the CC since I replaced that fuse. Also, the "ABS" warning light was coming on occasionally. When I have a chance to test it out, I'll update the thread.
__________________
2004 Southwind 32VS
2014 C-Max toad
Workhorse chassis
wilanddij is offline   Reply With Quote
Old 02-26-2006, 04:17 PM   #5
Senior Member
 
Workhorse Chassis Owner
Join Date: Oct 2004
Location: California Desert
Posts: 357
As advertised by Bluewind, the blown "Stop/Haz/Auxfan" fuse also made the CC stop working (something to remember). I also added brake fluid, so that may have been the fix for the ABS light. Anyway, all is well now.
__________________
2004 Southwind 32VS
2014 C-Max toad
Workhorse chassis
wilanddij is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control SEMO Mike Spartan Motorhome Chassis Forum 3 09-21-2008 11:14 AM
Cruise Control Lindsay Richards Winnebago Industries Owner's Forum 7 03-05-2008 07:21 PM
Cruise Control Lindsay Richards iRV2.com General Discussion 5 12-09-2007 03:02 PM
Cruise Control Fossilhog Winnebago Industries Owner's Forum 3 04-19-2006 04:51 PM
Cruise control gryb Winnebago Industries Owner's Forum 1 01-12-2006 01:31 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.