Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-12-2005, 06:55 PM   #1
Senior Member
 
supercub's Avatar
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: Modesto, CA
Posts: 413
On my 03 Fleetwood 32VS the back up camera has gone out. Does anyone know where the fuse is?? I know there's a fuse block under the dash...but it's not marked. There's one in the bedroom in the electrical panel, but I don't see it there. Have checked the two panels in the engine compartment and haven't seen it there either. Anyone know where I can get a wiring schematic of Workhorse or Fleetwood....or both??
__________________
2004 Fleetwood Revolution 38B
supercub is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-12-2005, 06:55 PM   #2
Senior Member
 
supercub's Avatar
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: Modesto, CA
Posts: 413
On my 03 Fleetwood 32VS the back up camera has gone out. Does anyone know where the fuse is?? I know there's a fuse block under the dash...but it's not marked. There's one in the bedroom in the electrical panel, but I don't see it there. Have checked the two panels in the engine compartment and haven't seen it there either. Anyone know where I can get a wiring schematic of Workhorse or Fleetwood....or both??
__________________
2004 Fleetwood Revolution 38B
supercub is offline   Reply With Quote
Old 12-13-2005, 05:56 AM   #3
iRV2 Marketing
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,641
Blog Entries: 70
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by supercub:
Anyone know where I can get a wiring schematic of Workhorse or Fleetwood....or both?? </div></BLOCKQUOTE>A backup camera is not a chassis issue so Workhorse won't have anything there to help you. On the other hand the fuse block under the dash typically accomodates 12 volt coach equipment so it would located there if anywhere. Call Fleetwood.
__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 12-13-2005, 11:32 AM   #4
Member
 
Join Date: May 2005
Location: Georgia
Posts: 46
Remove the camera and check the connector at the camera. Mine went out on a 98 Fleetwood and it was in the connector. I cleaned it up and everything worked fine.
__________________
Charles

2004 Winnebago Adventure 37B
Charles99 is offline   Reply With Quote
Old 12-13-2005, 05:59 PM   #5
Senior Member
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Oct 2004
Location: Scottsdale, AZ
Posts: 1,502
My camera system went black also and was related to poor connector contact at the plug in back of the monitor. BTW the wiring to my monitor has the fuses within the wiring. So you may want to look for a series connected fuse.
__________________
2003 34' Dolphin 5342, W22, UP, UPGBrake, F and R Track Bars, Rear IPD sway bar, Koni FSDs, Safe-T-Plus, Scan Gauge II.. 2004 Jeep Liberty, Blue-Ox Adventa..
M&EM is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical help please...... RBAJJK Spartan Motorhome Chassis Forum 5 11-01-2008 01:12 PM
Electrical lightnin78 MH-General Discussions & Problems 6 09-12-2007 05:12 AM
electrical help tstorey Winnebago Industries Owner's Forum 12 04-22-2007 04:24 PM
electrical ROADTREK MH-General Discussions & Problems 6 02-21-2007 01:08 AM
Need More Help Please! Electrical Kazoo Tom Winnebago Industries Owner's Forum 8 04-18-2006 01:27 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.