Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-31-2009, 05:47 AM   #1
Senior Member
 
Workhorse Chassis Owner
Join Date: Mar 2005
Location: On The Road
Posts: 101
Engine Running Cool

Yesterday driving my W-22 2002 from Quartzsite to Palm Springs and gazing fondly at my scan gauge I noted the engine temp had dropped to 181 degrees. The outside temp was 49. When the outside temp rose to 63 the engine temp returned to its normal 195. I'll contine to monitor the temp on the way to San Diego. I'm assuming the thermostat may have temporarily hung in the open position and should probably be replaced. Also assuming the engine does not like to run cold. Anyone had a simular occurance? Marv
Carvin Marvin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-31-2009, 06:06 AM   #2
paz
Senior Member
 
paz's Avatar
 
Join Date: May 2005
Location: Full-timers - Home is where we park it.
Posts: 4,717
I agree with your theory that your thermostat is possibly stuck in the open position. On a cool day, the engine wasn't working hard enough to maintain normal temperature with the thermostat fully open.
paz is offline   Reply With Quote
Old 10-31-2009, 07:40 AM   #3
Senior Member
 
Workhorse Chassis Owner
Join Date: Jun 2006
Location: Northwestern Montana
Posts: 3,454
Quote:
Originally Posted by Carvin Marvin View Post
Yesterday driving my W-22 2002 from Quartzsite to Palm Springs and gazing fondly at my scan gauge I noted the engine temp had dropped to 181 degrees. The outside temp was 49. When the outside temp rose to 63 the engine temp returned to its normal 195. I'll contine to monitor the temp on the way to San Diego. I'm assuming the thermostat may have temporarily hung in the open position and should probably be replaced. Also assuming the engine does not like to run cold. Anyone had a simular occurance? Marv

Maybe the Workhorse cool pack is just too efficient Marv.

Yeah, right!!

I would just keep an eye on it were it me.



Dieselclacker
dieselclacker is offline   Reply With Quote
Old 10-31-2009, 01:07 PM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 1,548
Could be a sudden onset of hysteresis that will pass at midnite tonite.
__________________
TandW
TandW is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pre-workhorse 454 engine needs help DaveFL Workhorse and Chevrolet Chassis Motorhome Forum 19 01-21-2010 07:48 AM
Engine Running Rich RoadRohrers Ford Motorhome Chassis Forum 11 05-29-2009 11:11 AM
Cleaned the C7 Engine Crankcase Breather element SteveG Caterpillar Engine Forum 1 03-31-2009 11:55 AM
Check Engine Light ricere Newmar Owner's Forum 4 05-08-2007 04:32 PM
engine will not start PairoDocs Workhorse and Chevrolet Chassis Motorhome Forum 10 04-23-2005 06:14 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.