Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2022, 11:16 PM   #1
Junior Member
 
Join Date: Dec 2022
Posts: 1
Smile FIXED***2004 Workhorse won't start

I went to start my 2004 Workhorse P42 and nothing. I thought it was the ignition switch since it went bad before so I changed it, still nothing. Battery is new. No power at all on the dash, headlights wont work, no click from starter, nothing. What a pain. I read a ton of threads on forums and narrowed down the problem. I had to be sure the starter worked though so I jumped it at the starter relay under the hood. That worked. So I was down to loose wires at the starter maybe or bad ground. Wires were tight and snug at starter. I added a ground wire from the battery to the engine (I left the old one on just for the heck of it) and that was the problem. Original ground no good, or not good enough anymore. 1 day of troubleshooting but turns on like a champ now. I hope this helps people with the same problem.
Big Bad Rog is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-10-2022, 08:04 AM   #2
Senior Member
 
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Jul 2005
Location: USA
Posts: 4,067
Welcome aboard! Thanks for sharing!
__________________
TandW
TandW is offline   Reply With Quote
Old 12-10-2022, 03:33 PM   #3
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 12,169
Thanks for the update, glad all is well!
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Measure twice...Cut once.
Arch Hoagland is offline   Reply With Quote
Old 12-10-2022, 10:35 PM   #4
Senior Member
 
Join Date: Aug 2021
Posts: 155
seems GM has issues with battery cables.my 07 suburban started acting weird.out of the blue stepping on the brake pedal would cause all the gauges to quit momentarily and then the doors would lock,turns out lots of people had the same problem and the fix is to replace both battery cables.it cured the problem.
catmandoo62 is offline   Reply With Quote
Old 01-25-2023, 11:47 PM   #5
Senior Member
 
Join Date: Apr 2022
Posts: 456
Could be that the 'engine to chassis' braided cable is shot and in need of replacing. This also one of many things I changed after purchasing my 94 (P-30 chassis).
__________________
94 Southwind Storm 28ft - 454TBI w/4L80E
VIN#1GBJP37N4R3314754
Flight System G-Man 360 generator man (PM me)
1972VWbus is offline   Reply With Quote
Reply

Tags
workhorse



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Workhorse won't start... Andy T Workhorse and Chevrolet Chassis Motorhome Forum 25 01-02-2019 12:28 PM
Diesel cranks, won't start: diagnosed and fixed! BigPapaYams Monaco Owner's Forum 20 03-22-2017 09:35 AM
W22 Tail Lights Fixed - DriVer An Enormous Help! - Flashers Fixed Update 9/5/07 GerryB54 Workhorse and Chevrolet Chassis Motorhome Forum 30 09-05-2007 02:42 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.