Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-04-2021, 01:03 PM   #1
Member
 
Join Date: Jul 2014
Posts: 36
Get me home parking brake fix

So Iím kinda familiar with this stupid parking brake setup. Iíve previously replaced the RGS and had the spring actuator deal rebuilt. All of a sudden yesterday all was well then I set parking brake for my dad to get in and it wouldnít disengage and the auto park light was on. Instant pissed happens! I pull on and off and all sudden it releases but auto park is on. Short trip to our stop all is well. Iíve spent the morning underneath this thing trying to figure it out. Ive got a lengthy trip home and canít find a switch around me of course and canít get one until Wednesday.

Things Iíve done -
Ensured reservoir was filled
Inspected for leaked at RGS
Unplug switch and auto park light goes out
Visual and with help of phone it appears I have a leak from somewhere. (Itís on frame rail) leak only appears to be as itís being actuated on and off
Bigk_54 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-04-2021, 01:15 PM   #2
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 1,548
Quote:
Originally Posted by Bigk_54 View Post
So Iím kinda familiar with this stupid parking brake setup. Iíve previously replaced the RGS and had the spring actuator deal rebuilt. All of a sudden yesterday all was well then I set parking brake for my dad to get in and it wouldnít disengage and the auto park light was on. Instant pissed happens! I pull on and off and all sudden it releases but auto park is on. Short trip to our stop all is well. Iíve spent the morning underneath this thing trying to figure it out. Ive got a lengthy trip home and canít find a switch around me of course and canít get one until Wednesday.

Things Iíve done -
Ensured reservoir was filled
Inspected for leaked at RGS
Unplug switch and auto park light goes out
Visual and with help of phone it appears I have a leak from somewhere. (Itís on frame rail) leak only appears to be as itís being actuated on and off
There is another switch on the inlet to the cylinder if memory serves me correctly. It is prone to rupture and leaking off the pressure needed to keep the brake off. Replace it and you'll be back in business.
__________________
TandW
TandW is offline   Reply With Quote
Old 09-05-2021, 11:36 AM   #3
Senior Member
 
Join Date: Nov 2018
Location: Fulda, MN
Posts: 615
Blog Entries: 1
Go to the top of this forum and type in j71 in the search box and you find all kinds of threads on this subject.
David 70 is offline   Reply With Quote
Old 09-05-2021, 02:01 PM   #4
Member
 
Join Date: Jul 2014
Posts: 36
Quote:
Originally Posted by David 70 View Post
Go to the top of this forum and type in j71 in the search box and you find all kinds of threads on this subject.
Iíve read a lot of them was looking for a quick answer what else maybe I missed. Today the pump wonít even pump sheís in park. Ordered green switch, at this point Iím sure itís that and Iím stuck in a bad place now lol
Bigk_54 is offline   Reply With Quote
Old 09-05-2021, 02:15 PM   #5
Senior Member
 
edgray's Avatar
 
Join Date: Oct 2002
Location: Madison, MS
Posts: 9,763
Get me home parking brake fix

FWIW, think the RGS and the other one are interchangeable. I believe the grey switch only job is to turn on the warning lite.
And I believe you can buy better quality switches at : www.urvp.com
edgray is offline   Reply With Quote
Old 09-05-2021, 02:36 PM   #6
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 1,548
Quote:
Originally Posted by Bigk_54 View Post
I’ve read a lot of them was looking for a quick answer what else maybe I missed. Today the pump won’t even pump she’s in park. Ordered green switch, at this point I’m sure it’s that and I’m stuck in a bad place now lol
If memory serves me correctly, there is a grey switch on the cylinder where you see leakage. That switch has likely ruptured.
If you get the system to run it'll blow off all the rest of the ATF fluid in the reservoir.
In my Allegro the pump motor was prone to rain washing in while traveling. Eventually the motor rusted up, the oillite bearings in it dried out and wore into ovals and then the armature hit the permanent magnets which had cracked from blistering rust. Replaced it with a snow-plow pump motor. That rainwater also passed the pump shaft seal allowing water into the system. You have to cycle the system many times, changing out ATF along the way as it mixes with the entrained water.
My Allegro is retired and up on blocks. My biggest scare with the AAPB happened when it rolled away from the gas pumps with no one onboard. There is barely 1/8 inch of material on new brake shoes and when that is gone due to the ignition switch anomalies we had early on with Workhorse Chassis, 2 episodes of at speed failure of the switch had wiped the shoes nearly clean of material. And as I recall there was no adjustment available or left in the mechanism at that point. Good luck to all with J71 AAPB systems.
__________________
TandW
TandW is offline   Reply With Quote
Old 09-05-2021, 02:48 PM   #7
Member
 
Join Date: Jul 2014
Posts: 36
Quote:
Originally Posted by edgray View Post
FWIW, think the RGS and the other one are interchangeable. I believe the grey switch only job is to turn on the warning lite.
And I believe you can buy better quality switches at : www.urvp.com
Gonna give that a try thanks!

Well that didn’t work, BUT that switch was unplugged and I think it was because the light stayed on so someone told me to unplug it
Bigk_54 is offline   Reply With Quote
Old 09-05-2021, 02:49 PM   #8
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 1,548
Quote:
Originally Posted by Bigk_54 View Post
Gonna give that a try thanks!
NO NO NO They are not!
__________________
TandW
TandW is offline   Reply With Quote
Old 09-05-2021, 03:03 PM   #9
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 1,548
There was something peculiar to the RGS in the adapter it mounts into. If you don't hold back the adapter as you remove the RGS you may inadvertently remove the RGS along with the adapter and if not careful you could lose a metering pin or some sort of thing. But it's been along time soooooo.
__________________
TandW
TandW is offline   Reply With Quote
Old 09-05-2021, 04:13 PM   #10
Member
 
Join Date: Jul 2014
Posts: 36
There are the 2 pressure switches, a 3rd item screwed into the aluminum plate and then the pump. I have 12v going to all of them. As I connect and disconnect plug for the rgs I can hear the relay clicking. As the parking park handle is pushed in and out I can hear the relay click ��
__________________
2000 38.5' Newmar Mountain Aire
Bigk_54 is offline   Reply With Quote
Old 09-05-2021, 04:21 PM   #11
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 1,548
Quote:
Originally Posted by Bigk_54 View Post
There are the 2 pressure switches, a 3rd item screwed into the aluminum plate and then the pump. I have 12v going to all of them. As I connect and disconnect plug for the rgs I can hear the relay clicking. As the parking park handle is pushed in and out I can hear the relay click ��
Could be your pump motor gave up the smoke like they like to say elsewhere in these forums, or it just isn't receiving voltage. Use your VOM and get back with some readings.
__________________
TandW
TandW is offline   Reply With Quote
Old 09-05-2021, 08:21 PM   #12
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 6,540
It would help if you were to tell us the model year of your coach as there are several versions of the automatic parking brake system, though mentioning the rotten green switch narrows that down to 2 or 3 versions.
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L w/ 400 watts solar
2017 Jeep Cherokee Overland & 2007 Toyota Yaris TOADs with Even Brake,
Demco Commander tow bar and Blue Ox / Roadmaster base plates
Isaac-1 is offline   Reply With Quote
Old 09-05-2021, 08:37 PM   #13
Member
 
Join Date: Jul 2014
Posts: 36
Quote:
Originally Posted by Isaac-1 View Post
It would help if you were to tell us the model year of your coach as there are several versions of the automatic parking brake system, though mentioning the rotten green switch narrows that down to 2 or 3 versions.
My apologies it was in my signature.
1999 mountainaire on workhorse
RGS, pump, etc is on passenger side frame rail
Bigk_54 is offline   Reply With Quote
Old 09-06-2021, 07:35 AM   #14
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 822
Not sure I am reading your post right.. there is am emergency manual release.. but I warn you.. it is for emergency only.. YOU WILL HAVE TO.. CHOCK ALL WHEELS ALL THE TIME OR RV WILL ROLL AWAY AND POSSIBLY KILL SOMEONE.. that said.. on driver's side frame rail.. by trans.. there is a bracket that both the a/p actuator cable and a/p brake drunk cable go into.. now they are under great spring tension.. the is a pin.. on the actuator cable.. you pull that.. NOW KEEP FIGURES OUT OF WAY.. YOU CAN LOSS ONE.. USE LONG FLAT BLADE SCREWDRIVER OR SOMETHING LIKE THAT.. and no a/p.. unless the internal shoes have rusted or hanged up.. before pulling pin.. CHOCK ALL WHEELs.. SO.. you say you are familiar with a/p.. and worked on it before.. then to be clear.. because I don't want readers to get hurt.. to be clear.. this is not like a car.. there is no parking Pawl.. to hold rv in place.. so once you pull pin.. rv will roll and damage will occur.. 2nd.. you noticed drips.. did all the hydraulic fluid drain out of resovior ? Next you said that you had checked and changed switches.. inspect the small hydraulic line that runs from the pump to actuator.. I had a small leak in mine. So i had one made.. or order new one.. . next.. how far and what speed did you drive ? We need to know to better help you.. next.. inspect outside of a/p brake drum.. is it discolored ? Get back with us.. and we will get you more help.. why have you not installed the genie lamp system ? Good luck let us know what you did and maybe better members then me will help you.. now is good time to get genie light system installed..
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Reply

Tags
brake, parking



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I do a temporary leaking window fix until I get home olustee bus MH-General Discussions & Problems 4 08-15-2020 02:24 PM
Class C Parking Brake warning light says ON and can't get it out of park katlmt66 Ford Motorhome Chassis Forum 7 11-09-2018 04:29 PM
"CH FIX" - MODS: Adjustable CHF/ LEVEL SB/ One hole SB FIX TeJay Ford Motorhome Chassis Forum 9 03-07-2016 10:19 AM
Parking Brake Lite On - But Brake is OFF K5EAG MH-General Discussions & Problems 1 09-17-2010 10:25 AM
Auto Parking Brake/ emergency brake??? HD tech Workhorse and Chevrolet Chassis Motorhome Forum 6 03-11-2005 02:04 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.