Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-17-2015, 10:52 AM   #1
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Low oil pressure warnings when pressure is good II.

Bit the bullet and took our 05 Tiffin Allegro 32ba to a shop that does workhorse work.
Lucky for me they were able to duplicate the while driving with a manual oil pump. The pressure did drop. Also the check engine light turned out to be the 02 sensor.
The oil pump and shaft and 02 sensor were replaced. No warning lights and oil pressure stayed around 35-45 lbs and !5-18 when idling after driving awhile.
It was higher when first started.
Unfortunately, the cruise control didn't work. Wish I tried it before I was almost home form shop. I called and the mechanic was on vacation so 'll call back when he returns.
To save a hour drive back to the shop I'll check with this forum.
The shop was checking the dash cluster and oil pressure in the process. Is anyone familiar with where the cruise control may plug in?
Hopefully, that may be the problem.
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-17-2015, 10:39 PM   #2
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 12,291
I'm interested in the O2 sensor replacement.

What was the check engine light code they got that caused them to replace it and which O2 sensor did they replace?
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Measure twice...Cut once.
Arch Hoagland is online now   Reply With Quote
Old 07-18-2015, 07:55 AM   #3
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Quote:
Originally Posted by Arch Hoagland View Post
I'm interested in the O2 sensor replacement.

What was the check engine light code they got that caused them to replace it and which O2 sensor did they replace?
Hi Arch,
Shop maynot be open on Saturdays - - no answer. I'll call and ask.
I'hope some one has some info on where the cruise control connects. Hopefully they didn't re connect it.
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Old 07-18-2015, 07:56 AM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: May 2005
Posts: 665
There's a good chance they inadvertently moved the brake light switch which is down by the brake pedal. It is a very flimsy switch and easily moved. Try re-positioning it. This happened to me once when I was once working under the dash. Also, if there is anything wrong with the brake light circuit, the cruise control will not work. You might also check for a burnt out brake light bulb.
__________________
Fred Kennerson
2003 Dolphin L/X 6320
Yucaipa, Ca
kennersonf is offline   Reply With Quote
Old 07-18-2015, 08:22 AM   #5
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Quote:
Originally Posted by kennersonf View Post
There's a good chance they inadvertently moved the brake light switch which is down by the brake pedal. It is a very flimsy switch and easily moved. Try re-positioning it. This happened to me once when I was once working under the dash. Also, if there is anything wrong with the brake light circuit, the cruise control will not work. You might also check for a burnt out brake light bulb.
Thanks Fred,
I'll try to get down there to the brake pedal. Let's say I'm not as agile as I once was....I do remember the cruise control acting real wierd and there was corrosion on the brake lights.. thanks again.. I wouldn't have thought of the brake system.
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Old 07-18-2015, 09:35 AM   #6
Senior Member
 
Tom N's Avatar
 
Winnebago Owners Club
Pond Piggies Club
Appalachian Campers
Mid Atlantic Campers
Join Date: Dec 2002
Location: Sarver, PA/Crystal River, FL/Shelocta, PA
Posts: 4,671
Quote:
Originally Posted by tim fm ct View Post
Bit the bullet and took our 05 Tiffin Allegro 32ba to a shop that does workhorse work.
Lucky for me they were able to duplicate the while driving with a manual oil pump. The pressure did drop.
Can you tell me about the manual oil pump??
__________________
Sarver, PA/Crystal River, FL/Shelocta, PA FMCA 335149 W3TLN
2005 Suncruiser 38R W24, no chassis mods needed 2013 Honda Accord EX-L 2008 Honda Odyssey EX-L

Tom N is offline   Reply With Quote
Old 07-19-2015, 08:09 AM   #7
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Quote:
Originally Posted by Tom N View Post
Can you tell me about the manual oil pump??
Hi Tom,
Hmmm, I should've said oil gauge, instead of having to rely on the data sent via the oil pressure sender and electronics, they used a regular/manual oil pressure gauge.
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Old 07-19-2015, 11:37 AM   #8
Senior Member
 
Tom N's Avatar
 
Winnebago Owners Club
Pond Piggies Club
Appalachian Campers
Mid Atlantic Campers
Join Date: Dec 2002
Location: Sarver, PA/Crystal River, FL/Shelocta, PA
Posts: 4,671
Thanks. I should have been able to read between the lines and recognized that.
__________________
Sarver, PA/Crystal River, FL/Shelocta, PA FMCA 335149 W3TLN
2005 Suncruiser 38R W24, no chassis mods needed 2013 Honda Accord EX-L 2008 Honda Odyssey EX-L

Tom N is offline   Reply With Quote
Old 07-21-2015, 05:59 AM   #9
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Quote:
Originally Posted by tim fm ct View Post
Thanks Fred,
I'll try to get down there to the brake pedal. Let's say I'm not as agile as I once was....I do remember the cruise control acting real wierd and there was corrosion on the brake lights.. thanks again.. I wouldn't have thought of the brake system.
thanks again, fred.
Although I couldn't maneuver under there to get two hands on the switch. I certainly did try. it did turn out to be that switch..
Bravo,
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Old 07-21-2015, 06:04 AM   #10
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Quote:
Originally Posted by Arch Hoagland View Post
I'm interested in the O2 sensor replacement.

What was the check engine light code they got that caused them to replace it and which O2 sensor did they replace?
Arch,
The tech blurted out a lot of info about the 02 sensor. Here's what I retained. The sensor something about upstream, Bank one, sensor 1. I think he said there were 4 sensors. He didn't remember the code something about low voltage.
. hope this helps
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Old 07-21-2015, 09:48 AM   #11
Senior Member
 
Arch Hoagland's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Aug 2002
Location: Clovis, CA, USA
Posts: 12,291
Quote:
Originally Posted by tim fm ct View Post
Arch,
The tech blurted out a lot of info about the 02 sensor. Here's what I retained. The sensor something about upstream, Bank one, sensor 1. I think he said there were 4 sensors. He didn't remember the code something about low voltage.
. hope this helps
I was getting codes P0151 and P0131. Everybody said the sensors were bad. Changed one and didn't help, turned out the O2 sensors were doing their job...telling me the MAF was dirty and causing bad fuel mixture.

Cleaned the MAF and problem cleared instantly.

Had one shop tell me I had to have them replaced every three years at a cost of $600. Yeah Right. That place is famous for ripping people off.

So be careful when they tell you the sensors are bad. I replaced the one myself at a cost of about $70 plus the purchase of a special socket you need for O2 sensors.
__________________
2004 Monaco La Palma 36DBD, W22, 8.1, 7.1 MPG
2000 LEXUS RX300 FWD 22MPG 4020 LBS
Measure twice...Cut once.
Arch Hoagland is online now   Reply With Quote
Old 07-21-2015, 10:06 AM   #12
Registered User
 
mel s's Avatar
 
Join Date: Mar 2010
Posts: 8,777
Quote:
Originally Posted by tim fm ct View Post
Bit the bullet and took our 05 Tiffin Allegro 32ba to a shop that does workhorse work.
Lucky for me they were able to duplicate the while driving with a manual oil pump. The pressure did drop. Also the check engine light turned out to be the 02 sensor.
The oil pump and shaft and 02 sensor were replaced. No warning lights and oil pressure stayed around 35-45 lbs and !5-18 when idling after driving awhile.
It was higher when first started.
tim fm ct
What engine is in your 05 Tiffin Allegro 32BA, (with a 13 Fusion hybrid, 06 Ranger XLT with ramp gizmo, and a 05 Superglide on the gizmo)?
Although you did include a lot of useless information in the signature your post, you left out that one related and, IMO, very important fact.
Mel
'96 Safari
mel s is offline   Reply With Quote
Old 07-21-2015, 10:30 AM   #13
Senior Member
 
tim fm ct's Avatar
 
Tiffin Owners Club
Join Date: Apr 2009
Posts: 115
Quote:
Originally Posted by mel s View Post
tim fm ct
What engine is in your 05 Tiffin Allegro 32BA, (with a 13 Fusion hybrid, 06 Ranger XLT with ramp gizmo, and a 05 Superglide on the gizmo)?
Although you did include a lot of useless information in the signature your post, you left out that one related and, IMO, very important fact.
Mel
'96 Safari
"you did include a lot of useless information in the signature" Now, now Mel, you sound like the Mel that was on that comedy show in the diner with the two waitresses.
But "I'll show you mine if you show me yours" '96 Safari. ?
pause............................................. .................................................. ................... oh ok, mine is the 8.1 GM
__________________
Tim fm CT in our Home Sweet Dome
05 Tiffin Allegro 32BA,13 Ford Fusion hybrid, 06 Ranger XLT with ramp gizmo,05 Superglide, 12 CedarCreek Silverback 29RE 5th whl, gotta get rid of something
tim fm ct is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sensor centurion95 Spartan Motorhome Chassis Forum 4 03-19-2015 09:48 AM
Low oil pressure Jeff753 Cummins Engines 13 06-18-2014 04:46 PM
Oil pressure light Nuclear Ford Motorhome Chassis Forum 5 04-27-2014 03:54 PM
Looking for a good electric pressure washer dukenrock iRV2.com General Discussion 14 12-16-2013 07:30 PM
Oil pressure SMRDNR Caterpillar Engine Forum 8 11-17-2013 09:01 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.