Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-23-2020, 12:05 PM   #1
Junior Member
 
Join Date: Dec 2020
Posts: 2
Not cranking or starting - melted bsti fuse

I have a 2002 Fleetwood Terra. Its a workhorse p32 chassis. Recently started having starting issues after stopping for about 10 minutes and trying to start it again. My engine doesn't crank at all. The dash fully lights up. There's just one loud click from behind the instrument panel upon turning the ignition back to off position.

I noticed that the bsti relay had completely melted and damaged the fuse box a bit (picture attached). I'm wondering if that is my starting issue maybe? I'm not sure what to test.
Attached Thumbnails
Click image for larger version

Name:	20201217_140946.jpg
Views:	54
Size:	429.8 KB
ID:	312225  
Terra02 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-23-2020, 01:02 PM   #2
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 4,543


Bummer. I think you're gonna want to see behind there to see if any of the wires melted. I guess if you can't find any shorts you could solder in the fuse/relay but you may need a new fuse block. Hopefully it's just want you can see that is melted.

Good luck.
__________________
1996 Tioga Class C
2007 Monaco Diplomat 40 PDQ
TOAD 2012 Cadillac SRX 4
okcnewbie is offline   Reply With Quote
Old 12-23-2020, 01:39 PM   #3
Senior Member
 
F4Gary's Avatar
 
Join Date: Feb 2015
Location: Grapevine, Tx
Posts: 4,934
Is there a sticker in the lid to that box that tells you what goes in those slots?
__________________
2004 Fleetwood Southwind 32VS W20
ReadyBrute Elite towing a 2017 Ford Edge Sport
F4Gary is offline   Reply With Quote
Old 12-23-2020, 02:00 PM   #4
Junior Member
 
Join Date: Dec 2020
Posts: 2
Yes. That melted one is the brake to shift relay. The one above it is just supposed to be empty.
Terra02 is offline   Reply With Quote
Old 12-23-2020, 05:10 PM   #5
Registered User
 
Join Date: Jul 2013
Location: Somerset, Ky
Posts: 256
ktoutoor is offline   Reply With Quote
Reply

Tags
fuse, no cranking, no start, not starting



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter : Melted Fuse and fuse block ChrisFSB Newmar Owner's Forum 13 10-19-2020 08:19 AM
Antenna up switch and cut off fuse melted a1kaching Class A Motorhome Discussions 2 10-02-2019 09:48 PM
10k generator not cranking over DaveyD1 Monaco Owner's Forum 13 01-25-2017 07:50 PM
Melted Fuse Chuck Q Going Green 4 08-02-2016 09:28 AM
Cranking battery not being charged when on shorepower Stretch Monaco Owner's Forum 4 11-29-2010 12:48 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.