Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-30-2022, 09:55 AM   #1
Junior Member
 
Join Date: Jun 2022
Posts: 0
Angry Power issue

I have a 1998 Tiffin Allegro thats on a p30 chassis with a 7.4 /454 engine and i was having issues with the dash ac not working , i tested all the fuses and when i was done went to crank the rv and nothing I heard a click somewhere in the dash area and that was it . Now I have no power, no dash power no head lights ,no radio nothing and it wont start. Has anyone had anything like this to happen need to fix asap. Thanks in advance
Coachced is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-30-2022, 09:58 AM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 30,806
Battery cable ends are corroded and not passing power. Remove, clean, replace.
twinboat is offline   Reply With Quote
Old 06-30-2022, 10:07 AM   #3
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 3,215
First, welcome aboard!
Second, go back over everything you just did. If you pulled relays along with fuses make sure they are fully seated.
Three, see post #2.
__________________
TandW
TandW is offline   Reply With Quote
Old 06-30-2022, 10:13 AM   #4
Junior Member
 
Join Date: Jan 2022
Posts: 6
Question

Quote:
Originally Posted by Coachced View Post
I have a 1998 Tiffin Allegro thats on a p30 chassis with a 7.4 /454 engine and i was having issues with the dash ac not working , i tested all the fuses and when i was done went to crank the rv and nothing I heard a click somewhere in the dash area and that was it . Now I have no power, no dash power no head lights ,no radio nothing and it wont start. Has anyone had anything like this to happen need to fix asap. Thanks in advance
Having the exact problem on my Thor Axis. I am stumped, if you get a solution please post it.
Oliverbritt is offline   Reply With Quote
Old 06-30-2022, 10:23 AM   #5
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 1,527
What is date on all the batteries..? Both coach and chassis batteries ? Can you start gen? If so.. start gen.. leave running for 20mins and then press and hold aux start button for 10mins and while holding down try to start eng.. then drive asap to closest place to get battery and have them test.. if your chassis battery is bad.. it can burn alternator up too.. and often does..
If chassis battery is new.. test voltage.. what did you get? Could be bad chassis battery disconnect switches.. that is one of the large black boxes under hood.. above battery.. they are often can be taken apart and cleaned.. they get very corroded over time and need cleaning. But use all safety precautions.. that means.. negative cables removed from all batteries, coach and chassis.. no shore or gen or solar.. it's very tight in there and you might short out wires..
Use cellphone with camera and flash and record all wires 1st before you touch them.. and mark where they go.. they all need recleaned and resealed.. take your time.. it could be time for new starter.. and there are tests that can be done for that.. could be bad ignition switch.. they ove heat and burn up..
Good luck and keep us posted
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Old 06-30-2022, 03:52 PM   #6
Senior Member
 
Join Date: Aug 2017
Posts: 1,836
First measure your battery voltage .Then start by removing the batterie cables and cleaning them . Also remove the neg cable at the frame and clean it. Then check for power with a meter on the large stud of the alternator with the ign switch on. If there is no power there you will have to remove the cables on the starter and clean them . There is a fusible link on the wire that runs from the starter to a junction block then to the fuse panel and alternator. This may be the problem.
__________________
1993 Tiffin Allegro Bay 32'
Soppy is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shore power issue that was not an issue before pilotag Class A Motorhome Discussions 7 08-22-2021 12:11 AM
Power Step Power Issue Tlmr4784 Entegra Owner's Forum 3 07-29-2021 03:07 PM
Power issue when use shore power Oilman04957 Class A Motorhome Discussions 30 11-01-2020 11:24 AM
Shore power and generator power issue BracketRacer iRV2.com General Discussion 2 09-03-2012 01:19 PM
Southwind 36D Issue after issue after issue.... fixn2gocamp Fleetwood Owner's Forum 4 10-21-2009 07:05 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.