Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-18-2022, 07:16 PM   #1
Junior Member
 
Fleetwood Owners Club
Join Date: Jul 2021
Location: Show Low, AZ
Posts: 3
Power steering not working.

Fleetwood Southwind power steering reservoir is full. Power steering not working. No noise from pump. How can I check check for problems? Any help is appreciated. It's a 1991 Fleetwood Southwind on a P30 with chevy 454cid.
BC1948 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-18-2022, 09:14 PM   #2
Senior Member
 
Join Date: Apr 2022
Posts: 471
First thing to check...

Do you have the belt on?

Look underneath there is a (2) belts that go around the PS pump.
__________________
94 Southwind Storm 28ft - 454TBI w/4L80E
VIN#1GBJP37N4R3314754
Flight System G-Man 360 generator man (PM me)
1972VWbus is offline   Reply With Quote
Old 06-18-2022, 09:43 PM   #3
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 2,009
Do you still have power brakes ? Google hydroboost or you tube
Good luck and keep us posted
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Old 09-06-2022, 08:41 PM   #4
Junior Member
 
Fleetwood Owners Club
Join Date: Jul 2021
Location: Show Low, AZ
Posts: 3
sorry it ha taken me so long to get back to this. Family emergency took priority.
Yes the belt it on and tight. do not see two belts. no to the power brakes working. full of fluid. When I drove it there was absolutely no power steering and not a sound from the belt nor pump. No brakes to speak of. Drove like a tank. This RV sat for years without being moved and I doubt it started and ran for years. So things may well be gummed up.
I am thinking about pulling the steering lined and seeing if the pump works. Then checking the steering box. I have the time and tools. But any useful advice is more than welcomed.
BC1948 is offline   Reply With Quote
Old 09-06-2022, 10:01 PM   #5
Senior Member
 
Join Date: Aug 2020
Location: Ohio
Posts: 2,009
So just guessing here.. you have an emergency or parking brake peddle in addition to regular brake peddle.. 1st thing is.. do you have auto park system ? .. I don't know.. because I don't know.. I am concerned for your safety and safety of others.. so you must chock all wheels.. rv could roll away and cause significant damage or injury.. so be careful.. chock all wheels until you find out what you are dealing with..

So.. the p/s pump is not like on a car.. the p/s pump is a hydraulic pump.. that does a lot more than just power steering.. it also uses hydraulic fluid to give you power brakes.. so hit you tube and look up gm hydroboost system.. and watch a few vids..

Now you need to look in workhorse section.. important discussions sub section.. an then down to auto park system.. and read.. also hit website autopark.com and read.. because the hydraulic pump on some rv.. powers the parking brake.. it depends on the model.. but it's up to you to investigate.. so chock all wheels until you find out..
Because the rv is too heavy.. the transmission does not have a parking pawl in trans.. so when you put in park.. a brake drum on drive shaft mounted on back of trans to keep rv from rolling.. it's not like a car.. and you just may have one that also uses the p/s pump to power the parking brake.. I don't know.. so just chock all wheels until you find out.. now members here will rightfully correct me.. and say.. when rv is off the brake will automatically engage .. but if it's been sitting and po neglected auto park system.. then the parking brake shoes may be shot.. this could kill you or someone else.. so you must be on safe side.. chock all wheels... all the time.. .

Po neglected rv and gave up on it because did not bother to maintain 3 dependant sub systems.. p/s.. hydroboost.. and auto park system.. on many old rv these systems use what you call p/s pump and use complex hydraulic valves to route the pressure where it's needed.. if po would have reached out to the many great and valuable members here.. they would have helped them to break it all down and make a great repairs..

So chock all wheels.. all the time.. I know you are tired of hearing that.. but no fear.. it seems like a lot.. but there are some very great members here for help.. and you will get some great opinions.. be careful.. almost no shops left with old timers to repair auto park system.. but.. parts are very available and easy with elbow grease to fix..
Good luck and keep us posted
__________________
2000 southwind storm, workhorse custom chassis with 7.4l vortec
donr103 is offline   Reply With Quote
Reply

Tags
power, steering



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chevy P30 Power steering and Brakes not working when put in "Drive" Thor33 Workhorse and Chevrolet Chassis Motorhome Forum 24 07-16-2021 11:49 PM
Hard steering in cold weather power steering pump location Rwbrown3 Damon 6 05-02-2021 06:39 PM
Starting to loose steering and power steering djay Class A Motorhome Discussions 3 06-16-2020 11:40 AM
Steering Stabilizer vs. Power Steering dpinvidic MH-General Discussions & Problems 15 05-09-2017 06:15 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 05:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.