Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-27-2021, 05:16 AM   #1
Member
 
Join Date: Apr 2019
Location: Ukraine
Posts: 68
Blog Entries: 1
Reduced engine power

Hope somebody can help here, my Chevrolet 8.1 has lately been sounding funny, when Iím driving, somewhere in the air intakes , sounds like a desert storm, or like rain falling on the roof, just a sort of random sound of something like that..
Then 2 days ago, I started the engine and it idled, but with nothing happening with the accelerator, then, I seen a light on Iíve never seen before, reduced engine power..
I was able to drive, but, not with my foot on accelerator, it kind of drove by itself, but at 10 mphÖ the next day she was working fine again, but, I have a feeling it might come back.. anybody any advice?

Recently, I have taken to idling the engine, and using the engine to warm up the rv.. (i do this because when I put furnace on, itís seems to me the fan drains my leisure batteries) so, I open up the vents and blast out the heatÖ Iím wondering if this and my other problem are connected ? As that funny sound seems to be inside of the air ducts.
Thanks for any help in advance
Guitarman3 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-27-2021, 07:18 AM   #2
Member
 
Retired Fire Service RVer's
Join Date: Jun 2018
Posts: 88
many people have had similar problems. Usually turns out to be the mass air flow sensor. It is located in the air filter area. Handle with care or have a technician clean it. There is a special aerosol MAF cleaner. I clean mine once as year depending on mileage.
__________________
2004 Winnebago Adventurer 35U
8.1 Workhorse
2002 Corvette
mdka99 is offline   Reply With Quote
Old 10-27-2021, 07:30 AM   #3
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 4,255
GM had bad run of fly by wire throttle bodies. Poor TPS and sticking plate that can strip servo motor gears.
I followed my friend from work to his mechanics garage, the owner knew problem before he finished the sentence.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is online now   Reply With Quote
Old 10-27-2021, 11:18 AM   #4
Junior Member
 
Join Date: Jun 2021
Posts: 8
Diesel Sludge

Ok, similar problem, different engine, we had similar symptoms leading up to shut down, it went into limp mode (10mph) intermittently, until it finally would not start. I borrowed an OBD reader, which showed fuel codes and crank sensor code (intermittently)

It was diesel sludge in my 6.5 chevy diesel, clogged up the filter, 3/4 inch of sludge in the bottom of the tank, sender unit was completely clogged, so the fuel system was not getting enough fuel.

Cleaned filter housing, replaced filter, blew fuel lines through, changed lift pump (I don't think I needed to do this), took sender unit out of tank, cleaned completely, drained tank, through the sender unit hole, scrapped as much of the sludge out with paint scraper, then used thinners to break up the rest and wipe out with tissue.

Put it all back together, hey presto, all fixed, she even accelerates uphill not

Hope this helps someone.

2002 Georgie Boy Landau
6.5 TD Chevy V8
Workhorse Chassis
narnarvish is offline   Reply With Quote
Reply

Tags
engine, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DTC P1515 - Reduced Engine Power Clay L Winnebago Industries Owner's Forum 2 08-15-2012 07:28 AM
Reduced Engine Power notice and Altitude??? Paul and Sue Workhorse and Chevrolet Chassis Motorhome Forum 3 02-09-2010 10:53 AM
Reduced Engine Power while in Cruise DriVer Workhorse and Chevrolet Chassis Motorhome Forum 2 09-24-2009 10:20 AM
Can an oil change message result in Reduced Engine Power? GLWilliams58 Workhorse and Chevrolet Chassis Motorhome Forum 21 09-12-2008 07:26 AM
Service Engine Soon / Reduced Engine Power Nonno Workhorse and Chevrolet Chassis Motorhome Forum 6 08-22-2006 11:10 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.