Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-11-2014, 10:00 AM   #1
Junior Member
 
justinnine's Avatar
 
Tiffin Owners Club
Join Date: Jul 2010
Location: West Point Ut
Posts: 29
Transmission wont shift into Reverse

My 1996 Allegro Bay P30 won't shift into reverse. I had to take it into a RV shop over a year ago be cause the park brake wouldn't hold it on any kind of incline. They fixed that but now over time it's gotten to were it won't shift from park to any gear with out really jamming it hard from park to drive. And now it won't shift into reverse. Any thoughts on how to adjust this?
justinnine is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-11-2014, 10:27 AM   #2
Senior Member
 
89sandman's Avatar
 
Join Date: May 2012
Posts: 916
sounds like your linkage is binding somewhere, need to inspect it from the trans to the shifter to see if you can find out where. could also be somewhere in your auto park.
89sandman is offline   Reply With Quote
Old 04-11-2014, 10:37 AM   #3
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 5,855
On this year P32 chassis, I found the park brake linkage was out of adjustment. There are some adjustable links on the gear selector, park brake linkage that can get out of adjustment and causes the park brake to be engaged while in reverse. If you give it gas, while in reverse, and you hear the engine straining, That tells you that the park brake is engaged. If you look at the linkage in the drivers wheel well, you will see the linkage and two small plates attached to them. There is a small hole drilled in each plate. You adjust the linkage until the holes line up and you can get a drill bit in both holes.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2014 Honda CRV toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 04-12-2014, 09:28 AM   #4
Senior Member
 
Join Date: Mar 2008
Posts: 274
gear shift lever position switch

gatraveller has probably identified the issue per above. You can email oldusedbear11@charter.net for specific instructions on fixing this problem. It is a somewhat tedious procedure but still something that most any do it yourselfer can handle.

oub
__________________
Resident AutoPark Expert
oldusedbear is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tires and Transmission Running Hot Marca Alpine Coach Owner's Forum 8 09-06-2014 09:26 AM
Ford 4R100 Transmission Question/Problem/Need Advice winnie32v Ford Motorhome Chassis Forum 9 07-07-2014 05:54 AM
Allison HT740 shift problem kawi027 Allison Transmission Forum 1 06-27-2014 12:08 PM
Arnes Shift Pad - No Lights & Dead Holiday Ram Allison Transmission Forum 2 04-02-2014 10:11 AM
Transmission Fluid - Dexron IIE or Dexron III ScottyBye Workhorse and Chevrolet Chassis Motorhome Forum 4 07-14-2013 12:02 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.