Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Workhorse and Chevrolet Chassis Motorhome Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-02-2008, 04:57 PM   #1
Senior Member
 
mountainkowboy's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Dec 2006
Location: Socal/NE Oregon
Posts: 602
I have been noticing that my brakes are making a stange noise. Not at the wheels but the pedal. It feels like my ABS is coming on or the back up booster motor. Its kinda of a whiney, howling noise and the pedal fights back. This is only at an idle and crawling along. Any thoughts?
__________________
Chuck, Ruth, with 4 legged Molly
2007 Tiffin Allegro 30DA
2011 Ranger, 1987 FLHTP
mountainkowboy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-02-2008, 04:57 PM   #2
Senior Member
 
mountainkowboy's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Dec 2006
Location: Socal/NE Oregon
Posts: 602
I have been noticing that my brakes are making a stange noise. Not at the wheels but the pedal. It feels like my ABS is coming on or the back up booster motor. Its kinda of a whiney, howling noise and the pedal fights back. This is only at an idle and crawling along. Any thoughts?
__________________
Chuck, Ruth, with 4 legged Molly
2007 Tiffin Allegro 30DA
2011 Ranger, 1987 FLHTP
mountainkowboy is offline   Reply With Quote
Old 01-03-2008, 05:57 AM   #3
iRV2 Sponsor
 
Redlands Truck and RV's Avatar
 
Join Date: Nov 2006
Location: Redlands, Ca
Posts: 136
mountainkowboy,

If you have an 05 Workhorse W Chassis it should be hydraulic brakes and under warranty. Give us a call and we will be happy to take care of it for you.

Thanks,
__________________
Keith Shomaker
Redlands Truck and RV
888.249.0124
Redlands Truck and RV is offline   Reply With Quote
Old 01-03-2008, 06:19 AM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: Aug 2007
Posts: 480
I have just noticed (actually my wife did since here ears still function welll! ) while coming to a stop I hear a high pitched squeal that sounds like a "normal" brake squeal. The funny thing is that it continues past when I am stopped and until I let go of the brake pedal. Anyone have any ideas on that?
Joe
__________________
Joe & Sherri
2004 Winnebago Adventurer 37B
UltraPower
JWatkins is offline   Reply With Quote
Old 01-03-2008, 11:44 AM   #5
Senior Member
 
Workhorse Chassis Owner
Join Date: Dec 2001
Posts: 985
December 03, 2007 10:09 PM Hide Post
quote:
Originally posted by oemtech:
"They have closed the original investigation (PE07032)and opened a new engineering evaluation."
jdsr stated: If you own a wh w20 or w22 this needs to be reported to the nhtsa whether its under warr or not. dont just let a wh ser center fix it and not report it. I wonder why that ser center didnt mention this. I wonder how many brakes are being fixed and not reported.
__________________
2004 adventurer/22.5 workhorse....
jdsr is offline   Reply With Quote
Old 01-03-2008, 04:34 PM   #6
Senior Member
 
Full-Timers's Avatar
 
Workhorse Chassis Owner
Rexhall Owners Group
Join Date: Feb 2003
Location: Everywhere,USA
Posts: 1,462
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by JWatkins:
I have just noticed (actually my wife did since here ears still function welll! ) while coming to a stop I hear a high pitched squeal that sounds like a "normal" brake squeal. The funny thing is that it continues past when I am stopped and until I let go of the brake pedal. Anyone have any ideas on that?
Joe </div></BLOCKQUOTE>This is normal for the Workhorse chassis.
__________________
Full-Timers
in a
2003 Rexhall Aerbus 3550BSL
W22 Workhorse
Full-Timers is offline   Reply With Quote
Old 01-03-2008, 05:33 PM   #7
Senior Member
 
Join Date: Nov 2005
Posts: 3,941
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by JWatkins:
I have just noticed (actually my wife did since here ears still function welll! ) while coming to a stop I hear a high pitched squeal that sounds like a "normal" brake squeal. The funny thing is that it continues past when I am stopped and until I let go of the brake pedal. Anyone have any ideas on that?
Joe </div></BLOCKQUOTE>

Joe,

The hydroboost unit will squeal like that at times and it is a normal condition on both Workhorse and Ford chassis. The newer chassis have an electric brake booster that helps you stop if the engine stalls. You will hear this electric pump whine or squeal at times depending on the temperature etc.

If you or your wife feel there is reason to be concerned have it checked immediatly otherwise have them verify the hydroboost during you next maintenance stop.
__________________
Neil V
2001 Winnebago Adventurer WFG35U
NeilV is offline   Reply With Quote
Old 01-03-2008, 08:48 PM   #8
Senior Member
 
Workhorse Chassis Owner
Join Date: Aug 2007
Posts: 480
Thanks NeilV and FullTimers! That takes a load off. I am planning on setting up a appt. with WH to just have a good go-over on my coach since it is new to me. I will mention the HydroBoost issue.
Joe
__________________
Joe & Sherri
2004 Winnebago Adventurer 37B
UltraPower
JWatkins is offline   Reply With Quote
Old 01-04-2008, 05:37 PM   #9
Senior Member
 
mountainkowboy's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Dec 2006
Location: Socal/NE Oregon
Posts: 602
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Redlands Truck and RV:
mountainkowboy,

If you have an 05 Workhorse W Chassis it should be hydraulic brakes and under warranty. Give us a call and we will be happy to take care of it for you.

Thanks, </div></BLOCKQUOTE>

Thanks, I have never had ANY issues with the brakes, it has been this way since new. It only does it at an idle and at a crawl. I would hate to bring it in for nothing. It has no problems stopping, maybe it the electric brake booster.
__________________
Chuck, Ruth, with 4 legged Molly
2007 Tiffin Allegro 30DA
2011 Ranger, 1987 FLHTP
mountainkowboy is offline   Reply With Quote
Old 02-29-2008, 06:08 PM   #10
Senior Member
 
mountainkowboy's Avatar
 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Dec 2006
Location: Socal/NE Oregon
Posts: 602
Well just got back from Redlands Truck and RV and couldnt be happier! The "brake" issue was an un-seated ABS sensor that was causing the ABS to freakout at low speeds. We also got the front end re-aligned to there specs..............what a difference that made. The people at Redlands are top-notch in my book!
__________________
Chuck, Ruth, with 4 legged Molly
2007 Tiffin Allegro 30DA
2011 Ranger, 1987 FLHTP
mountainkowboy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated! Mayberry Campground Oct. 31 - Nov. 2, 2008-Updated! diandtom Southeast Region 174 11-04-2008 01:46 PM
Another brake question TXredfish Workhorse and Chevrolet Chassis Motorhome Forum 43 05-14-2008 11:43 AM
Brake Question Mike Bowman Workhorse and Chevrolet Chassis Motorhome Forum 16 03-11-2008 03:40 PM
Toad Brake question RonNBama Monaco Owner's Forum 15 01-16-2008 06:38 PM
Brake Buddy Question Toads and Motorhome Related Towing 9 10-27-2007 05:28 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.